aboutsummaryrefslogtreecommitdiff
path: root/textproc/gladtex
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-03-07 20:04:30 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-03-07 20:04:30 +0000
commit6e20cdaa4f95e50e1f86e196f963d1edf0851472 (patch)
tree7c42518a1aced8eb57c20fc4a412598721abe28b /textproc/gladtex
parent7ca7352dcabd1fd67df90344f887563637ee7906 (diff)
- Update to 1.3
- Trim Makefile header - Remove any ABI version number from LIB_DEPENDS - Remove Author field in pkg-descr
Notes
Notes: svn path=/head/; revision=313603
Diffstat (limited to 'textproc/gladtex')
-rw-r--r--textproc/gladtex/Makefile22
-rw-r--r--textproc/gladtex/distinfo4
-rw-r--r--textproc/gladtex/files/patch-Makefile2
-rw-r--r--textproc/gladtex/files/patch-eqn2img.c10
-rw-r--r--textproc/gladtex/pkg-descr3
5 files changed, 18 insertions, 23 deletions
diff --git a/textproc/gladtex/Makefile b/textproc/gladtex/Makefile
index 694c1d162b23..2498342a0222 100644
--- a/textproc/gladtex/Makefile
+++ b/textproc/gladtex/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: gladtex
-# Date created: 2006-02-04
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= gladtex
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
+PORTREVISION= 0
CATEGORIES= textproc math www
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,23 +13,23 @@ COMMENT= A program to replace LaTeX formulas in HTML files with images
LICENSE= GPLv2
-LIB_DEPENDS= gif.5:${PORTSDIR}/graphics/giflib \
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
dvips:${PORTSDIR}/print/dvipsk-tetex
-USE_PERL5= yes
-
BINPATH= ${PREFIX}/bin
-INCPATH= -I${LOCALBASE}/include
-LIBPATH= -L${LOCALBASE}/lib
+INCPATH= "-I${LOCALBASE}/include"
+LIBPATH= "-L${LOCALBASE}/lib"
-MAKE_ENV+= BINPATH=${BINPATH} INCPATH="${INCPATH}" LIBPATH=${LIBPATH}
+MAKE_ENV+= BINPATH=${BINPATH} INCPATH="${INCPATH}" LIBPATH="${LIBPATH}"
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1
.endif
+USE_PERL5= yes
+
do-install:
@cd ${WRKSRC}; \
${INSTALL_SCRIPT} ${PORTNAME} ${BINPATH}; \
diff --git a/textproc/gladtex/distinfo b/textproc/gladtex/distinfo
index 284e06e11aef..02231e3ba24b 100644
--- a/textproc/gladtex/distinfo
+++ b/textproc/gladtex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gladtex-1.2.tar.gz) = ecb9a524e0fbbaeecff2c66f59a5ad7dbaea45fc3d554af15dbd12b041a45a61
-SIZE (gladtex-1.2.tar.gz) = 20210
+SHA256 (gladtex-1.3.tar.gz) = 276cf10f57a0fd28354a9494e76befe9c3b088e9ff873336ad82811e49e0b192
+SIZE (gladtex-1.3.tar.gz) = 153600
diff --git a/textproc/gladtex/files/patch-Makefile b/textproc/gladtex/files/patch-Makefile
index 62033e295e74..ba6f45cc4daa 100644
--- a/textproc/gladtex/files/patch-Makefile
+++ b/textproc/gladtex/files/patch-Makefile
@@ -10,7 +10,7 @@
-CC = gcc -O2 -DGIF
-LIB = -lm -lz -lgif -lpng
-+CC = gcc
++CC ?= gcc
+CFLAGS+= -DGIF ${INCPATH}
+LIB = -lm -lz ${LIBPATH} -lgif -lpng
OBJ = eqn2img.o
diff --git a/textproc/gladtex/files/patch-eqn2img.c b/textproc/gladtex/files/patch-eqn2img.c
index 321948086d70..c71ea7f5dc9d 100644
--- a/textproc/gladtex/files/patch-eqn2img.c
+++ b/textproc/gladtex/files/patch-eqn2img.c
@@ -1,5 +1,5 @@
---- eqn2img.c.orig 2010-07-31 17:30:20.000000000 +0200
-+++ eqn2img.c 2012-05-06 15:41:55.000000000 +0200
+--- ./eqn2img.c.orig 2013-03-07 15:44:58.000000000 +0100
++++ ./eqn2img.c 2013-03-07 15:47:58.000000000 +0100
@@ -367,7 +367,7 @@
info_ptr = png_create_info_struct(png_ptr);
assert(info_ptr);
@@ -21,9 +21,9 @@
@@ -715,7 +715,7 @@
fprintf(stderr, " -> ps");
- cmd = NEW(char, 2*strlen(basename) + 38);
-- sprintf(cmd, "dvips -E -o %s.ps %s.dvi > /dev/null 2>&1", basename, basename);
-+ sprintf(cmd, "dvips -q -E -o %s.ps %s.dvi > /dev/null 2>&1", basename, basename);
+ cmd = NEW(char, 2*strlen(basename) + 46);
+- sprintf(cmd, "dvips -E -o %s.ps %s.dvi > /dev/null 2> /dev/null", basename, basename);
++ sprintf(cmd, "dvips -q -E -o %s.ps %s.dvi > /dev/null 2> /dev/null", basename, basename);
if(system(cmd)) {
fprintf(stderr, "\nError running dvips\n");
return -1;
diff --git a/textproc/gladtex/pkg-descr b/textproc/gladtex/pkg-descr
index 3f117b447682..bc77b078e154 100644
--- a/textproc/gladtex/pkg-descr
+++ b/textproc/gladtex/pkg-descr
@@ -1,5 +1,4 @@
Gladtex reads a 'htex' file (html with LaTeX maths embedded in <EQ></EQ>)
and produces html with equations substituted by images.
-Author: Martin G. Gulbrandsen
-WWW: http://ans.hsh.no/home/mgg/gladtex/index.html
+WWW: http://gladtex.sourceforge.net/