aboutsummaryrefslogtreecommitdiff
path: root/textproc/gmetadom
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-19 00:32:09 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-19 00:32:09 +0000
commit2f04f83e28cca0d1e6f4de113e0aa09094949137 (patch)
tree0130a78c67d5c2783cc83dde5a1946e68ca00921 /textproc/gmetadom
parentba8df2c25601c875266bd609da55a6fa17ff40f0 (diff)
downloadports-2f04f83e28cca0d1e6f4de113e0aa09094949137.tar.gz
ports-2f04f83e28cca0d1e6f4de113e0aa09094949137.zip
- install pkg-config .pc file to the correct place
- bump PORTREVISION PR: 52140 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=81312
Diffstat (limited to 'textproc/gmetadom')
-rw-r--r--textproc/gmetadom/Makefile21
-rw-r--r--textproc/gmetadom/pkg-plist4
2 files changed, 13 insertions, 12 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index 4a05b656b45c..d70f72230172 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gmetadom
PORTVERSION= 0.1.7
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +16,18 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Collection of DOM Implementations
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- xslt.1:${PORTSDIR}/textproc/libxslt \
- gdome.7:${PORTSDIR}/textproc/gdome2 \
- iconv.3:${PORTSDIR}/converters/libiconv
+BUILD_DEPENDS= ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
+ pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ocamlc:${PORTSDIR}/lang/ocaml
+LIB_DEPENDS= gdome.7:${PORTSDIR}/textproc/gdome2
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
-USE_GNOME= glib12
-USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= glib12 gnomehack libxslt
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/textproc/gmetadom/pkg-plist b/textproc/gmetadom/pkg-plist
index 4635e1606397..80207a778260 100644
--- a/textproc/gmetadom/pkg-plist
+++ b/textproc/gmetadom/pkg-plist
@@ -147,10 +147,10 @@ lib/ocaml/gdome2/tProcessingInstruction.cmi
lib/ocaml/gdome2/tProcessingInstruction.mli
lib/ocaml/gdome2/tText.cmi
lib/ocaml/gdome2/tText.mli
-lib/ocaml/stublibs/dllmlgdome.so.owner
lib/ocaml/stublibs/dllmlgdome.so
+lib/ocaml/stublibs/dllmlgdome.so.owner
lib/ocaml/stublibs/libmlgdome.so
-lib/pkgconfig/gdome2-cpp-smart.pc
+libdata/pkgconfig/gdome2-cpp-smart.pc
@dirrm include/gmetadom/gdome_cpp_smart
@dirrm include/gmetadom
@dirrm lib/ocaml/gdome2