aboutsummaryrefslogtreecommitdiff
path: root/textproc/gmetadom
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-23 05:22:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-23 05:22:13 +0000
commitbc7316915f139d3f2cbbdaa0fe4ac80732083621 (patch)
tree34536e41ec7a9d9b901614d373cf2147af8e65af /textproc/gmetadom
parentd22a5789cc5074f0182008e6f8fc64d347bb2898 (diff)
downloadports-bc7316915f139d3f2cbbdaa0fe4ac80732083621.tar.gz
ports-bc7316915f139d3f2cbbdaa0fe4ac80732083621.zip
textproc/gmetadom: Add USES=compiler:c++11-lang
This is necessary to fix the build of x11-toolkits/gtkmathview on GCC-based architectures. While here, add USES=gnome localbase. PR: 235937 Submitted by: pkubaj@anongoth.pl
Notes
Notes: svn path=/head/; revision=493641
Diffstat (limited to 'textproc/gmetadom')
-rw-r--r--textproc/gmetadom/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/textproc/gmetadom/Makefile b/textproc/gmetadom/Makefile
index 58e644226b1e..dd19876981d9 100644
--- a/textproc/gmetadom/Makefile
+++ b/textproc/gmetadom/Makefile
@@ -12,12 +12,11 @@ COMMENT= Collection of DOM Implementations
LIB_DEPENDS= libgdome.so:textproc/gdome2
-USES= gmake iconv libtool pathfix pkgconfig
+USES= compiler:c++11-lang gmake gnome iconv libtool localbase \
+ pathfix pkgconfig
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= OCAML