aboutsummaryrefslogtreecommitdiff
path: root/textproc/go-text
diff options
context:
space:
mode:
authorGrzegorz Blach <gblach@FreeBSD.org>2013-08-17 15:49:21 +0000
committerGrzegorz Blach <gblach@FreeBSD.org>2013-08-17 15:49:21 +0000
commit1efda898713d26e4c18ed430b9bd2384ccb73ea5 (patch)
tree8cc7cc38e09f192d3e20a811817a44ebfaf59cfc /textproc/go-text
parentec9133b75e66401e101d82fb8f0a039f7537ff08 (diff)
downloadports-1efda898713d26e4c18ed430b9bd2384ccb73ea5.tar.gz
ports-1efda898713d26e4c18ed430b9bd2384ccb73ea5.zip
Notes
Diffstat (limited to 'textproc/go-text')
-rw-r--r--textproc/go-text/Makefile23
-rw-r--r--textproc/go-text/distinfo2
-rw-r--r--textproc/go-text/pkg-descr4
-rw-r--r--textproc/go-text/pkg-plist7
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/go-text/Makefile b/textproc/go-text/Makefile
new file mode 100644
index 000000000000..1cb94ddf8791
--- /dev/null
+++ b/textproc/go-text/Makefile
@@ -0,0 +1,23 @@
+# Created by: Grzegorz Blach <gblach@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= go-text
+PORTVERSION= 20130502
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/gblach/
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Go package for manipulating paragraphs of text
+
+SUBLIBDIR= github.com/kr
+GO_PKGNAME= ${SUBLIBDIR}/text
+
+do-install:
+ ${MKDIR} ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${INSTALL_DATA} ${GO_WRKDIR_PKG}/${SUBLIBDIR}/text.a ${GO_LOCAL_LIBDIR}/${SUBLIBDIR}
+ ${MKDIR} ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
+ ${INSTALL_DATA} ${GO_WRKSRC}/indent.go ${GO_LOCAL_SRCDIR}/${GO_PKGNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/go-text/distinfo b/textproc/go-text/distinfo
new file mode 100644
index 000000000000..2f32e764eb90
--- /dev/null
+++ b/textproc/go-text/distinfo
@@ -0,0 +1,2 @@
+SHA256 (go-text-20130502.tar.gz) = 84b386efc3a51870a1e931019fac9bcb89883b287badcc48ffa29afaae9d0a18
+SIZE (go-text-20130502.tar.gz) = 9729
diff --git a/textproc/go-text/pkg-descr b/textproc/go-text/pkg-descr
new file mode 100644
index 000000000000..5a050cfbede4
--- /dev/null
+++ b/textproc/go-text/pkg-descr
@@ -0,0 +1,4 @@
+Go package which provides rudimentary functions for manipulating text
+in paragraphs.
+
+WWW: https://github.com/kr/text
diff --git a/textproc/go-text/pkg-plist b/textproc/go-text/pkg-plist
new file mode 100644
index 000000000000..4597e10000c2
--- /dev/null
+++ b/textproc/go-text/pkg-plist
@@ -0,0 +1,7 @@
+%%GO_LIBDIR%%/github.com/kr/text.a
+%%GO_SRCDIR%%/github.com/kr/text/indent.go
+@dirrmtry %%GO_LIBDIR%%/github.com/kr
+@dirrmtry %%GO_LIBDIR%%/github.com
+@dirrm %%GO_SRCDIR%%/github.com/kr/text
+@dirrmtry %%GO_SRCDIR%%/github.com/kr
+@dirrmtry %%GO_SRCDIR%%/github.com