aboutsummaryrefslogtreecommitdiff
path: root/textproc/goldendict
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-07-17 17:24:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-07-17 17:24:41 +0000
commit0820bff51b490de653f8197ea5386265c92266e6 (patch)
tree30584bb2e338e565a892a4ef992cdea993c3217d /textproc/goldendict
parentee03ae3ca0226920790f38d1931057d3e86a4dc2 (diff)
downloadports-0820bff51b490de653f8197ea5386265c92266e6.tar.gz
ports-0820bff51b490de653f8197ea5386265c92266e6.zip
- Resurrect and update to the latest GitHub version (1.5.0-g20190709)
- Allow for more granular builds by introducing EPWING (Japanese dictionary format support), FFMPEG, and OPENCC (Chinese conversion support) options; enable them by default for feature-rich package - Reword the COMMENT and the port description text while I'm here
Notes
Notes: svn path=/head/; revision=506808
Diffstat (limited to 'textproc/goldendict')
-rw-r--r--textproc/goldendict/Makefile48
-rw-r--r--textproc/goldendict/distinfo3
-rw-r--r--textproc/goldendict/pkg-descr7
-rw-r--r--textproc/goldendict/pkg-plist42
4 files changed, 100 insertions, 0 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
new file mode 100644
index 000000000000..7a6cde0fbb24
--- /dev/null
+++ b/textproc/goldendict/Makefile
@@ -0,0 +1,48 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= goldendict
+DISTVERSION= 1.5.0-g20190709
+CATEGORIES= textproc
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= Feature-rich dictionary lookup program
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
+ liblzo2.so:archivers/lzo2 \
+ libvorbis.so:audio/libvorbis
+
+USES= compiler:c++11-lang gnome iconv:wchar_t pkgconfig \
+ qmake qt:5
+USE_GITHUB= yes
+GH_TAGNAME= 05bfc35
+USE_XORG= xtst
+USE_QT= buildtools_build linguisttools_build core gui help \
+ multimedia network printsupport sql svg webkit widgets \
+ x11extras xml
+INSTALLS_ICONS= yes
+QMAKE_ARGS= ${PORTNAME}.pro CONFIG+="zim_support"
+
+OPTIONS_DEFINE= EPWING FFMPEG OPENCC
+OPTIONS_DEFAULT= EPWING FFMPEG OPENCC
+
+EPWING_DESC= Japanese EPWING dictionary format support
+EPWING_LIB_DEPENDS= libeb.so:japanese/eb
+EPWING_QMAKE_OFF= CONFIG+="no_epwing_support"
+
+FFMPEG_LIB_DEPENDS= libao.so:audio/libao \
+ libavutil.so:multimedia/ffmpeg
+FFMPEG_QMAKE_OFF= CONFIG+="no_ffmpeg_player"
+
+OPENCC_DESC= Chinese conversion support via OpenCC
+OPENCC_LIB_DEPENDS= libopencc.so:chinese/opencc
+OPENCC_QMAKE_ON= CONFIG+="chinese_conversion_support"
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/locale
+ ${INSTALL_DATA} ${WRKSRC}/locale/*.qm ${STAGEDIR}${DATADIR}/locale
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/textproc/goldendict/distinfo b/textproc/goldendict/distinfo
new file mode 100644
index 000000000000..2b78c678e0d8
--- /dev/null
+++ b/textproc/goldendict/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1562684423
+SHA256 (goldendict-goldendict-1.5.0-g20190709-05bfc35_GH0.tar.gz) = 44e99110caec5edb942119459e49754a9ffaa6677eda983e94873f0e65bdfbda
+SIZE (goldendict-goldendict-1.5.0-g20190709-05bfc35_GH0.tar.gz) = 18694740
diff --git a/textproc/goldendict/pkg-descr b/textproc/goldendict/pkg-descr
new file mode 100644
index 000000000000..f4ed5f736e85
--- /dev/null
+++ b/textproc/goldendict/pkg-descr
@@ -0,0 +1,7 @@
+A feature-rich dictionary lookup program, supporting multiple dictionary
+formats (StarDict/Babylon/Lingvo/Dictd) and online dictionaries, featuring
+perfect article rendering with the complete markup, illustrations and other
+content retained, and allowing you to type in words without any accents or
+correct case.
+
+WWW: http://goldendict.org/
diff --git a/textproc/goldendict/pkg-plist b/textproc/goldendict/pkg-plist
new file mode 100644
index 000000000000..6f87f9c17ceb
--- /dev/null
+++ b/textproc/goldendict/pkg-plist
@@ -0,0 +1,42 @@
+bin/goldendict
+share/applications/goldendict.desktop
+share/metainfo/goldendict.appdata.xml
+share/pixmaps/goldendict.png
+%%DATADIR%%/help/gdhelp_en.qch
+%%DATADIR%%/help/gdhelp_ru.qch
+%%DATADIR%%/locale/ar_SA.qm
+%%DATADIR%%/locale/ay_WI.qm
+%%DATADIR%%/locale/be_BY.qm
+%%DATADIR%%/locale/be_BY@latin.qm
+%%DATADIR%%/locale/bg_BG.qm
+%%DATADIR%%/locale/cs_CZ.qm
+%%DATADIR%%/locale/de_DE.qm
+%%DATADIR%%/locale/el_GR.qm
+%%DATADIR%%/locale/eo_EO.qm
+%%DATADIR%%/locale/es_AR.qm
+%%DATADIR%%/locale/es_BO.qm
+%%DATADIR%%/locale/es_ES.qm
+%%DATADIR%%/locale/fa_IR.qm
+%%DATADIR%%/locale/fi_FI.qm
+%%DATADIR%%/locale/fr_FR.qm
+%%DATADIR%%/locale/it_IT.qm
+%%DATADIR%%/locale/ja_JP.qm
+%%DATADIR%%/locale/ko_KR.qm
+%%DATADIR%%/locale/lt_LT.qm
+%%DATADIR%%/locale/mk_MK.qm
+%%DATADIR%%/locale/nl_NL.qm
+%%DATADIR%%/locale/pl_PL.qm
+%%DATADIR%%/locale/pt_BR.qm
+%%DATADIR%%/locale/qu_WI.qm
+%%DATADIR%%/locale/ru_RU.qm
+%%DATADIR%%/locale/sk_SK.qm
+%%DATADIR%%/locale/sq_AL.qm
+%%DATADIR%%/locale/sr_SR.qm
+%%DATADIR%%/locale/sv_SE.qm
+%%DATADIR%%/locale/tg_TJ.qm
+%%DATADIR%%/locale/tk_TM.qm
+%%DATADIR%%/locale/tr_TR.qm
+%%DATADIR%%/locale/uk_UA.qm
+%%DATADIR%%/locale/vi_VN.qm
+%%DATADIR%%/locale/zh_CN.qm
+%%DATADIR%%/locale/zh_TW.qm