aboutsummaryrefslogtreecommitdiff
path: root/textproc/goldendict
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-21 03:55:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-01-21 03:55:54 +0000
commit47a2987e5d0cfbd093cf935ab48358278e08b247 (patch)
tree4e9440bdec2aaf58d50df24a580acaac115ec03a /textproc/goldendict
parent79f65a7cc1ed942a7124ef134d0b66c49723a4e4 (diff)
downloadports-47a2987e5d0cfbd093cf935ab48358278e08b247.tar.gz
ports-47a2987e5d0cfbd093cf935ab48358278e08b247.zip
- Update to the latest GitHub snapshot
- Adjust LICENSE and set LICENSE_FILE - Make Qt multimedia player optional - Add missing LIB_DEPENDS and USE_XORG - Report Git hash in the About dialog
Notes
Notes: svn path=/head/; revision=562174
Diffstat (limited to 'textproc/goldendict')
-rw-r--r--textproc/goldendict/Makefile32
-rw-r--r--textproc/goldendict/distinfo8
-rw-r--r--textproc/goldendict/files/patch-sptr.hh12
-rw-r--r--textproc/goldendict/pkg-plist2
4 files changed, 28 insertions, 26 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index a56337fa8b3a..c14c45ef6deb 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -2,32 +2,35 @@
# $FreeBSD$
PORTNAME= goldendict
-DISTVERSION= 1.5.0-g20190709
-PORTREVISION= 2
+DISTVERSION= 1.5.0-g20210115
CATEGORIES= textproc
MAINTAINER= bsam@FreeBSD.org
COMMENT= Feature-rich dictionary lookup program
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
liblzo2.so:archivers/lzo2 \
- libvorbis.so:audio/libvorbis
+ libogg.so:audio/libogg \
+ libtiff.so:graphics/tiff \
+ libvorbis.so:audio/libvorbis \
+ libzstd.so:archivers/zstd
USES= compiler:c++11-lang gnome iconv:wchar_t pkgconfig \
qmake qt:5 xorg
USE_GITHUB= yes
-GH_TAGNAME= 05bfc35
-USE_XORG= xtst
+GH_TAGNAME= 73ec1b5
+USE_XORG= x11 xtst
USE_QT= buildtools_build linguisttools_build core gui help \
- multimedia network printsupport sql svg webkit widgets \
+ network printsupport sql svg webkit widgets \
x11extras xml
INSTALLS_ICONS= yes
QMAKE_ARGS= ${PORTNAME}.pro CONFIG+="zim_support"
-OPTIONS_DEFINE= EPWING FFMPEG OPENCC
-OPTIONS_DEFAULT= EPWING FFMPEG OPENCC
+OPTIONS_DEFINE= EPWING FFMPEG MULTIMEDIA OPENCC
+OPTIONS_DEFAULT= EPWING FFMPEG MULTIMEDIA OPENCC
EPWING_DESC= Japanese EPWING dictionary format support
EPWING_LIB_DEPENDS= libeb.so:japanese/eb
@@ -37,13 +40,24 @@ FFMPEG_LIB_DEPENDS= libao.so:audio/libao \
libavutil.so:multimedia/ffmpeg
FFMPEG_QMAKE_OFF= CONFIG+="no_ffmpeg_player"
+MULTIMEDIA_DESC= Multimedia support with QMediaPlayer
+MULTIMEDIA_USE= QT=multimedia
+MULTIMEDIA_QMAKE_OFF= CONFIG+="no_qtmultimedia_player"
+
OPENCC_DESC= Chinese conversion support via OpenCC
OPENCC_LIB_DEPENDS= libopencc.so:chinese/opencc
OPENCC_QMAKE_ON= CONFIG+="chinese_conversion_support"
+post-patch:
+ @${REINPLACE_CMD} -e '/^VERSION = /s,git,&${GH_TAGNAME},' \
+ ${WRKSRC}/goldendict.pro
+
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/locale
${INSTALL_DATA} ${WRKSRC}/locale/*.qm ${STAGEDIR}${DATADIR}/locale
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+post-stage:
+ ${RM} ${STAGEDIR}${PREFIX}/share/applications/ecp.*
+
.include <bsd.port.mk>
diff --git a/textproc/goldendict/distinfo b/textproc/goldendict/distinfo
index 0054f3bb63b1..068179b29531 100644
--- a/textproc/goldendict/distinfo
+++ b/textproc/goldendict/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1606837559
-SHA256 (goldendict-goldendict-1.5.0-g20190709-05bfc35_GH0.tar.gz) = 44e99110caec5edb942119459e49754a9ffaa6677eda983e94873f0e65bdfbda
-SIZE (goldendict-goldendict-1.5.0-g20190709-05bfc35_GH0.tar.gz) = 18694740
-SHA256 (f905b93de5386284166588ac1f05383af9aa1d2e.patch) = 0ee620a8bf7410f8d05e940c3dff884aa0fc09e79b67a2e49f247b734ff4d8be
-SIZE (f905b93de5386284166588ac1f05383af9aa1d2e.patch) = 590
+TIMESTAMP = 1610723742
+SHA256 (goldendict-goldendict-1.5.0-g20210115-73ec1b5_GH0.tar.gz) = 48fc218976bd173418741b862d55b50c6f8bd6434cf586bb13e9786290bfcb64
+SIZE (goldendict-goldendict-1.5.0-g20210115-73ec1b5_GH0.tar.gz) = 20210581
diff --git a/textproc/goldendict/files/patch-sptr.hh b/textproc/goldendict/files/patch-sptr.hh
deleted file mode 100644
index 23dcb67ba623..000000000000
--- a/textproc/goldendict/files/patch-sptr.hh
+++ /dev/null
@@ -1,12 +0,0 @@
---- sptr.hh.orig 2020-11-23 20:39:45 UTC
-+++ sptr.hh
-@@ -67,9 +67,6 @@ class sptr_base (public)
- }
- }
-
-- unsigned use_count() const
-- { return count; }
--
- sptr_base & operator = ( sptr_base const & other )
- { if ( &other != this ) { reset(); p = other.p; count = other.count; increment(); }
- return * this; }
diff --git a/textproc/goldendict/pkg-plist b/textproc/goldendict/pkg-plist
index 6f87f9c17ceb..543131623a22 100644
--- a/textproc/goldendict/pkg-plist
+++ b/textproc/goldendict/pkg-plist
@@ -19,8 +19,10 @@ share/pixmaps/goldendict.png
%%DATADIR%%/locale/fa_IR.qm
%%DATADIR%%/locale/fi_FI.qm
%%DATADIR%%/locale/fr_FR.qm
+%%DATADIR%%/locale/ie_001.qm
%%DATADIR%%/locale/it_IT.qm
%%DATADIR%%/locale/ja_JP.qm
+%%DATADIR%%/locale/jb_JB.qm
%%DATADIR%%/locale/ko_KR.qm
%%DATADIR%%/locale/lt_LT.qm
%%DATADIR%%/locale/mk_MK.qm