aboutsummaryrefslogtreecommitdiff
path: root/textproc/goldendict
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-12 13:33:00 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-12 13:33:00 +0000
commitd732440950c938043bcc7b4bdfb1708c7a9e47f3 (patch)
treef02d9341fff763d9d7bc69d46c7057ba75468f11 /textproc/goldendict
parent283993719c2e005aa137f370f01dc4e94760d37c (diff)
downloadports-d732440950c938043bcc7b4bdfb1708c7a9e47f3.tar.gz
ports-d732440950c938043bcc7b4bdfb1708c7a9e47f3.zip
1. Fix build with clang and libc++ (3 cases, add "#include <unistd.h>" to
apropriate files): ----- bgl_babylon.cc:97:19: error: use of undeclared identifier 'dup' file = gzdopen( DUP( fileno( f ) ), "r" ); ^ bgl_babylon.cc:36:13: note: expanded from macro 'DUP' #define DUP dup ^ ----- processwrapper.cc:99:12: error: use of undeclared identifier 'getpid' return getpid(); ^ ----- qtsingleapplication/src/qtlocalpeer.cpp:96:56: error: no member named 'getuid' in the global namespace socketName += QLatin1Char('-') + QString::number(::getuid(), 16); ~~^ ----- 2. Use new syntax for LIB_DEPENDS.
Notes
Notes: svn path=/head/; revision=327062
Diffstat (limited to 'textproc/goldendict')
-rw-r--r--textproc/goldendict/Makefile7
-rw-r--r--textproc/goldendict/files/patch-bgl_babylon.cc8
-rw-r--r--textproc/goldendict/files/patch-processwrapper.cc9
-rw-r--r--textproc/goldendict/files/patch-qtsingleapplication-src-qtlocalpeer.cpp10
4 files changed, 31 insertions, 3 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index 217432748365..eafaf70349cd 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -13,14 +13,15 @@ COMMENT= Feature-rich Qt4 based dictionary lookup program
LICENSE= GPLv3
-LIB_DEPENDS= hunspell-1.3:${PORTSDIR}/textproc/hunspell \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
NO_WRKSUBDIR= yes
HAS_CONFIGURE= yes
USES= desktop-file-utils pkgconfig
+USE_DOS2UNIX= processwrapper.cc # is needed only to apply a patch to this file
USE_XORG= xtst
USE_QT4= corelib gui webkit phonon \
qmake_build linguist_build moc_build rcc_build script_build uic_build
diff --git a/textproc/goldendict/files/patch-bgl_babylon.cc b/textproc/goldendict/files/patch-bgl_babylon.cc
index b74ba732f90f..fc170af97e0d 100644
--- a/textproc/goldendict/files/patch-bgl_babylon.cc
+++ b/textproc/goldendict/files/patch-bgl_babylon.cc
@@ -1,5 +1,13 @@
--- ./bgl_babylon.cc.orig 2010-12-04 00:12:46.000000000 +0300
+++ ./bgl_babylon.cc 2010-12-28 11:46:37.203723541 +0300
+@@ -26,6 +26,7 @@
+ #include<stdlib.h>
+ #include<string.h>
+ #include<stdio.h>
++#include<unistd.h>
+ #include<iconv.h>
+ #include <QTextDocument>
+
@@ -648,13 +648,8 @@
inbufbytes = s.size();
diff --git a/textproc/goldendict/files/patch-processwrapper.cc b/textproc/goldendict/files/patch-processwrapper.cc
new file mode 100644
index 000000000000..3ae6f65b00e7
--- /dev/null
+++ b/textproc/goldendict/files/patch-processwrapper.cc
@@ -0,0 +1,9 @@
+--- ./processwrapper.cc.orig 2013-09-12 13:03:02.450955685 +0400
++++ ./processwrapper.cc 2013-09-12 13:04:34.115949039 +0400
+@@ -1,5 +1,6 @@
+ #include "processwrapper.hh"
+
++#include <unistd.h>
+ #include <QtCore>
+
+ #ifdef Q_OS_WIN32
diff --git a/textproc/goldendict/files/patch-qtsingleapplication-src-qtlocalpeer.cpp b/textproc/goldendict/files/patch-qtsingleapplication-src-qtlocalpeer.cpp
new file mode 100644
index 000000000000..7b11ff12f01a
--- /dev/null
+++ b/textproc/goldendict/files/patch-qtsingleapplication-src-qtlocalpeer.cpp
@@ -0,0 +1,10 @@
+--- qtsingleapplication/src/qtlocalpeer.cpp.orig 2013-09-12 13:40:34.269802688 +0400
++++ qtsingleapplication/src/qtlocalpeer.cpp 2013-09-12 13:41:07.606795170 +0400
+@@ -50,6 +50,7 @@
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {