aboutsummaryrefslogtreecommitdiff
path: root/textproc/groff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-04-16 04:23:23 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-04-16 04:23:23 +0000
commit253fbf52523e05b5ef2a5a54b620dd17ce9cc0b4 (patch)
treecbf460d411c5557da0762cc23fdebf5c3b5098ac /textproc/groff
parentb6c7e744115673fca722d687edb11aa55f692066 (diff)
downloadports-253fbf52523e05b5ef2a5a54b620dd17ce9cc0b4.tar.gz
ports-253fbf52523e05b5ef2a5a54b620dd17ce9cc0b4.zip
Add a new option URWFONTS
This options allows to disable at build time dependency on gsfonts and ghostcript, to reduce the number of dependency for minimal setup. Note that ghostscript and gsfonts are only needed at build time otherwise (mark ghostscritp as such in any case now) and they are needed for some usage of gropdf. Reported by: Zeus Panchenko <zeus@ibs.dn.ua>
Notes
Notes: svn path=/head/; revision=499075
Diffstat (limited to 'textproc/groff')
-rw-r--r--textproc/groff/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/textproc/groff/Makefile b/textproc/groff/Makefile
index 1f0508782574..ec7127c48eb3 100644
--- a/textproc/groff/Makefile
+++ b/textproc/groff/Makefile
@@ -3,6 +3,7 @@
PORTNAME= groff
PORTVERSION= 1.22.4
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= GNU
@@ -11,13 +12,12 @@ COMMENT= Software typesetting package
LICENSE= GPLv3
-BUILD_DEPENDS= gsfonts>=0:print/gsfonts \
- psselect:print/psutils
+BUILD_DEPENDS= psselect:print/psutils
RUN_DEPENDS:= psselect:print/psutils
MAKE_JOBS_UNSAFE= yes
-USES= cpe ghostscript gmake perl5 shebangfix makeinfo
+USES= cpe gmake perl5 shebangfix makeinfo
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-awk=/usr/bin/awk
CONFIGURE_ENV+= PERLPATH=${perl_CMD} # shebangfix
@@ -43,9 +43,10 @@ PAPERSIZE=A4
CONFIGURE_ENV+= PAGE=${PAPERSIZE}
.endif
-OPTIONS_DEFINE= X11
+OPTIONS_DEFINE= X11 URWFONTS
X11_DESC= X11 devices (-TX*) and gxditview
-OPTIONS_DEFAULT= X11
+URWFONTS_DESC= URW fonts support (needed for growpdf)
+OPTIONS_DEFAULT= X11 URWFONTS
CONFLICTS= ja-groff-[0-9]*
@@ -55,6 +56,10 @@ DATADIR= ${PREFIX}/share/${PORTNAME}/${PORTVERSION}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
EXAMPLESDIR= ${DOCSDIR}/examples
+URWFONTS_CONFIGURE_OFF= --without-urw-fonts-dir
+URWFONTS_USES= ghostscript:build
+URWFONTS_BUILD_DEPENDS= gsfonts>=0:print/gsfonts
+
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MX11}