aboutsummaryrefslogtreecommitdiff
path: root/textproc/gsed
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:09:32 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-08 08:09:32 +0000
commitd73388c5ad917bae8a550a1fb99ed1d132c68644 (patch)
tree8715b688d7cfb14c6bef701900bf330bcf862e3b /textproc/gsed
parent1e83f4f9ce1053a682845732664ce34adfca0639 (diff)
downloadports-d73388c5ad917bae8a550a1fb99ed1d132c68644.tar.gz
ports-d73388c5ad917bae8a550a1fb99ed1d132c68644.zip
- Fix typo in manpage
- Eliminate a patch - Respect DESTDIR PR: 101565 Submitted by: gabor (maintainer)
Notes
Notes: svn path=/head/; revision=170078
Diffstat (limited to 'textproc/gsed')
-rw-r--r--textproc/gsed/Makefile10
-rw-r--r--textproc/gsed/files/patch-lib-regex_internal.h11
2 files changed, 6 insertions, 15 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 73ee3b34bdf5..64c7d0fe5473 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sed
PORTVERSION= 4.1.5
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,11 +27,11 @@ MAN1= gsed.1
# Local variables
PATCH_SUBDIRS= . doc lib sed
-DATADIR= ${PREFIX}/share/${PKGBASE}
+DATADIR= ${TARGETDIR}/share/${PKGBASE}
SAMP_FILES= binary*.sed dc.sed
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/${PKGBASE}
PORTDOCS= AUTHORS BUGS COPYING COPYING.DOC NEWS README THANKS
-DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+DOCSDIR= ${TARGETDIR}/share/doc/${PKGBASE}
.include <bsd.port.pre.mk>
@@ -41,8 +42,9 @@ EXTRA_PATCHES= ${FILESDIR}/extrapatch-lib-regexec.c
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\* sed:,* CNU sed:,' \
+ @${REINPLACE_CMD} 's,^\* sed:,* GNU sed:,' \
${WRKSRC}/doc/config.texi
+ @${REINPLACE_CMD} "s|#include <alloca.h>||" ${WRKSRC}/lib/regex_internal.h
post-configure:
.for subdir in ${PATCH_SUBDIRS}
diff --git a/textproc/gsed/files/patch-lib-regex_internal.h b/textproc/gsed/files/patch-lib-regex_internal.h
deleted file mode 100644
index 9fc8806d6fbb..000000000000
--- a/textproc/gsed/files/patch-lib-regex_internal.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/regex_internal.h.orig Tue Feb 28 01:36:13 2006
-+++ lib/regex_internal.h Tue Feb 28 01:36:38 2006
-@@ -410,8 +410,6 @@
- #define re_string_skip_bytes(pstr,idx) ((pstr)->cur_idx += (idx))
- #define re_string_set_index(pstr,idx) ((pstr)->cur_idx = (idx))
-
--#include <alloca.h>
--
- #ifndef _LIBC
- # if HAVE_ALLOCA
- /* The OS usually guarantees only one guard page at the bottom of the stack,