aboutsummaryrefslogtreecommitdiff
path: root/textproc/highlight
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-08-20 19:07:44 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-08-20 19:07:44 +0000
commitab152d3e314f909425d16bcee08934d78f333caf (patch)
tree528547f601f47eb02f22859c0505ae1ca432fbdb /textproc/highlight
parent3cbc81d1fac22cbd24a9d9834061e17c95135434 (diff)
downloadports-ab152d3e314f909425d16bcee08934d78f333caf.tar.gz
ports-ab152d3e314f909425d16bcee08934d78f333caf.zip
Update highlight to 3.31.
Strip binary.
Notes
Notes: svn path=/head/; revision=420526
Diffstat (limited to 'textproc/highlight')
-rw-r--r--textproc/highlight/Makefile3
-rw-r--r--textproc/highlight/distinfo5
-rw-r--r--textproc/highlight/files/patch-src_makefile32
-rw-r--r--textproc/highlight/pkg-plist2
4 files changed, 30 insertions, 12 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index f907bd8090be..d1c6825233cb 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= highlight
-PORTVERSION= 3.28
+PORTVERSION= 3.31
PORTEPOCH= 2
CATEGORIES= textproc
MASTER_SITES= http://www.andre-simon.de/zip/
@@ -32,5 +32,6 @@ post-patch:
post-install:
@cd ${STAGEDIR}${PREFIX}/etc/highlight && ${MV} filetypes.conf \
filetypes.conf.sample
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/highlight
.include <bsd.port.mk>
diff --git a/textproc/highlight/distinfo b/textproc/highlight/distinfo
index 0b1e7b8efec0..818f686e1213 100644
--- a/textproc/highlight/distinfo
+++ b/textproc/highlight/distinfo
@@ -1,2 +1,3 @@
-SHA256 (highlight-3.28.tar.bz2) = 36364b6d906148dac04426a0c892fe2343e5e2c752316666589f8dff741ce7cd
-SIZE (highlight-3.28.tar.bz2) = 622161
+TIMESTAMP = 1471716553
+SHA256 (highlight-3.31.tar.bz2) = c78cdce3c8133736c3bc2f931d34cb69c09e043c9ce681251e26a9f9b19c4c6d
+SIZE (highlight-3.31.tar.bz2) = 628481
diff --git a/textproc/highlight/files/patch-src_makefile b/textproc/highlight/files/patch-src_makefile
index 3e5e726211d9..9cb44a2cf516 100644
--- a/textproc/highlight/files/patch-src_makefile
+++ b/textproc/highlight/files/patch-src_makefile
@@ -1,15 +1,15 @@
---- src/makefile.orig 2015-07-02 16:51:26.582456000 +0200
-+++ src/makefile 2015-07-02 16:51:53.706070000 +0200
+--- src/makefile.orig 2016-08-20 21:01:57.961708000 +0200
++++ src/makefile 2016-08-20 21:03:49.861494000 +0200
@@ -12,7 +12,7 @@
# See src/gui-qt/highlight.pro for the Qt GUI compilation options
--CXX=c++
-+CXX?=c++
+-CXX=g++
++CXX?=g++
- # Added -qt4 because of Arch Linux Qt5 migration
- QMAKE=qmake-qt4
-@@ -37,10 +37,10 @@
+ # was: qmake-qt5
+ QMAKE=qmake
+@@ -38,10 +38,10 @@
# If Lua 5.2 is not default on your system yet you have to
# use lua5.1 in the pkg-config calls
@@ -22,12 +22,26 @@
# luajit lib
# LUA_LIBS=$(shell pkg-config --libs luajit)
-@@ -67,7 +67,7 @@
+@@ -65,19 +65,19 @@
+ CFLAGS+=-fPIC
+ endif
+
+-LDFLAGS = -ldl
++LDFLAGS = #-ldl
+ # Do not strip by default (Mac OS X lazy pointer issues)
+ # Add -static to avoid linking with shared libs (can cause trouble when highlight
+ # is run as service)
#LDFLAGS = ${LDFLAGS} -s
#LDFLAGS= -Wl,--as-needed
-CXX_COMPILE=${CXX} ${CFLAGS} -c -I ${INCLUDE_DIR} ${LUA_CFLAGS}
-+CXX_COMPILE=${CXX} ${CFLAGS} -c -I ${INCLUDE_DIR} -I%%LOCALBASE%%/include ${LUA_CFLAGS}
++CXX_COMPILE=${CXX} ${CFLAGS} -c -I ${INCLUDE_DIR} -I/usr/local/include ${LUA_CFLAGS}
# Data directories (data dir, configuration file dir)
CXX_DIR=-DHL_DATA_DIR=\"${HL_DATA_DIR}\" -DHL_CONFIG_DIR=\"${HL_CONFIG_DIR}\"
+
+-AR=ar
++AR?=ar
+ ARFLAGS=-crs
+
+ # objects files to build the library
diff --git a/textproc/highlight/pkg-plist b/textproc/highlight/pkg-plist
index 8705e7d1dbb9..70e92a00a5b4 100644
--- a/textproc/highlight/pkg-plist
+++ b/textproc/highlight/pkg-plist
@@ -37,6 +37,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/ceylon.lang
%%DATADIR%%/langDefs/charmm.lang
%%DATADIR%%/langDefs/chill.lang
+%%DATADIR%%/langDefs/chpl.lang
%%DATADIR%%/langDefs/clean.lang
%%DATADIR%%/langDefs/clearbasic.lang
%%DATADIR%%/langDefs/clipper.lang
@@ -199,6 +200,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/xml.lang
%%DATADIR%%/langDefs/xpp.lang
%%DATADIR%%/langDefs/yaiff.lang
+%%DATADIR%%/langDefs/yaml.lang
%%DATADIR%%/langDefs/yang.lang
%%DATADIR%%/langDefs/znn.lang
%%DATADIR%%/plugins/asciidoc_html_add_links.lua