aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-citeproc-hs/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-08-03 02:30:07 +0000
commitdb8a630740d7952632fca1d12503a442fc625335 (patch)
tree8ee3a15fcf61eb9a77ce79ffe7cc567f6e56e480 /textproc/hs-citeproc-hs/Makefile
parent336cf4f81e31ae43ff7b5ec434e2305615de4392 (diff)
downloadports-db8a630740d7952632fca1d12503a442fc625335.tar.gz
ports-db8a630740d7952632fca1d12503a442fc625335.zip
Notes
Diffstat (limited to 'textproc/hs-citeproc-hs/Makefile')
-rw-r--r--textproc/hs-citeproc-hs/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/hs-citeproc-hs/Makefile b/textproc/hs-citeproc-hs/Makefile
index b6d64a29f41e..34477a87324f 100644
--- a/textproc/hs-citeproc-hs/Makefile
+++ b/textproc/hs-citeproc-hs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= citeproc-hs
PORTVERSION= 0.3.4
+PORTREVISION= 1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
@@ -16,20 +17,22 @@ LICENSE= BSD
USE_CABAL= json mtl pandoc-types>=1.8 utf8-string xml
-OPTIONS= BIBUTILS "Use Chris Putnam's Bibutils" on \
- NETWORK "Use network and HTTP to retrieve CSL file" on
+OPTIONS_DEFINE= BIBUTILS NETWORK
+OPTIONS_DEFAULT= BIBUTILS NETWORK
+
+BIBUTILS_DESC= Use Chris Putnam's Bibutils
+NETWORK_DESC= Use network and HTTP to retrieve CSL file
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
-.if defined(WITH_BIBUTILS)
+.if ${PORT_OPTIONS:MBIBUTILS}
CONFIGURE_ARGS+= --flags="bibutils"
USE_CABAL+= hs-bibutils>=0.3
.else
CONFIGURE_ARGS+= --flags="-bibutils"
.endif
-.if defined(WITH_NETWORK)
+.if ${PORT_OPTIONS:MNETWORK}
CONFIGURE_ARGS+= --flags="network"
USE_CABAL+= HTTP>=4000.0.9 network>=2
.else