aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-pandoc
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-25 18:29:57 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-25 18:29:57 +0000
commit04fe1b9af906b00d2d49103f2803187af758ba8e (patch)
tree580da5a9c06fd7908e1077d4468025d59db0da0e /textproc/hs-pandoc
parent27c3d07a6db86bac65866df3a336c680bc56ef87 (diff)
downloadports-04fe1b9af906b00d2d49103f2803187af758ba8e.tar.gz
ports-04fe1b9af906b00d2d49103f2803187af758ba8e.zip
- Update pandoc to 1.13.0.1
- Update gitit to 0.10.5 - Update texmath to 0.8 - Update zip-archive to 0.2.3.4 - Add haddock-library: Library exposing some functionality of Haddock - Add hoauth2: Haskell OAuth2 authentication - Add JuicyPixels: Picture loading/serialization Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=366123
Diffstat (limited to 'textproc/hs-pandoc')
-rw-r--r--textproc/hs-pandoc/Makefile38
-rw-r--r--textproc/hs-pandoc/distinfo4
-rw-r--r--textproc/hs-pandoc/files/patch-Setup.hs20
-rw-r--r--textproc/hs-pandoc/files/patch-pandoc.cabal26
-rw-r--r--textproc/hs-pandoc/files/patch-src__Text__Pandoc__Readers__TeXMath.hs11
-rw-r--r--textproc/hs-pandoc/pkg-descr25
6 files changed, 52 insertions, 72 deletions
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index 023b419d35e0..7c8796c11477 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pandoc
-PORTVERSION= 1.12.4.2
+PORTVERSION= 1.13.0.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
@@ -12,13 +12,14 @@ LICENSE= GPLv2
USE_CABAL= aeson>=0.7 attoparsec>=0.10 base64-bytestring>=0.1 \
blaze-html>=0.5 blaze-markup>=0.5.1 data-default>=0.4 \
- extensible-exceptions>=0.1 highlighting-kate>=0.5.8 \
- hslua>=0.3 HTTP>=4000.0.5 http-conduit>=1.9 http-types>=0.8 \
- mtl>=1.1 network>=2 pandoc-types>=1.12.3.3 parsec>=3.1 \
- random>=1 scientific>=0.2 syb>=0.1 tagsoup>=0.13.1 \
- temporary>=1.1 texmath>=0.6.6.1 text>=0.11 \
- unordered-containers>=0.2 vector>=0.10 xml>=1.3.12 \
- yaml>=0.8.8.2 zip-archive>=0.1.3.3 zlib>=0.5
+ extensible-exceptions>=0.1 haddock-library>=1.1 \
+ highlighting-kate>=0.5.8 hslua>=0.3 HTTP>=4000.0.5 \
+ JuicyPixels>=3.1.6.1 mtl>=1.1 network>=2 \
+ pandoc-types>=1.12.3.3 parsec>=3.1 random>=1 scientific>=0.2 \
+ SHA>=1.6 syb>=0.1 tagsoup>=0.13.1 temporary>=1.1 texmath>=0.8 \
+ text>=0.11 unordered-containers>=0.2 vector>=0.10 xml>=1.3.12 \
+ yaml>=0.8.8.2 zip-archive>=0.2.3.4 zlib>=0.5
+
USE_ALEX= yes
USE_HAPPY= yes
@@ -27,18 +28,29 @@ EXECUTABLE= pandoc
# For PDF generation
USE_TEX= texmf:run
+MAN1SRC= man/man1
+MAN5SRC= man/man5
MAN1PAGES= pandoc.1
MAN5PAGES= pandoc_markdown.5
+MANCOMPRESSED= no
-FLAGS_DEFINE= EMBED_DATA_FILES HTTP_CONDUIT
-FLAGS_DEFAULT= HTTP_CONDUIT
+FLAGS_DEFINE= EMBED_DATA_FILES HTTPS TRYPANDOC
+FLAGS_DEFAULT= HTTPS
EMBED_DATA_FILES_DESC= Embed data files in binary for relocatable executable
EMBED_DATA_FILES_FLAG_ENABLE= embed_data_files
-HTTP_CONDUIT_DESC= Enable downloading of resources over HTTPS
-HTTP_CONDUIT_FLAG_ENABLE= http-conduit
-HTTP_CONDUIT_FLAG_CABAL= http-conduit>=1.9 http-types>=0.8
+HTTPS_DESC= Enable downloading of resources over HTTPS
+HTTPS_FLAG_ENABLE= https
+HTTPS_FLAG_CABAL= http-client>=0.3.2 http-client-tls>=0.2 http-types>=0.8
+
+TRYPANDOC_DESC= Build trypandoc cgi executable
+TRYPANDOC_FLAG_ENABLE= trypandoc
+TRYPANDOC_FLAG_CABAL= aeson highlighting-kate text wai-extra wai>=0.3 \
+ http-types
+TRYPANDOC_FLAG_EXECUTABLE= trypandoc
+
+FLAGS_DISABLE= make-pandoc-man-pages
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-pandoc/distinfo b/textproc/hs-pandoc/distinfo
index 03e14a741d66..4761abd4dd0e 100644
--- a/textproc/hs-pandoc/distinfo
+++ b/textproc/hs-pandoc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/pandoc-1.12.4.2.tar.gz) = 2f47f5f36498d26aa9cda7b93bcee76afedeeca7463478b5eda076209ba27f45
-SIZE (cabal/pandoc-1.12.4.2.tar.gz) = 1048263
+SHA256 (cabal/pandoc-1.13.0.1.tar.gz) = a6994016a01050b4582021b88e8370d9bc6a0a03b164da5bde60bf91b2ee5e5e
+SIZE (cabal/pandoc-1.13.0.1.tar.gz) = 1866051
diff --git a/textproc/hs-pandoc/files/patch-Setup.hs b/textproc/hs-pandoc/files/patch-Setup.hs
deleted file mode 100644
index d7882e836375..000000000000
--- a/textproc/hs-pandoc/files/patch-Setup.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Setup.hs.orig 2013-12-09 04:22:42.000000000 +0100
-+++ ./Setup.hs 2013-12-27 02:49:01.000000000 +0100
-@@ -9,7 +9,7 @@
- import Distribution.Simple.LocalBuildInfo
- (LocalBuildInfo(..), absoluteInstallDirs)
- import Distribution.Verbosity ( Verbosity, silent )
--import Distribution.Simple.InstallDirs (mandir, CopyDest (NoCopyDest), toPathTemplate)
-+import Distribution.Simple.InstallDirs (prefix, CopyDest (NoCopyDest), toPathTemplate)
- import Distribution.Simple.Utils (installOrdinaryFiles, info)
- import Distribution.Simple.Test (test)
- import Prelude hiding (catch)
-@@ -59,7 +59,7 @@
- installManpages :: PackageDescription -> LocalBuildInfo
- -> Verbosity -> CopyDest -> IO ()
- installManpages pkg lbi verbosity copy =
-- installOrdinaryFiles verbosity (mandir (absoluteInstallDirs pkg lbi copy))
-+ installOrdinaryFiles verbosity (prefix (absoluteInstallDirs pkg lbi copy) </> manDir)
- (zip (repeat manDir) manpages)
-
- ppBlobSuffixHandler :: PPSuffixHandler
diff --git a/textproc/hs-pandoc/files/patch-pandoc.cabal b/textproc/hs-pandoc/files/patch-pandoc.cabal
index e3c233a8eb6b..3cb0a7f47131 100644
--- a/textproc/hs-pandoc/files/patch-pandoc.cabal
+++ b/textproc/hs-pandoc/files/patch-pandoc.cabal
@@ -1,11 +1,15 @@
---- ./pandoc.cabal.orig 2014-05-15 00:07:54.000000000 +0200
-+++ ./pandoc.cabal 2014-07-13 00:56:47.000000000 +0200
-@@ -234,7 +234,7 @@
- blaze-markup >= 0.5.1 && < 0.7,
- attoparsec >= 0.10 && < 0.12,
- yaml >= 0.8.8.2 && < 0.9,
-- scientific >= 0.2 && < 0.3,
-+ scientific >= 0.2 && < 0.4,
- vector >= 0.10 && < 0.11,
- hslua >= 0.3 && < 0.4,
- binary >= 0.5 && < 0.8
+--- ./pandoc.cabal.orig 2014-08-18 02:12:46.000000000 +0200
++++ ./pandoc.cabal 2014-08-24 15:03:23.000000000 +0200
+@@ -364,10 +364,10 @@
+ Executable trypandoc
+ Main-Is: trypandoc.hs
+ Hs-Source-Dirs: trypandoc
+- build-depends: base, aeson, pandoc, highlighting-kate,
+- text, wai-extra, wai >= 0.3, http-types
+ default-language: Haskell2010
+ if flag(trypandoc)
++ build-depends: base, aeson, pandoc, highlighting-kate,
++ text, wai-extra, wai >= 0.3, http-types
+ Buildable: True
+ else
+ Buildable: False
diff --git a/textproc/hs-pandoc/files/patch-src__Text__Pandoc__Readers__TeXMath.hs b/textproc/hs-pandoc/files/patch-src__Text__Pandoc__Readers__TeXMath.hs
deleted file mode 100644
index ee7e5f4ae50a..000000000000
--- a/textproc/hs-pandoc/files/patch-src__Text__Pandoc__Readers__TeXMath.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/Text/Pandoc/Readers/TeXMath.hs.orig 2014-05-15 00:07:52.000000000 +0200
-+++ ./src/Text/Pandoc/Readers/TeXMath.hs 2014-07-29 12:58:00.000000000 +0200
-@@ -30,7 +30,7 @@
- module Text.Pandoc.Readers.TeXMath ( readTeXMath, readTeXMath' ) where
-
- import Text.Pandoc.Definition
--import Text.TeXMath
-+import Text.TeXMath ( texMathToPandoc, DisplayType(DisplayBlock, DisplayInline) )
-
- -- | Converts a raw TeX math formula to a list of 'Pandoc' inlines.
- -- Defaults to raw formula between @$@ or @$$@ characters if entire formula
diff --git a/textproc/hs-pandoc/pkg-descr b/textproc/hs-pandoc/pkg-descr
index da61bb64cd19..d532d32887bf 100644
--- a/textproc/hs-pandoc/pkg-descr
+++ b/textproc/hs-pandoc/pkg-descr
@@ -1,20 +1,15 @@
Pandoc is a Haskell library for converting from one markup format to
another, and a command-line tool that uses this library. It can read
markdown and (subsets of) HTML, reStructuredText, LaTeX, DocBook,
-MediaWiki markup, Haddock markup, OPML, Emacs Org-Mode, and Textile, and
-it can write markdown, reStructuredText, HTML, LaTeX, ConTeXt, Docbook,
-OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki, Textile, groff man
-pages, plain text, Emacs Org-Mode, AsciiDoc, EPUB (v2 and v3),
-FictionBook2, InDesign ICML, and several kinds of HTML/javascript slide
-shows (S5, Slidy, Slideous, DZSlides, reveal.js). Pandoc extends
-standard markdown syntax with footnotes, embedded LaTeX, definition
-lists, tables, and other features. A compatibility mode is provided for
-those who need a drop-in replacement for Markdown.pl. In contrast to
-existing tools for converting markdown to HTML, which use regex
-substitutions, pandoc has a modular design: it consists of a set of
-readers, which parse text in a given format and produce a native
-representation of the document, and a set of writers, which convert this
-native representation into a target format. Thus, adding an input or
-output format requires only adding a reader or writer.
+MediaWiki markup, Haddock markup, OPML, Emacs Org-Mode, txt2tags and
+Textile, and it can write markdown, reStructuredText, HTML, LaTeX,
+ConTeXt, Docbook, OPML, OpenDocument, ODT, Word docx, RTF, MediaWiki,
+DokuWiki, Textile, groff man pages, plain text, Emacs Org-Mode,
+AsciiDoc, Haddock markup, EPUB (v2 and v3), FictionBook2, InDesign ICML,
+and several kinds of HTML/javascript slide shows (S5, Slidy, Slideous,
+DZSlides, reveal.js). Pandoc extends standard markdown syntax with
+footnotes, embedded LaTeX, definition lists, tables, and other features.
+A compatibility mode is provided for those who need a drop-in
+replacement for Markdown.pl.
WWW: http://johnmacfarlane.net/pandoc