aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-pandoc
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2019-01-22 15:03:24 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2019-01-22 15:03:24 +0000
commitd5427d383a79b68363988ef53068c6175e0f9fe4 (patch)
treec1c1a8d784c6f26409a4e5ee93fba426780fbbce /textproc/hs-pandoc
parenta1ac8c389227ab918eb178663dbbec04273030f1 (diff)
downloadports-d5427d383a79b68363988ef53068c6175e0f9fe4.tar.gz
ports-d5427d383a79b68363988ef53068c6175e0f9fe4.zip
textproc/hs-pandoc: Switch to static build and fix option issues
- With the default options, there were many large dependencies, including ghc. Most users likely just want the application without the compiler and libraries, so switch to a static build. - The build was failing with a few non-default option combinations (e.g, with HTTPS off). Fix these and/or remove options that are probably not that useful for most users. - The binary is linked to libffi.so, so add LIB_DEPENDS on devel/libffi. - Pacify portlint Reported by: adamw Approved by: maintainer (haskell via arrowd) Differential Revision: https://reviews.freebsd.org/D18899
Notes
Notes: svn path=/head/; revision=490955
Diffstat (limited to 'textproc/hs-pandoc')
-rw-r--r--textproc/hs-pandoc/Makefile61
1 files changed, 26 insertions, 35 deletions
diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile
index 7907f2b88cab..9d98cbb8a3d9 100644
--- a/textproc/hs-pandoc/Makefile
+++ b/textproc/hs-pandoc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pandoc
PORTVERSION= 2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,50 +11,41 @@ COMMENT= Conversion between markup formats
LICENSE= GPLv2
-USE_CABAL= aeson aeson-pretty base64-bytestring blaze-html \
- blaze-markup cmark cmark-gfm data-default \
- deepseq-generics doctemplates extensible-exceptions \
- filemanip Glob haddock-library \
- hslua hslua-module-text HsYAML HTTP JuicyPixels mtl \
- network network-uri pandoc-types \
- random scientific SHA skylighting syb tagsoup\
- temporary texmath unicode-transforms \
- unordered-containers vector xml \
- yaml zip-archive zlib
+LIB_DEPENDS= libffi.so:devel/libffi
USE_ALEX= yes
+USE_CABAL= aeson aeson-pretty base64-bytestring blaze-html blaze-markup \
+ cmark cmark-gfm data-default deepseq-generics doctemplates \
+ extensible-exceptions filemanip Glob haddock-library hslua \
+ hslua-module-text HsYAML http-client http-client-tls \
+ http-types HTTP JuicyPixels mtl network network-uri \
+ pandoc-types random scientific SHA skylighting syb tagsoup \
+ temporary texmath unicode-transforms unordered-containers \
+ vector xml yaml zip-archive zlib
USE_HAPPY= yes
-EXECUTABLE= pandoc
-
-MAN1SRC= man
-MAN1PAGES= pandoc.1
-
+FLAGS_DEFINE= EMBED_DATA TRYPANDOC
OPTIONS_DEFINE= PDFGEN
OPTIONS_DEFAULT= PDFGEN
-PDFGEN_DESC= Include TeX for PDF generation
-PDFGEN_USE= TEX=texmf:run
-
-FLAGS_DEFINE= EMBED_DATA HTTPS TRYPANDOC
-FLAGS_DEFAULT= HTTPS
-
-EMBED_DATA_DESC= Embed data files in binary for relocatable executable
+EMBED_DATA_DESC= Embed data files in binary for relocatable executable
EMBED_DATA_FLAG_ENABLE= embed_data_files
-EMBED_DATA_FLAG_CABAL= hsb2hs>=0.3.1
-
-HTTPS_DESC= Enable downloading of resources over HTTPS
-HTTPS_FLAG_ENABLE= https
-HTTPS_FLAG_CABAL= http-client>=0.3.2 http-client-tls>=0.2 http-types>=0.8
-
-TRYPANDOC_DESC= Build trypandoc cgi executable
-TRYPANDOC_FLAG_ENABLE= trypandoc
-TRYPANDOC_FLAG_CABAL= aeson wai-extra wai>=0.3 \
- http-types
+EMBED_DATA_FLAG_CABAL= file-embed>=0.0
+PDFGEN_DESC= Include TeX for PDF generation
+PDFGEN_USE= TEX=texmf:run
+TRYPANDOC_DESC= Build trypandoc cgi executable
+TRYPANDOC_FLAG_ENABLE= trypandoc
+TRYPANDOC_FLAG_CABAL= aeson wai-extra wai>=0.3
TRYPANDOC_FLAG_EXECUTABLE= trypandoc
-FLAGS_ENABLE= network-uri
-FLAGS_DISABLE= make-pandoc-man-pages
+EXECUTABLE= pandoc
+FLAGS_ENABLE= network-uri
+FLAGS_DISABLE= make-pandoc-man-pages
+IGNORE_DYNAMIC= yes
+IGNORE_PROFILE= yes
+MAN1SRC= man
+MAN1PAGES= pandoc.1
+STANDALONE= yes
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>