aboutsummaryrefslogtreecommitdiff
path: root/textproc/html/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-13 08:37:15 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-13 08:37:15 +0000
commitcd4dafaf26dd1e567ad80498f1a4a481bbf14b92 (patch)
tree148220550c04042202a0de16ce1a058d2a5530ec /textproc/html/Makefile
parent51a336fefc2e8a176d136daf2f7eb6c6dd941811 (diff)
downloadports-cd4dafaf26dd1e567ad80498f1a4a481bbf14b92.tar.gz
ports-cd4dafaf26dd1e567ad80498f1a4a481bbf14b92.zip
Allow staging as a regular user
Notes
Notes: svn path=/head/; revision=368077
Diffstat (limited to 'textproc/html/Makefile')
-rw-r--r--textproc/html/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/textproc/html/Makefile b/textproc/html/Makefile
index 8d7bb697e549..47719ad8068b 100644
--- a/textproc/html/Makefile
+++ b/textproc/html/Makefile
@@ -5,9 +5,7 @@ PORTNAME= html
PORTVERSION= 4.01
PORTREVISION= 2
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= kuriyama
-EXTRACT_ONLY= # empty
+MASTER_SITES= LOCAL/kuriyama
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= All W3C published SGML DTDs for HTML
@@ -21,16 +19,12 @@ NO_WRKSUBDIR= yes
PLIST_SUB= DTD_NAME=${PORTNAME} XMLCATMGR=${XMLCATMGR}
PLIST_SUB+= CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
-INSTDIR= ${STAGEDIR}${PREFIX}/share/sgml/html
+INSTDIR= ${PREFIX}/share/sgml/html
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
-pre-su-install:
- @[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
-
do-install:
- @zcat ${DISTDIR}/${DISTFILES} |(cd ${INSTDIR}; ${PAX} -r)
- @${CHMOD} ${SHAREMODE} `${FIND} ${INSTDIR} -type f`
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
+ ${MKDIR} ${STAGEDIR}${INSTDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "2.0 3.2 4.0 4.01 catalog" ${STAGEDIR}${INSTDIR})
.include <bsd.port.mk>