aboutsummaryrefslogtreecommitdiff
path: root/textproc/html2text
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-03-03 00:21:22 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-03-03 00:21:22 +0000
commit24b38246dbe9a4bc9346bae362bee65620e62bd1 (patch)
tree1e3833dfb1ed55e58a582631fb65e0bb00e44bac /textproc/html2text
parent7f9081c6187c8bc456ea194e6a7d938ba7c52686 (diff)
downloadports-24b38246dbe9a4bc9346bae362bee65620e62bd1.tar.gz
ports-24b38246dbe9a4bc9346bae362bee65620e62bd1.zip
Teach portscout that 1.3.2 is not newer than 1.3.2a.
Pet portlint by using "fle" instead of "file" Mark port safe for use with MAKE_JOBS
Notes
Notes: svn path=/head/; revision=313311
Diffstat (limited to 'textproc/html2text')
-rw-r--r--textproc/html2text/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index f1de192a1c82..f34cbec5faae 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -19,20 +19,22 @@ MAN5= html2textrc.5
PORTDOCS= CHANGES CREDITS KNOWN_BUGS README TODO
PLIST_FILES= bin/html2text
+MAKE_JOBS_SAFE= yes
+
CONFLICTS= py27-html2text-[0-9]*
-PORTSCOUT= skipb:0
+PORTSCOUT= skipb:0 skipv:1.3.2
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
-.for file in Makefile.in libstd/Makefile.in
+.for fle in Makefile.in libstd/Makefile.in
@${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; \
- /^CXXFLAGS/s/=/+=/' ${WRKSRC}/${file}
+ /^CXXFLAGS/s/=/+=/' ${WRKSRC}/${fle}
.endfor
-.for file in Area.h HTMLControl.h Properties.h format.h
- @${REINPLACE_CMD} -e 's/<istream>/<iostream>/' ${WRKSRC}/${file}
+.for fle in Area.h HTMLControl.h Properties.h format.h
+ @${REINPLACE_CMD} -e 's/<istream>/<iostream>/' ${WRKSRC}/${fle}
.endfor
do-install:
@@ -41,8 +43,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for fle in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${fle} ${DOCSDIR}
.endfor
.endif