aboutsummaryrefslogtreecommitdiff
path: root/textproc/html2text
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-03-27 02:09:23 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-03-27 02:09:23 +0000
commitefaa98f4e377b26f1dc7d633e853eadd6feece70 (patch)
tree947cb97a35b248a898fd93205baf64a2acac65dd /textproc/html2text
parent8d45ccc69bbc1102508dc2217e83c6d63118127c (diff)
downloadports-efaa98f4e377b26f1dc7d633e853eadd6feece70.tar.gz
ports-efaa98f4e377b26f1dc7d633e853eadd6feece70.zip
Add html2text 1.3.1, converts HTML documents into plain text.
Submitted by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
Notes
Notes: svn path=/head/; revision=77508
Diffstat (limited to 'textproc/html2text')
-rw-r--r--textproc/html2text/Makefile40
-rw-r--r--textproc/html2text/distinfo1
-rw-r--r--textproc/html2text/pkg-descr16
-rw-r--r--textproc/html2text/pkg-plist8
4 files changed, 65 insertions, 0 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
new file mode 100644
index 000000000000..6818d4292827
--- /dev/null
+++ b/textproc/html2text/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: html2text
+# Date created: 7 March 2003
+# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html2text
+PORTVERSION= 1.3.1
+CATEGORIES= textproc
+MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
+ ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
+
+MAINTAINER= corecode@corecode.ath.cx
+COMMENT= Converts HTML documents into plain text
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+MANCOMPRESSED= yes
+
+MAN1= html2text.1
+MAN5= html2textrc.5
+
+DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/libstd/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:C#^#${WRKSRC}/#g} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/html2text/distinfo b/textproc/html2text/distinfo
new file mode 100644
index 000000000000..4da2e5b50a66
--- /dev/null
+++ b/textproc/html2text/distinfo
@@ -0,0 +1 @@
+MD5 (html2text-1.3.1.tar.gz) = faa3eaeb062540e72d251d6c3fa6cc71
diff --git a/textproc/html2text/pkg-descr b/textproc/html2text/pkg-descr
new file mode 100644
index 000000000000..930d340e557c
--- /dev/null
+++ b/textproc/html2text/pkg-descr
@@ -0,0 +1,16 @@
+html2text is a command line utility, written in C++, that converts
+HTML documents (HTML 3.2) into plain text (ISO 8859-1).
+
+Each HTML document is loaded from a location indicated by an URI or
+read from standard input, and formatted into a stream of plain text
+characters that is written to standard output or into an output-file.
+The input-URI may specify a remote site, from that the documents are
+loaded with the Hypertext Transfer Protocol (HTTP). The program is
+even able to preserve the original positions of table fields and
+accepts also syntactically incorrect input, attempting to interpret it
+"reasonably". The rendering is largely customisable through an RC
+file.
+
+WWW: http://userpage.fu-berlin.de/~mbayer/tools/html2text.html
+
+- Simon 'corecode' Schubert
diff --git a/textproc/html2text/pkg-plist b/textproc/html2text/pkg-plist
new file mode 100644
index 000000000000..75866489551e
--- /dev/null
+++ b/textproc/html2text/pkg-plist
@@ -0,0 +1,8 @@
+bin/html2text
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%