aboutsummaryrefslogtreecommitdiff
path: root/textproc/htmldoc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 05:24:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 05:24:20 +0000
commit9c227d0a1cca62f3b12537ea4e6a8932216d6b0c (patch)
tree210d9714fe7fffc3e0efa298b4aff3138950c906 /textproc/htmldoc
parent1ddb2382579c04df86febfe0ad3ae650cc43b6be (diff)
downloadports-9c227d0a1cca62f3b12537ea4e6a8932216d6b0c.tar.gz
ports-9c227d0a1cca62f3b12537ea4e6a8932216d6b0c.zip
textproc/htmldoc: unbreak with clang 4.0
htmlsep.cxx:527:19: error: ordered comparison between pointer and zero ('int *' and 'int') if (heading >= 0) ~~~~~~~ ^ ~ PR: 216159 Reported by: antoine (via exp-run) Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=432965
Diffstat (limited to 'textproc/htmldoc')
-rw-r--r--textproc/htmldoc/Makefile2
-rw-r--r--textproc/htmldoc/files/patch-htmldoc_htmlsep.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/textproc/htmldoc/Makefile b/textproc/htmldoc/Makefile
index efe94bbf8f5e..46cdd450d3ca 100644
--- a/textproc/htmldoc/Makefile
+++ b/textproc/htmldoc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= htmldoc
PORTVERSION= 1.8.28
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://www.msweet.org/files/project1/ \
EASYSW/${PORTNAME}/${PORTVERSION}
diff --git a/textproc/htmldoc/files/patch-htmldoc_htmlsep.cxx b/textproc/htmldoc/files/patch-htmldoc_htmlsep.cxx
new file mode 100644
index 000000000000..2b70322610ec
--- /dev/null
+++ b/textproc/htmldoc/files/patch-htmldoc_htmlsep.cxx
@@ -0,0 +1,11 @@
+--- htmldoc/htmlsep.cxx.orig 2013-08-09 13:43:34 UTC
++++ htmldoc/htmlsep.cxx
+@@ -524,7 +524,7 @@ write_doc(FILE **out, // I - Output
+ if (t->markup >= MARKUP_H1 && t->markup < (MARKUP_H1 + TocLevels) &&
+ htmlGetVariable(t, (uchar *)"_HD_OMIT_TOC") == NULL)
+ {
+- if (heading >= 0)
++ if (*heading >= 0)
+ write_footer(out, *heading);
+
+ (*heading) ++;