aboutsummaryrefslogtreecommitdiff
path: root/textproc/hunspell
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-07-19 05:23:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-07-19 05:23:03 +0000
commit0f57ce77afaad12ca17c2e74d318f146418f5aad (patch)
tree2a519361558e66339300a0c17273a15d22026c77 /textproc/hunspell
parent6e7763dcc32be608dd5017c4472bc7a4c757e45c (diff)
downloadports-0f57ce77afaad12ca17c2e74d318f146418f5aad.tar.gz
ports-0f57ce77afaad12ca17c2e74d318f146418f5aad.zip
- update to 1.3.2
- remove hungarian dictionnary (will be readded later as a separate port) - rework description - change WWW - chase library bump - add license
Notes
Notes: svn path=/head/; revision=277936
Diffstat (limited to 'textproc/hunspell')
-rw-r--r--textproc/hunspell/Makefile67
-rw-r--r--textproc/hunspell/distinfo6
-rw-r--r--textproc/hunspell/files/patch-Makefile.in14
-rw-r--r--textproc/hunspell/files/patch-src_tools_hunspell.cxx17
-rw-r--r--textproc/hunspell/files/patch-sysintl14
-rw-r--r--textproc/hunspell/pkg-descr27
-rw-r--r--textproc/hunspell/pkg-plist38
7 files changed, 57 insertions, 126 deletions
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index 5d57f09370c6..c6e91b1c3d02 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -6,71 +6,36 @@
#
PORTNAME= hunspell
-PORTVERSION= 1.2.11
+PORTVERSION= 1.3.2
CATEGORIES= hungarian textproc
-MASTER_SITES= SF/${PORTNAME}/Hunspell/${PORTVERSION}:code \
- SF/magyarispell/Magyar%20Ispell/${DICTVERSION}:data
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:code \
- hu_HU-${DICTVERSION}${EXTRACT_SUFX}:data
+MASTER_SITES= SF/${PORTNAME}/Hunspell/${PORTVERSION}
MAINTAINER= bapt@FreeBSD.org
COMMENT= Improved spell-checker for Hungarian and other languages
-#EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+LICENSE= GPLv2 LGPL21 MPL
+LICENSE_COMB= dual
-#USE_GETTEXT= yes
-#USE_ICONV= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ui --with-readline --disable-nls
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
-EXTRACT_AFTER_ARGS=|${TAR} -xpf - --exclude intl
-ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
+MAKE_JOBS_SAFE= yes
-MAN1= hunspell.1
-MAN4= hunspell.4
+USE_NCURSES= yes
+USE_GNOME= gnomehack
-DICTVERSION= 1.6.1
-PORTDOCS= README README.myspell
+MANLANG= "" hu
+MAN1_EN= hunspell.1 \
+ hunzip.1 \
+ hzip.1
+MAN3_EN= hunspell.3
+MAN4_EN= hunspell.4
-.include <bsd.port.pre.mk>
+MAN1_HU= hunspell.1
+MAN4_HU= hunspell.4
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/src/tools/hunspell.cxx
-do-install:
- ${INSTALL_MAN} ${WRKSRC}/man/hunspell.1 ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/man/hunspell.4 ${PREFIX}/man/man4
- ${INSTALL_PROGRAM} ${WRKSRC}/src/tools/.libs/hunspell ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/include/hunspell
- ${INSTALL_DATA} ${WRKSRC}/src/hunspell/*.h* ${PREFIX}/include/hunspell/
- ${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.a ${PREFIX}/lib
- ${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.lai ${PREFIX}/lib/libhunspell-1.1.la
- ${INSTALL_DATA} ${WRKSRC}/src/hunspell/.libs/libhunspell-1.2.so.0 ${PREFIX}/lib
- ${LN} -s ${LOCALBASE}/lib/libhunspell-1.2.so.0 ${PREFIX}/lib/libhunspell-1.2.so
- ${MKDIR} ${PREFIX}/share/myspell/
- ${INSTALL_DATA} ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.dic \
- ${WRKDIR}/hu_HU-${DICTVERSION}/hu_HU.aff \
- ${PREFIX}/share/myspell/
- ${INSTALL_DATA} ${WRKSRC}/hunspell.pc ${PREFIX}/libdata/pkgconfig/
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/magyar.dic
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/hungarian.dic
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.dic ${PREFIX}/share/myspell/default.dic
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/magyar.aff
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/hungarian.aff
- ${LN} -s ${LOCALBASE}/share/myspell/hu_HU.aff ${PREFIX}/share/myspell/default.aff
- #${LOCALBASE}/bin/msgfmt -o ${WRKSRC}/hunspell.mo ${WRKSRC}/hunspell.po
- #${MKDIR} ${PREFIX}/share/locale/hu/LC_MESSAGES/ && \
- #${INSTALL_DATA} ${WRKSRC}/hunspell.mo ${PREFIX}/share/locale/hu/LC_MESSAGES/
-
-.ifndef(NOPORTDOCS)
-post-install:
- ${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/hunspell/distinfo b/textproc/hunspell/distinfo
index aa85fcb6d5dd..f5cdad62e1e8 100644
--- a/textproc/hunspell/distinfo
+++ b/textproc/hunspell/distinfo
@@ -1,4 +1,2 @@
-SHA256 (hunspell-1.2.11.tar.gz) = 3f975c056e0e8883b38ebe75f04a32e3983ea9d951afa035181806b070d06e93
-SIZE (hunspell-1.2.11.tar.gz) = 926658
-SHA256 (hu_HU-1.6.1.tar.gz) = 0a1ab4672bf75acc1c29c4b3fbcab5d10b7883ba1e7fc25e8054d2209f0352c2
-SIZE (hu_HU-1.6.1.tar.gz) = 730641
+SHA256 (hunspell-1.3.2.tar.gz) = b4edd4a4ee944cb9f485b35473e46b729ed768e9d24da8e78e4c4c6ca56addbd
+SIZE (hunspell-1.3.2.tar.gz) = 975917
diff --git a/textproc/hunspell/files/patch-Makefile.in b/textproc/hunspell/files/patch-Makefile.in
deleted file mode 100644
index 672e80e67f74..000000000000
--- a/textproc/hunspell/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig
-+++ Makefile.in
-@@ -320,7 +320,7 @@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- ACLOCAL_AMFLAGS = -I m4
--SUBDIRS = intl po src man m4 tests
-+SUBDIRS = po src man m4 tests
- pkgconfdir = $(libdir)/pkgconfig
- pkgconf_DATA = hunspell.pc
- EXTRA_DIST = BUGS README.myspell AUTHORS.myspell license.myspell license.hunspell \
diff --git a/textproc/hunspell/files/patch-src_tools_hunspell.cxx b/textproc/hunspell/files/patch-src_tools_hunspell.cxx
index 6928f3adfc74..e0470da14663 100644
--- a/textproc/hunspell/files/patch-src_tools_hunspell.cxx
+++ b/textproc/hunspell/files/patch-src_tools_hunspell.cxx
@@ -1,22 +1,21 @@
-
-$FreeBSD$
-
---- src/tools/hunspell.cxx.orig
-+++ src/tools/hunspell.cxx
-@@ -61,26 +61,22 @@
+--- ./src/tools/hunspell.cxx.orig 2011-01-21 18:01:29.000000000 +0100
++++ ./src/tools/hunspell.cxx 2011-07-19 07:16:58.346225286 +0200
+@@ -61,28 +61,23 @@
#include "firstparser.hxx"
#define LIBDIR \
- "/usr/share/hunspell:" \
- "/usr/share/myspell:" \
-- "/usr/share/myspell/dicts"
+- "/usr/share/myspell/dicts:" \
+- "/Library/Spelling"
+ "%%PREFIX%%/share/hunspell:" \
+ "%%PREFIX%%/share/myspell:" \
-+ "%%PREFIX%%/share/myspell/dicts"
++ "%%PREFIX%%/share/myspell/dicts:"
#define USEROOODIR \
".openoffice.org/3/user/wordbook:" \
".openoffice.org2/user/wordbook:" \
- ".openoffice.org2.0/user/wordbook"
+ ".openoffice.org2.0/user/wordbook:" \
+ "Library/Spelling"
#define OOODIR \
- "/opt/openoffice.org/basis3.0/share/dict/ooo:" \
- "/usr/lib/openoffice.org/basis3.0/share/dict/ooo:" \
diff --git a/textproc/hunspell/files/patch-sysintl b/textproc/hunspell/files/patch-sysintl
deleted file mode 100644
index d44d394cba79..000000000000
--- a/textproc/hunspell/files/patch-sysintl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- configure.orig
-+++ configure
-@@ -20562,7 +20562,7 @@
- fi
-
-
--ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile intl/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/hunspell/hunvisapi.h src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
-+ac_config_files="$ac_config_files Makefile hunspell.pc man/Makefile man/hu/Makefile po/Makefile.in m4/Makefile src/Makefile src/hunspell/Makefile src/hunspell/hunvisapi.h src/parsers/Makefile src/tools/Makefile src/win_api/Makefile tests/Makefile tests/suggestiontest/Makefile"
-
- cat >confcache <<\_ACEOF
- # This file is a shell script that caches the results of configure
diff --git a/textproc/hunspell/pkg-descr b/textproc/hunspell/pkg-descr
index 12b121008bdd..93461f1e08fc 100644
--- a/textproc/hunspell/pkg-descr
+++ b/textproc/hunspell/pkg-descr
@@ -1,19 +1,12 @@
-Hungarian Spell Checher utility with Hungarian dictionary
-and affix files. It has several advantages over ispell.
-It has better affix rules than hu-ispell.
+Hunspell is a wildly use spell checker
-It is installing hungarian dictionary by default, but other dictionaries can
-be found at: http://wiki.services.openoffice.org/wiki/Dictionaries
+Main features:
+- Extended support for language peculiarities; Unicode character encoding,
+ compounding and complex morphology.
+- Improved suggestion using n-gram similarity, rule and dictionary based
+ pronounciation data.
+- Morphological analysis, stemming and generation.
+- Hunspell is based on MySpell and works also with MySpell dictionaries.
+- C++ library under GPL/LGPL/MPL tri-license.
-Magyar helyes.r.s ellen.rz. hunspell. El.ny.k az ispell-hez k.pest:
-- T.bb karakter v.ltoz.ssal j.r. tipikus hib.kra jav.t.si javaslat.
-- Helyes .sszetett sz.nak l.tsz. szavak tilt.sa.
-- 6-3-as szab.ly
-- mozg.szab.ly
-- .sszet.teli szab.lyok
-- t.bbsz.r.s k.pz.k helyes haszn.lata
-- .kezetes.t.si javaslatok
-Alepesetben csak a magyar sz.t.rat install.lja, de tov.bbi sz.t.rak
-el.rhet.ek: http://wiki.services.openoffice.org/wiki/Dictionaries
-
-WWW: http://magyarispell.sourceforge.net/
+WWW: http://hunspell.sourceforge.net/
diff --git a/textproc/hunspell/pkg-plist b/textproc/hunspell/pkg-plist
index 0e68b39d1aae..b960c4920523 100644
--- a/textproc/hunspell/pkg-plist
+++ b/textproc/hunspell/pkg-plist
@@ -1,4 +1,15 @@
bin/hunspell
+bin/affixcompress
+bin/analyze
+bin/chmorph
+bin/hunzip
+bin/hzip
+bin/ispellaff2myspell
+bin/makealias
+bin/munch
+bin/unmunch
+bin/wordforms
+bin/wordlist2hunspell
include/hunspell/affentry.hxx
include/hunspell/affixmgr.hxx
include/hunspell/atypes.hxx
@@ -10,27 +21,20 @@ include/hunspell/hashmgr.hxx
include/hunspell/htypes.hxx
include/hunspell/hunspell.h
include/hunspell/hunspell.hxx
+include/hunspell/hunvisapi.h
include/hunspell/hunzip.hxx
include/hunspell/langnum.hxx
-include/hunspell/license.hunspell
include/hunspell/phonet.hxx
include/hunspell/replist.hxx
include/hunspell/suggestmgr.hxx
include/hunspell/w_char.hxx
-include/hunspell/hunvisapi.h
-include/hunspell/hunvisapi.h.in
-@dirrm include/hunspell
-lib/libhunspell-1.2.a
-lib/libhunspell-1.1.la
-lib/libhunspell-1.2.so.0
-lib/libhunspell-1.2.so
+lib/libhunspell-1.3.a
+lib/libhunspell-1.3.la
+lib/libhunspell-1.3.so
+lib/libhunspell-1.3.so.0
+lib/libparsers.a
libdata/pkgconfig/hunspell.pc
-share/myspell/hu_HU.aff
-share/myspell/hu_HU.dic
-share/myspell/hungarian.aff
-share/myspell/hungarian.dic
-share/myspell/magyar.aff
-share/myspell/magyar.dic
-share/myspell/default.aff
-share/myspell/default.dic
-@dirrm share/myspell
+@dirrmtry include/hunspell
+@dirrmtry man/hu/man4
+@dirrmtry man/hu/man1
+@dirrmtry man/hu