aboutsummaryrefslogtreecommitdiff
path: root/textproc/hyphen
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-30 07:24:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-30 07:24:01 +0000
commitd42a178c95ef3182e128d9001ddd0a36c787da5d (patch)
treee639dfaa21e52af4814e30c4bf8eb8ec0435c14f /textproc/hyphen
parentd0b8691f45556b3b127cdce5e4f78f87a8364312 (diff)
downloadports-d42a178c95ef3182e128d9001ddd0a36c787da5d.tar.gz
ports-d42a178c95ef3182e128d9001ddd0a36c787da5d.zip
hyphen.h is now exposing FILE type from stdio.h which breaks some configure scripts
include stdio.h in hyphen.h to fix those check in configure scripts
Notes
Notes: svn path=/head/; revision=359807
Diffstat (limited to 'textproc/hyphen')
-rw-r--r--textproc/hyphen/Makefile1
-rw-r--r--textproc/hyphen/files/patch-hyphen.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/hyphen/Makefile b/textproc/hyphen/Makefile
index a2e548bbfcc2..8aa7a606e49a 100644
--- a/textproc/hyphen/Makefile
+++ b/textproc/hyphen/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hyphen
PORTVERSION= 2.8.7
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF/hunspell/Hyphen/${PORTVERSION:R}/
DIST_SUBDIR= ${PORTNAME}
diff --git a/textproc/hyphen/files/patch-hyphen.h b/textproc/hyphen/files/patch-hyphen.h
new file mode 100644
index 000000000000..b92232a01925
--- /dev/null
+++ b/textproc/hyphen/files/patch-hyphen.h
@@ -0,0 +1,11 @@
+--- ./hyphen.h.orig 2013-03-18 11:49:03.000000000 +0100
++++ ./hyphen.h 2014-06-30 09:22:00.804214782 +0200
+@@ -55,6 +55,8 @@
+ extern "C" {
+ #endif /* __cplusplus */
+
++#include <stdio.h>
++
+ typedef struct _HyphenDict HyphenDict;
+ typedef struct _HyphenState HyphenState;
+ typedef struct _HyphenTrans HyphenTrans;