aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-kmfl
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2010-06-10 18:30:26 +0000
committerXin LI <delphij@FreeBSD.org>2010-06-10 18:30:26 +0000
commit759976db23015318f26e7d8fcb31fe3555378bb1 (patch)
tree078ee5d84224824ecd12fdf0e289679fc19cf5d3 /textproc/ibus-kmfl
parentbd3c3a9a7ba05c6b245a6b8d2814aeed131f0029 (diff)
downloadports-759976db23015318f26e7d8fcb31fe3555378bb1.tar.gz
ports-759976db23015318f26e7d8fcb31fe3555378bb1.zip
Add ibus-kmfl 1.0.2, KMFL IMEngine for IBus framework.
PR: ports/147763 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Notes
Notes: svn path=/head/; revision=256319
Diffstat (limited to 'textproc/ibus-kmfl')
-rw-r--r--textproc/ibus-kmfl/Makefile44
-rw-r--r--textproc/ibus-kmfl/distinfo3
-rw-r--r--textproc/ibus-kmfl/pkg-descr18
-rw-r--r--textproc/ibus-kmfl/pkg-plist7
4 files changed, 72 insertions, 0 deletions
diff --git a/textproc/ibus-kmfl/Makefile b/textproc/ibus-kmfl/Makefile
new file mode 100644
index 000000000000..e2566a036b98
--- /dev/null
+++ b/textproc/ibus-kmfl/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ibus-kmfl
+# Date created: 4 June 2010
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ibus-kmfl
+PORTVERSION= 1.0.2
+CATEGORIES= textproc
+MASTER_SITES= SF/kmfl/${PORTNAME}/${PORTVERSION} \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= KMFL IMEngine for IBus framework
+
+LIB_DEPENDS= ibus.2:${PORTSDIR}/textproc/ibus \
+ kmfl.0:${PORTSDIR}/textproc/libkmfl \
+ kmflcomp.0:${PORTSDIR}/textproc/kmflcomp
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp
+
+USE_GNOME= glib20 pkgconfig
+
+USE_AUTOTOOLS= aclocal:110 automake:110
+ACLOCAL_ARGS= -I m4
+AUTOMAKE_ARGS= --add-missing --copy
+USE_GMAKE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/|${PREFIX}/|g' \
+ ${WRKSRC}/src/kmflutil.c ${WRKSRC}/src/kmfl.xml.in.in
+
+.include <bsd.port.mk>
diff --git a/textproc/ibus-kmfl/distinfo b/textproc/ibus-kmfl/distinfo
new file mode 100644
index 000000000000..ea30fde19186
--- /dev/null
+++ b/textproc/ibus-kmfl/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/ibus-kmfl-1.0.2.tar.gz) = c1b369bcc5713f1e921dfd2c0f1285d8
+SHA256 (kmfl/ibus-kmfl-1.0.2.tar.gz) = e6b1af7e1f3dd4768489ee83f4842f7c47a64f707e4edeaf503ab2ec4e97751c
+SIZE (kmfl/ibus-kmfl-1.0.2.tar.gz) = 385440
diff --git a/textproc/ibus-kmfl/pkg-descr b/textproc/ibus-kmfl/pkg-descr
new file mode 100644
index 000000000000..1c4000ca92b3
--- /dev/null
+++ b/textproc/ibus-kmfl/pkg-descr
@@ -0,0 +1,18 @@
+This is the KMFL IMEngine for IBus (Intelligent Input Bus) framework.
+It allows you to use layouts written in KMN keyboard language through
+standard IBus interface, through KMFL compiler (textproc/kmflcomp) and
+KMFL library (textproc/libkmfl).
+
+KMFL aims to bring Tavultesoft Keyman functionality to *nix operating
+systems. KMFL is being jointly developed by SIL International
+(http://www.sil.org) and Tavultesoft (http://www.tavultesoft.com).
+
+The powerful KMN keyboard language supports contextual deadkeys, pre-
+and post-processing of keystrokes, rules grouping, 'storing' of
+character classes for use in similar rules, custom and Unicode character
+constants, SIL Ethnologue language codes, etc.
+
+Official Tavultesoft repository contains keyboards that cover more
+than 220 languages. Significant number of them are open source.
+
+WWW: http://kmfl.sourceforge.net/
diff --git a/textproc/ibus-kmfl/pkg-plist b/textproc/ibus-kmfl/pkg-plist
new file mode 100644
index 000000000000..93c7b9ecaebb
--- /dev/null
+++ b/textproc/ibus-kmfl/pkg-plist
@@ -0,0 +1,7 @@
+libexec/ibus-engine-kmfl
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-kmfl.mo
+share/ibus/component/kmfl.xml
+share/kmfl/icons/default.png
+share/kmfl/icons/ibus-kmfl.svg
+@dirrm share/kmfl/icons
+@dirrm share/kmfl