aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-kmfl
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-08 08:12:25 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-08 08:12:25 +0000
commit8214844bd7e655f28ad3e1e97b068bf9be20a495 (patch)
tree282e1def27b363624b65205cf9ea10b0b79fc87c /textproc/ibus-kmfl
parent8f3ed402289aff90928ba7bba6f6266d692e2c29 (diff)
downloadports-8214844bd7e655f28ad3e1e97b068bf9be20a495.tar.gz
ports-8214844bd7e655f28ad3e1e97b068bf9be20a495.zip
* Unbreak ibus-kmfl build with new ibus-1.4.0.
PR: ports/163899 Submitted by: Nikola Lecic <nikola.lecic@anthesphoria.net> (maintainer)
Notes
Notes: svn path=/head/; revision=288740
Diffstat (limited to 'textproc/ibus-kmfl')
-rw-r--r--textproc/ibus-kmfl/Makefile4
-rw-r--r--textproc/ibus-kmfl/files/patch-src-main.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/textproc/ibus-kmfl/Makefile b/textproc/ibus-kmfl/Makefile
index d1b5b384b95c..cb5339f48ef0 100644
--- a/textproc/ibus-kmfl/Makefile
+++ b/textproc/ibus-kmfl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ibus-kmfl
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= SF/kmfl/${PORTNAME}/${PORTVERSION} \
http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
@@ -16,7 +16,7 @@ DIST_SUBDIR= kmfl
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= KMFL IMEngine for IBus framework
-LIB_DEPENDS= ibus.2:${PORTSDIR}/textproc/ibus \
+LIB_DEPENDS= ibus-1.0.400:${PORTSDIR}/textproc/ibus \
kmfl.0:${PORTSDIR}/textproc/libkmfl \
kmflcomp.0:${PORTSDIR}/textproc/kmflcomp
RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp
diff --git a/textproc/ibus-kmfl/files/patch-src-main.c b/textproc/ibus-kmfl/files/patch-src-main.c
new file mode 100644
index 000000000000..cb835414ad60
--- /dev/null
+++ b/textproc/ibus-kmfl/files/patch-src-main.c
@@ -0,0 +1,11 @@
+--- src/main.c 2010-05-05 01:49:36.000000000 +0400
++++ src/main.c 2012-01-06 21:36:53.000000000 +0300
+@@ -51,7 +51,7 @@
+ engines = ibus_component_get_engines (component);
+ for (p = engines; p != NULL; p = p->next) {
+ IBusEngineDesc *engine = (IBusEngineDesc *)p->data;
+- ibus_factory_add_engine (factory, engine->name, IBUS_TYPE_KMFL_ENGINE);
++ ibus_factory_add_engine (factory, ibus_engine_desc_get_name (engine), IBUS_TYPE_KMFL_ENGINE);
+ }
+
+ if (ibus) { \ No newline at end of file