aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus-table
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-17 05:04:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-17 05:04:48 +0000
commit4bcac3c77f783062d7110034ed9d703870c55e5c (patch)
treec832ca73b0927287da13cd7558fad1882386a0b7 /textproc/ibus-table
parent04b06643e4eea18b0a7b75f9d8e5824ce37013d9 (diff)
downloadports-4bcac3c77f783062d7110034ed9d703870c55e5c.tar.gz
ports-4bcac3c77f783062d7110034ed9d703870c55e5c.zip
Re-added port: textproc/ibus-table: Table-based input method framework for IBus (existed 2009/11/22-2017/04/30, deleted in r439826)
PR: 219638 Differential Revision: https://reviews.freebsd.org/D13547
Notes
Notes: svn path=/head/; revision=464755
Diffstat (limited to 'textproc/ibus-table')
-rw-r--r--textproc/ibus-table/Makefile38
-rw-r--r--textproc/ibus-table/distinfo3
-rw-r--r--textproc/ibus-table/pkg-descr6
-rw-r--r--textproc/ibus-table/pkg-plist48
4 files changed, 95 insertions, 0 deletions
diff --git a/textproc/ibus-table/Makefile b/textproc/ibus-table/Makefile
new file mode 100644
index 000000000000..f8fcc28c4d52
--- /dev/null
+++ b/textproc/ibus-table/Makefile
@@ -0,0 +1,38 @@
+# Created by: Nikola Lecic <nikola.lecic@anthesphoria.net>
+# $FreeBSD$
+
+PORTNAME= ibus-table
+DISTVERSION= 1.9.18
+CATEGORIES= textproc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Table-based input method framework for IBus
+
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ docbook2man:textproc/docbook-utils \
+ docbook-sgml>0:textproc/docbook-sgml
+LIB_DEPENDS= libibus-1.0.so:textproc/ibus
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
+
+USES= autoreconf gmake pkgconfig python:3.4+
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= kaio
+USE_GNOME= pygtk2
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/|${PREFIX}/|g" ${WRKSRC}/engine/*.py
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DATADIR}/*/__pycache__
+
+.include <bsd.port.mk>
diff --git a/textproc/ibus-table/distinfo b/textproc/ibus-table/distinfo
new file mode 100644
index 000000000000..85cac03728d2
--- /dev/null
+++ b/textproc/ibus-table/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513729438
+SHA256 (kaio-ibus-table-1.9.18_GH0.tar.gz) = 63526e452975000b65b20481ca02d5d75a46a36af987349fc47806b7656d4625
+SIZE (kaio-ibus-table-1.9.18_GH0.tar.gz) = 467331
diff --git a/textproc/ibus-table/pkg-descr b/textproc/ibus-table/pkg-descr
new file mode 100644
index 000000000000..c0010377eb56
--- /dev/null
+++ b/textproc/ibus-table/pkg-descr
@@ -0,0 +1,6 @@
+This is the table based input method framework for IBus (Intelligent Input
+Bus). It does not include real tables except two demo layouts, "Compose"
+(which mimics Compose Key input) and "LaTeX" (which allows you to use LaTeX
+commands as keyboard sequences to input various symbols).
+
+WWW: https://github.com/kaio/ibus-table
diff --git a/textproc/ibus-table/pkg-plist b/textproc/ibus-table/pkg-plist
new file mode 100644
index 000000000000..052c43919df9
--- /dev/null
+++ b/textproc/ibus-table/pkg-plist
@@ -0,0 +1,48 @@
+bin/ibus-table-createdb
+libdata/pkgconfig/ibus-table.pc
+libexec/ibus-engine-table
+libexec/ibus-setup-table
+man/man1/ibus-table-createdb.1.gz
+share/applications/ibus-setup-table.desktop
+%%DATADIR%%/data/pinyin_table.txt.bz2
+%%DATADIR%%/engine/chinese_variants.py
+%%DATADIR%%/engine/factory.py
+%%DATADIR%%/engine/ibus_table_location.py
+%%DATADIR%%/engine/main.py
+%%DATADIR%%/engine/tabcreatedb.py
+%%DATADIR%%/engine/table.py
+%%DATADIR%%/engine/tabsqlitedb.py
+%%DATADIR%%/icons/acommit.svg
+%%DATADIR%%/icons/cb-mode.svg
+%%DATADIR%%/icons/chinese.svg
+%%DATADIR%%/icons/english.svg
+%%DATADIR%%/icons/full-letter.svg
+%%DATADIR%%/icons/full-punct.svg
+%%DATADIR%%/icons/half-letter.svg
+%%DATADIR%%/icons/half-punct.svg
+%%DATADIR%%/icons/ibus-table.svg
+%%DATADIR%%/icons/ncommit.svg
+%%DATADIR%%/icons/onechar.svg
+%%DATADIR%%/icons/phrase.svg
+%%DATADIR%%/icons/py-mode.svg
+%%DATADIR%%/icons/sc-mode.svg
+%%DATADIR%%/icons/scb-mode.svg
+%%DATADIR%%/icons/tab-mode.svg
+%%DATADIR%%/icons/tc-mode.svg
+%%DATADIR%%/icons/tcb-mode.svg
+%%DATADIR%%/setup/ibus-table-preferences.ui
+%%DATADIR%%/setup/main.py
+%%DATADIR%%/setup/version.py
+%%DATADIR%%/tables/template.txt
+share/ibus/component/table.xml
+%%NLS%%share/locale/ca/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/de/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-table.mo
+%%NLS%%share/metainfo/ibus-table.appdata.xml