aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2014-12-22 23:04:17 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2014-12-22 23:04:17 +0000
commit3c9a1d11c2210dcdc42a63b04622220896daba7a (patch)
treec4aafe980f6f5ff7e0903fde047107a9dd8c45d5 /textproc/ibus
parentf04a3f032a75a0a2a7378cf4edf2becfbdacaf25 (diff)
downloadports-3c9a1d11c2210dcdc42a63b04622220896daba7a.tar.gz
ports-3c9a1d11c2210dcdc42a63b04622220896daba7a.zip
Final removal of WITH_NEW_XORG
This knob was turned on for all version of FreeBSD in r369875 (2014-10-03) and officially deprecated. Since then, it was gradually removed from many ports when they needed an update. x11-servers/xorg-server was the last major user of this knob. The port was updated to xserver 1.14 in r374982 (2014-12-19). The update got rid of the knob, clearing the path to the final removal. This commit changes ports who were checking for WITH_NEW_XORG and remove its handling from bsd.port.mk. While here, two sanity checks are added to warn user about WITH_KMS and WITH_NEW_XORG which have no effect now. Differential Revision: https://reviews.freebsd.org/D1351 Reviewed by: antoine, bapt, kwm Approved by: portmgr (antoine, bapt), kwm
Notes
Notes: svn path=/head/; revision=375286
Diffstat (limited to 'textproc/ibus')
-rw-r--r--textproc/ibus/Makefile5
-rw-r--r--textproc/ibus/files/extra-xigrabkeycode29
2 files changed, 0 insertions, 34 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index b9cf94f3d545..a07bea582ac0 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -107,11 +107,6 @@ PLIST_SUB+= COMPDIR=""
PLIST_SUB+= COMPDIR="@comment "
.endif
-# Workaround XIGrabKeycode/XIUngrabKeycode bug: XIAllMasterDevice does not work
-.if !defined(WITH_NEW_XORG)
-EXTRA_PATCHES+= ${FILESDIR}/extra-xigrabkeycode
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/var/lib/dbus|/var/db/dbus|g' ${WRKSRC}/src/ibusshare.c
diff --git a/textproc/ibus/files/extra-xigrabkeycode b/textproc/ibus/files/extra-xigrabkeycode
deleted file mode 100644
index ed0d9723e595..000000000000
--- a/textproc/ibus/files/extra-xigrabkeycode
+++ /dev/null
@@ -1,29 +0,0 @@
---- ui/gtk3/keybindingmanager.vala.orig 2014-02-03 14:11:48.000000000 -0500
-+++ ui/gtk3/keybindingmanager.vala 2014-02-03 14:12:18.000000000 -0500
-@@ -35,6 +35,8 @@
- Gdk.ModifierType.HYPER_MASK |
- Gdk.ModifierType.META_MASK);
-
-+ public static const int META_CORE_KEYBOARD_ID = 3;
-+
- /**
- * Helper class to store keybinding
- */
-@@ -254,7 +256,7 @@
- XI.set_mask(evmask.mask, XI.EventType.KeyRelease);
-
- int retval = XI.grab_keycode (xdisplay,
-- XI.AllMasterDevices,
-+ META_CORE_KEYBOARD_ID,
- keycode,
- xdisplay.default_root_window(),
- X.GrabMode.Async,
-@@ -275,7 +277,7 @@
- }
-
- int retval = XI.ungrab_keycode (xdisplay,
-- XI.AllMasterDevices,
-+ META_CORE_KEYBOARD_ID,
- keycode,
- xdisplay.default_root_window(),
- get_grab_modifiers(modifiers));