aboutsummaryrefslogtreecommitdiff
path: root/textproc/ibus
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-02-08 18:48:04 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-02-08 18:48:04 +0000
commit4ffdccc0625ff6d24552d8bd8a6b8aedd511a771 (patch)
tree3b54b9b74720bae806399c1899fdb7ddd2b756c9 /textproc/ibus
parent1d8e0935ba5cd2b9d40977b0b52b41c764df4915 (diff)
downloadports-4ffdccc0625ff6d24552d8bd8a6b8aedd511a771.tar.gz
ports-4ffdccc0625ff6d24552d8bd8a6b8aedd511a771.zip
textproc/ibus: 1.5.5 -> 1.5.9
For changes see https://github.com/ibus/ibus/commits/master This also fixes the build problem reported by martin.dieringer@gmx.de. PR: 195219 Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=378669
Diffstat (limited to 'textproc/ibus')
-rw-r--r--textproc/ibus/Makefile20
-rw-r--r--textproc/ibus/distinfo4
-rw-r--r--textproc/ibus/pkg-plist30
3 files changed, 30 insertions, 24 deletions
diff --git a/textproc/ibus/Makefile b/textproc/ibus/Makefile
index a07bea582ac0..3f638322bc93 100644
--- a/textproc/ibus/Makefile
+++ b/textproc/ibus/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= ibus
-PORTVERSION= 1.5.5
-PORTREVISION= 3
+PORTVERSION= 1.5.9
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/ \
+ http://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= Intelligent Input Bus for Linux / Unix OS
@@ -13,17 +13,15 @@ COMMENT= Intelligent Input Bus for Linux / Unix OS
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus \
- librsvg2>=2.0:${PORTSDIR}/graphics/librsvg2
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0.83.0:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/__init__.py:${PORTSDIR}/devel/py-notify \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg \
- librsvg2>=2.0:${PORTSDIR}/graphics/librsvg2 \
setxkbmap:${PORTSDIR}/x11/setxkbmap
LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USES= compiler gmake libtool pathfix pkgconfig python
-USE_GNOME= pygobject3
+USE_GNOME= glib20 librsvg2 pygobject3
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
@@ -63,7 +61,7 @@ GTK3_USE= GNOME=gtk30
GTK3_CONFIGURE_ENABLE= gtk3 libnotify
GTK3_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
-VALA_BUILD_DEPENDS= vala>=0.16:${PORTSDIR}/lang/vala
+VALA_BUILD_DEPENDS= vala>=0.20:${PORTSDIR}/lang/vala
VALA_CONFIGURE_ENABLE= vala
GINTRO_BUILD_DEPENDS= gobject-introspection>=0.6.8:${PORTSDIR}/devel/gobject-introspection
@@ -108,10 +106,10 @@ PLIST_SUB+= COMPDIR="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/var/lib/dbus|/var/db/dbus|g' ${WRKSRC}/src/ibusshare.c
+ ${REINPLACE_CMD} -e 's|/var/lib/dbus|/var/db/dbus|g' ${WRKSRC}/src/ibusshare.c
post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/autostart
- @${INSTALL_DATA} ${PATCHDIR}/ibus.desktop ${STAGEDIR}${PREFIX}/etc/xdg/autostart
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/xdg/autostart
+ ${INSTALL_DATA} ${PATCHDIR}/ibus.desktop ${STAGEDIR}${PREFIX}/etc/xdg/autostart
.include <bsd.port.post.mk>
diff --git a/textproc/ibus/distinfo b/textproc/ibus/distinfo
index 05ad5d2501a1..7fac4b171dea 100644
--- a/textproc/ibus/distinfo
+++ b/textproc/ibus/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ibus-1.5.5.tar.gz) = 02ab36af6048399fedbe8d85074b161219b89df5020932df33cf8829764f8aec
-SIZE (ibus-1.5.5.tar.gz) = 2063794
+SHA256 (ibus-1.5.9.tar.gz) = ad41014aa3cb961854ee0aa392a5abd7452fab2c6b77d8ff2d736b7405b48ac6
+SIZE (ibus-1.5.9.tar.gz) = 2128459
diff --git a/textproc/ibus/pkg-plist b/textproc/ibus/pkg-plist
index 297b3861a435..ec856f953b38 100644
--- a/textproc/ibus/pkg-plist
+++ b/textproc/ibus/pkg-plist
@@ -51,7 +51,7 @@ include/ibus-1.0/ibusenginesimple.h
%%GTK3%%lib/gtk-3.0/3.0.0/immodules/im-ibus.so
lib/libibus-1.0.so
lib/libibus-1.0.so.5
-lib/libibus-1.0.so.5.0.505
+lib/libibus-1.0.so.5.0.509
%%PYTHON_LIB%%%%PYTHON_SITELIBDIR%%/ibus/__init__.py
%%PYTHON_LIB%%%%PYTHON_SITELIBDIR%%/ibus/__init__.pyc
%%PYTHON_LIB%%%%PYTHON_SITELIBDIR%%/ibus/__init__.pyo
@@ -218,6 +218,9 @@ share/applications/ibus-setup.desktop
%%PORTDOCS%%%%DOCSDIR%%/right.png
%%PORTDOCS%%%%DOCSDIR%%/style.css
%%PORTDOCS%%%%DOCSDIR%%/up.png
+%%PORTDOCS%%%%DOCSDIR%%/left-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%/right-insensitive.png
+%%PORTDOCS%%%%DOCSDIR%%/up-insensitive.png
%%GTK3%%%%DATADIR%%/component/gtkpanel.xml
%%GCONF%%%%DATADIR%%/component/gconf.xml
%%DCONF%%%%DATADIR%%/component/dconf.xml
@@ -234,6 +237,9 @@ share/applications/ibus-setup.desktop
%%DATADIR%%/setup/enginecombobox.py
%%DATADIR%%/setup/enginecombobox.pyc
%%DATADIR%%/setup/enginecombobox.pyo
+%%DATADIR%%/setup/enginedialog.py
+%%DATADIR%%/setup/enginedialog.pyc
+%%DATADIR%%/setup/enginedialog.pyo
%%DATADIR%%/setup/enginetreeview.py
%%DATADIR%%/setup/enginetreeview.pyc
%%DATADIR%%/setup/enginetreeview.pyo
@@ -274,6 +280,7 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%NLS%%share/locale/fa/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/fr/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/gu/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/he/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/hi/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/hu/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/ia/LC_MESSAGES/ibus10.mo
@@ -297,6 +304,7 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%NLS%%share/locale/te/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/tg/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/uk/LC_MESSAGES/ibus10.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/vi/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/ibus10.mo
%%NLS%%share/locale/zh_HK/LC_MESSAGES/ibus10.mo
@@ -305,16 +313,16 @@ share/icons/hicolor/scalable/apps/ibus.svg
%%VALA%%share/vala/vapi/ibus-1.0.vapi
share/bash-completion/completions/ibus.bash
%%DCONF%%share/GConf/gsettings/ibus.convert
-@dirrm %%DATADIR%%/setup
-@dirrmtry %%DATADIR%%/keymaps
-@dirrmtry %%DATADIR%%/engine
-%%COMPDIR%%@dirrmtry %%DATADIR%%/component
-@dirrmtry %%DATADIR%%
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PYTHON_LIB%%@dirrm %%PYTHON_SITELIBDIR%%/ibus/interface
-%%PYTHON_LIB%%@dirrm %%PYTHON_SITELIBDIR%%/ibus
-@dirrm include/ibus-1.0
-%%DCONF%%@dirrmtry etc/dconf/db/ibus.d
+@dir %%DATADIR%%/setup
+@dir %%DATADIR%%/keymaps
+@dir %%DATADIR%%/engine
+%%COMPDIR%%@dir %%DATADIR%%/component
+@dir %%DATADIR%%
+%%PORTDOCS%%@dir %%DOCSDIR%%
+%%PYTHON_LIB%%@dir %%PYTHON_SITELIBDIR%%/ibus/interface
+%%PYTHON_LIB%%@dir %%PYTHON_SITELIBDIR%%/ibus
+@dir include/ibus-1.0
+%%DCONF%%@dir etc/dconf/db/ibus.d
%%GTK3%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 --update-cache
%%GTK2%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
%%GTK3%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 --update-cache