aboutsummaryrefslogtreecommitdiff
path: root/textproc/info2man
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 10:02:58 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 10:02:58 +0000
commit5d3ed282b0d5baf51ed27158b9c1cf9124e6e1bd (patch)
tree2419511f961059f8e30f20103252f9c78249e328 /textproc/info2man
parent856704a6d19af5877048bbf7698ba31abc39a587 (diff)
downloadports-5d3ed282b0d5baf51ed27158b9c1cf9124e6e1bd.tar.gz
ports-5d3ed282b0d5baf51ed27158b9c1cf9124e6e1bd.zip
- Support staging
- Use shebangfix - Use COPYTREE_SHARE istead of CP
Notes
Notes: svn path=/head/; revision=346314
Diffstat (limited to 'textproc/info2man')
-rw-r--r--textproc/info2man/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/info2man/Makefile b/textproc/info2man/Makefile
index 26c72dd10cb7..91226785c18a 100644
--- a/textproc/info2man/Makefile
+++ b/textproc/info2man/Makefile
@@ -11,19 +11,19 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Translate GNU info files into man pages
-USES= perl5
+USES= perl5 shebangfix
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLSCRIPTS= info2man info2pod
+SHEBANG_FILES= info2pod
-NO_STAGE= yes
pre-configure:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/info2pod
do-install:
- ${INSTALL_SCRIPT} ${PLSCRIPTS:S|^|${WRKSRC}/|} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/cs ${DATADIR}
+ ${INSTALL_SCRIPT} ${PLSCRIPTS:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} cs ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>