aboutsummaryrefslogtreecommitdiff
path: root/textproc/info2man
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-01-23 21:55:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-01-23 21:55:46 +0000
commit797b6b5689e0475d08f6c67bfead77f524eb57ac (patch)
tree96d141bffe589a9c3838492ca8b5f8bdeaf0c701 /textproc/info2man
parentbf4f53c67586eb1803b33c4ff86ce5ab5162f656 (diff)
downloadports-797b6b5689e0475d08f6c67bfead77f524eb57ac.tar.gz
ports-797b6b5689e0475d08f6c67bfead77f524eb57ac.zip
Add info2man: translate GNU info files into man pages.
Notes
Notes: svn path=/head/; revision=127150
Diffstat (limited to 'textproc/info2man')
-rw-r--r--textproc/info2man/Makefile33
-rw-r--r--textproc/info2man/distinfo2
-rw-r--r--textproc/info2man/files/patch-info2pod11
-rw-r--r--textproc/info2man/pkg-descr9
-rw-r--r--textproc/info2man/pkg-plist15
5 files changed, 70 insertions, 0 deletions
diff --git a/textproc/info2man/Makefile b/textproc/info2man/Makefile
new file mode 100644
index 000000000000..df4d6b878fa0
--- /dev/null
+++ b/textproc/info2man/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: info2man
+# Date created: 19 January 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= info2man
+PORTVERSION= 20040717
+CATEGORIES= textproc
+MASTER_SITES= http://www.cskk.ezoshosting.com/cs/css/
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Translate GNU info files into man pages
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+PLSCRIPTS= info2man info2pod
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|' ${WRKSRC}/info2pod
+
+do-install:
+ ${INSTALL_SCRIPT} ${PLSCRIPTS:S|^|${WRKSRC}/|} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/cs ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/info2man/distinfo b/textproc/info2man/distinfo
new file mode 100644
index 000000000000..17b59fb5445e
--- /dev/null
+++ b/textproc/info2man/distinfo
@@ -0,0 +1,2 @@
+MD5 (info2man-20040717/info2man.tar.gz) = 303b9bf313e88558ff577806398f6c4c
+SIZE (info2man-20040717/info2man.tar.gz) = 22263
diff --git a/textproc/info2man/files/patch-info2pod b/textproc/info2man/files/patch-info2pod
new file mode 100644
index 000000000000..7da050adb9f0
--- /dev/null
+++ b/textproc/info2man/files/patch-info2pod
@@ -0,0 +1,11 @@
+--- info2pod.orig Fri Apr 9 10:03:56 2004
++++ info2pod Sat Jan 22 21:23:24 2005
+@@ -28,6 +28,8 @@
+
+ use strict qw(vars);
+
++use lib '%%DATADIR%%/';
++
+ use cs::Misc;
+ use cs::Sink;
+ use cs::GNUInfo;
diff --git a/textproc/info2man/pkg-descr b/textproc/info2man/pkg-descr
new file mode 100644
index 000000000000..b590dd224b43
--- /dev/null
+++ b/textproc/info2man/pkg-descr
@@ -0,0 +1,9 @@
+info2man converts GNU info files to pod or -man formats.
+
+GNU info can be a pain as it demands its own special pager, it's a binary
+format, it's cruder than HTML and less documented, and most GNU- authored
+manual entries basically say "we like info so we don't maintain this manual
+entry, thus it is probably wrong". info2man thus converts info files so that
+they can be read by ordinary tools.
+
+WWW: http://www.cskk.ezoshosting.com/cs/css/info2pod.html
diff --git a/textproc/info2man/pkg-plist b/textproc/info2man/pkg-plist
new file mode 100644
index 000000000000..a2b7fa181d76
--- /dev/null
+++ b/textproc/info2man/pkg-plist
@@ -0,0 +1,15 @@
+bin/info2man
+bin/info2pod
+%%DATADIR%%/cs/DEBUG.pm
+%%DATADIR%%/cs/GNUInfo.pm
+%%DATADIR%%/cs/GNUInfo/Node.pm
+%%DATADIR%%/cs/IO.pm
+%%DATADIR%%/cs/Math.pm
+%%DATADIR%%/cs/Misc.pm
+%%DATADIR%%/cs/Object.pm
+%%DATADIR%%/cs/Pathname.pm
+%%DATADIR%%/cs/Sink.pm
+%%DATADIR%%/cs/Source.pm
+@dirrm %%DATADIR%%/cs/GNUInfo
+@dirrm %%DATADIR%%/cs
+@dirrm %%DATADIR%%