aboutsummaryrefslogtreecommitdiff
path: root/textproc/jaxup
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-17 03:02:13 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-17 03:02:13 +0000
commit87d3dd19f71d9be5d4e2eb639259de4f74b8b473 (patch)
tree44a230a70224a30692e0a577a79d53c5e8b73999 /textproc/jaxup
parentdb5631a72d6903249c261b2c84754da66e094031 (diff)
downloadports-87d3dd19f71d9be5d4e2eb639259de4f74b8b473.tar.gz
ports-87d3dd19f71d9be5d4e2eb639259de4f74b8b473.zip
A Java XML Update engine
Jaxup defines an interface to update XML documents, through which clients can work without knowledge of the exact object model that the document uses. The interface is called Updater, and the idea behind it is the same as with Jaxen's Navigator interface. In addition, an implementation of xmldb.org's proposed XUpdate specification is provided. The implementation is in the XUpdate class. Implementations of the Updater interface are provided for the following object models: - DOM - Dom4j - JDom WWW: http://klomp.org/jaxup/
Notes
Notes: svn path=/head/; revision=121788
Diffstat (limited to 'textproc/jaxup')
-rw-r--r--textproc/jaxup/Makefile56
-rw-r--r--textproc/jaxup/distinfo2
-rw-r--r--textproc/jaxup/files/build.xml63
-rw-r--r--textproc/jaxup/pkg-descr14
4 files changed, 135 insertions, 0 deletions
diff --git a/textproc/jaxup/Makefile b/textproc/jaxup/Makefile
new file mode 100644
index 000000000000..f0370d779ef8
--- /dev/null
+++ b/textproc/jaxup/Makefile
@@ -0,0 +1,56 @@
+# Ports collection makefile for: Jaxup
+# Date created: 17 November 2004
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= jaxup
+PORTVERSION= 1.01
+CATEGORIES= textproc java
+MASTER_SITES= http://klomp.org/jaxup/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Java XUpdate engine
+
+RUN_DEPENDS= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom \
+ ${JAVALIBDIR}/jaxen-core.jar:${PORTSDIR}/java/jaxen \
+ ${JAVALIBDIR}/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+
+USE_ANT= yes
+ALL_TARGET= jar
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= docs
+.endif
+
+PLIST_FILES+= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= LICENSE.txt api index.html jaxup_files xupdate-wd.html xupdate-wd_files
+.endif
+
+post-extract:
+ @${CP} ${FILESDIR}/build.xml ${WRKSRC}/
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR files as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/build/lib/${PORTNAME}.jar ${JAVAJARDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/build/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DOCSDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/jaxup/distinfo b/textproc/jaxup/distinfo
new file mode 100644
index 000000000000..483c06174571
--- /dev/null
+++ b/textproc/jaxup/distinfo
@@ -0,0 +1,2 @@
+MD5 (jaxup-1.01-src.zip) = b7ec19cdf4e27fb165a60782d986bdc2
+SIZE (jaxup-1.01-src.zip) = 1836884
diff --git a/textproc/jaxup/files/build.xml b/textproc/jaxup/files/build.xml
new file mode 100644
index 000000000000..bd3fa60a7337
--- /dev/null
+++ b/textproc/jaxup/files/build.xml
@@ -0,0 +1,63 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- $FreeBSD$ -->
+
+<project name="jaxup" default="jar" basedir=".">
+
+ <property name="project.version" value="1.01"/>
+
+ <property name="build.dir" value="build"/>
+ <property name="build.classes.dir" value="${build.dir}/classes"/>
+ <property name="build.lib.dir" value="${build.dir}/lib"/>
+ <property name="build.docs.dir" value="${build.dir}/docs"/>
+ <property name="build.apidocs.dir" value="${build.docs.dir}/api"/>
+ <property name="src.dir" value="src"/>
+ <property name="src.java.dir" value="${src.dir}/java"/>
+ <property name="src.docs.dir" value="${src.dir}/doc"/>
+ <property name="src.tests.dir" value="${src.dir}/test"/>
+ <property name="lib.dir" value="lib"/>
+ <property name="project.fullname" value="${ant.project.name}-${project.version}"/>
+ <property name="jar.file" value="${build.lib.dir}/${ant.project.name}.jar"/>
+
+ <path id="project.classpath">
+ <pathelement path="${build.classes.dir}"/>
+ <fileset dir="${lib.dir}" includes="**.jar"/>
+ </path>
+
+ <target name="build" description="Compile Core Java sources">
+ <mkdir dir="${build.classes.dir}"/>
+ <javac srcdir="${src.java.dir}" destdir="${build.classes.dir}" deprecation="true" debug="Yes">
+ <classpath refid="project.classpath"/>
+ </javac>
+ </target>
+
+ <target name="clean" description="Delete built classes, docs, and JAR files">
+ <delete dir="${build.dir}"/>
+ </target>
+
+ <target name="rebuild" depends="clean, build" description="(Re)compile Java sources"/>
+
+ <target name="jar" depends="build" description="Pack the JARs">
+ <mkdir dir="${build.lib.dir}"/>
+ <jar destfile="${jar.file}">
+ <manifest>
+ <attribute name="Built-By" value="${user.name}"/>
+ </manifest>
+ <fileset dir="${build.classes.dir}" includes="**/*.class"/>
+ </jar>
+ </target>
+
+ <target name="docs" depends="apidocs" description="Build project docs">
+ <copy todir="${build.docs.dir}">
+ <fileset dir="${src.docs.dir}"/>
+ </copy>
+ </target>
+
+ <target name="apidocs" depends="build" unless="noapidocs" description="Build the API docs (with javadoc)">
+ <mkdir dir="${build.apidocs.dir}"/>
+ <javadoc destdir="${build.apidocs.dir}" windowtitle="${project.fullname}" author="true" version="true" use="true">
+ <fileset dir="${src.java.dir}"/>
+ <classpath refid="project.classpath"/>
+ </javadoc>
+ </target>
+
+</project>
diff --git a/textproc/jaxup/pkg-descr b/textproc/jaxup/pkg-descr
new file mode 100644
index 000000000000..9acaff35a7eb
--- /dev/null
+++ b/textproc/jaxup/pkg-descr
@@ -0,0 +1,14 @@
+Jaxup defines an interface to update XML documents, through which clients can
+work without knowledge of the exact object model that the document uses. The
+interface is called Updater, and the idea behind it is the same as with Jaxen's
+Navigator interface. In addition, an implementation of xmldb.org's proposed
+XUpdate specification is provided. The implementation is in the XUpdate class.
+
+Implementations of the Updater interface are provided for the following object
+models:
+
+ - DOM
+ - Dom4j
+ - JDom
+
+WWW: http://klomp.org/jaxup/