aboutsummaryrefslogtreecommitdiff
path: root/textproc/jid
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-02-23 14:48:55 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-02-23 14:48:55 +0000
commit1bc809a076590c6df8ca61ebfc195aa4921a3ded (patch)
treeb1e27ba41a6b719a6683506ab1227ee50489571a /textproc/jid
parent9f8fdd34bd8c4cdf17ed908d4052fb56b91328ee (diff)
downloadports-1bc809a076590c6df8ca61ebfc195aa4921a3ded.tar.gz
ports-1bc809a076590c6df8ca61ebfc195aa4921a3ded.zip
Fix USE_GITHUB usage.
(USES=go needs a bit more work though.) Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=434671
Diffstat (limited to 'textproc/jid')
-rw-r--r--textproc/jid/Makefile33
1 files changed, 9 insertions, 24 deletions
diff --git a/textproc/jid/Makefile b/textproc/jid/Makefile
index 896b5e75966e..b6fde4d765dc 100644
--- a/textproc/jid/Makefile
+++ b/textproc/jid/Makefile
@@ -13,35 +13,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= simeji
-GH_TUPLE= bitly:go-simplejson:aabad6e:simplejson \
- fatih:color:7824417:color \
- mattn:go-runewidth:9e777a8:runewidth \
- nsf:termbox-go:3540b76:termbox \
- nwidger:jsoncolor:75a6de4:jsoncolor \
- pkg:errors:645ef00:errors
+GH_SUBDIR= src/github.com/simeji/jid
+GH_TUPLE= bitly:go-simplejson:aabad6e:simplejson/src/github.com/bitly/go-simplejson \
+ fatih:color:7824417:color/src/github.com/fatih/color \
+ mattn:go-runewidth:9e777a8:runewidth/src/github.com/mattn/go-runewidth \
+ nsf:termbox-go:3540b76:termbox/src/github.com/nsf/termbox-go \
+ nwidger:jsoncolor:75a6de4:jsoncolor/src/github.com/nwidger/jsoncolor \
+ pkg:errors:645ef00:errors/src/github.com/pkg/errors
USES= go
PLIST_FILES= bin/jid
-pre-build: .SILENT
- ${MKDIR} ${WRKDIR}/src/github.com/mattn
- ${MV} ${WRKDIR}/go-runewidth-9e777a8 ${WRKDIR}/src/github.com/mattn/go-runewidth
- ${MKDIR} ${WRKDIR}/src/github.com/fatih
- ${MV} ${WRKDIR}/color-7824417 ${WRKDIR}/src/github.com/fatih/color
- ${MKDIR} ${WRKDIR}/src/github.com/bitly
- ${MV} ${WRKDIR}/go-simplejson-aabad6e ${WRKDIR}/src/github.com/bitly/go-simplejson
- ${MKDIR} ${WRKDIR}/src/github.com/nsf
- ${MV} ${WRKDIR}/termbox-go-3540b76 ${WRKDIR}/src/github.com/nsf/termbox-go
- ${MKDIR} ${WRKDIR}/src/github.com/nwidger
- ${MV} ${WRKDIR}/jsoncolor-75a6de4 ${WRKDIR}/src/github.com/nwidger/jsoncolor
- ${MKDIR} ${WRKDIR}/src/github.com/pkg
- ${MV} ${WRKDIR}/errors-645ef00 ${WRKDIR}/src/github.com/pkg/errors
- ${MKDIR} ${WRKDIR}/src/github.com/simeji
- ${CP} -r ${WRKDIR}/jid-${PORTVERSION} ${WRKDIR}/src/github.com/simeji/jid
-
do-build:
- @(cd ${WRKDIR}/src/github.com/simeji/jid; \
- ${SETENV} ${GO_ENV} ${GO_CMD} build -v -o ${WRKDIR}/bin/jid cmd/jid/jid.go)
+ @(cd ${WRKSRC}; \
+ ${SETENV} ${GO_ENV} GOPATH=${WRKSRC} ${GO_CMD} build -v -o ${WRKSRC}/bin/jid cmd/jid/jid.go)
.include <bsd.port.mk>