aboutsummaryrefslogtreecommitdiff
path: root/textproc/jshon
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-23 13:53:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-23 13:53:45 +0000
commitb7d57b373b1e9de553bda92739d105052f598410 (patch)
treee7e1b0a1838942c39925dbc0d1aee6f8240b43b3 /textproc/jshon
parent85e5d891e09fd8bb816b0c8ca2010a9c441f556d (diff)
downloadports-b7d57b373b1e9de553bda92739d105052f598410.tar.gz
ports-b7d57b373b1e9de553bda92739d105052f598410.zip
jshon parses, reads and creates JSON. It is designed to be as usable as possible
from within the shell and replaces fragile adhoc parsers made from grep/sed/awk as well as heavyweight one-line parsers made from perl/python. WWW: http://kmkeen.com/jshon/
Notes
Notes: svn path=/head/; revision=310867
Diffstat (limited to 'textproc/jshon')
-rw-r--r--textproc/jshon/Makefile32
-rw-r--r--textproc/jshon/distinfo2
-rw-r--r--textproc/jshon/pkg-descr5
3 files changed, 39 insertions, 0 deletions
diff --git a/textproc/jshon/Makefile b/textproc/jshon/Makefile
new file mode 100644
index 000000000000..e6c15b4b5cd7
--- /dev/null
+++ b/textproc/jshon/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= jshon
+PORTVERSION= 20121210
+CATEGORIES= textproc
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= json parser for the shell.
+
+LICENSE= MIT
+
+LIB_DEPENDS= jansson:${PORTSDIR}/devel/jansson
+
+USE_GMAKE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= keenerd
+GH_COMMIT= b21bc98
+GH_TAGNAME= ${GH_COMMIT}
+
+CFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-ljansson,-L${LOCALBASE}/lib -ljansson,g' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/jshon/distinfo b/textproc/jshon/distinfo
new file mode 100644
index 000000000000..73b4487f952e
--- /dev/null
+++ b/textproc/jshon/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jshon-20121210.tar.gz) = 130d6b8536dd8ea6b31394f5d5ff5e63f941f54e70b2fac68d9e0ce147b1b4db
+SIZE (jshon-20121210.tar.gz) = 10712
diff --git a/textproc/jshon/pkg-descr b/textproc/jshon/pkg-descr
new file mode 100644
index 000000000000..d757ef4e352b
--- /dev/null
+++ b/textproc/jshon/pkg-descr
@@ -0,0 +1,5 @@
+jshon parses, reads and creates JSON. It is designed to be as usable as possible
+from within the shell and replaces fragile adhoc parsers made from grep/sed/awk
+as well as heavyweight one-line parsers made from perl/python.
+
+WWW: http://kmkeen.com/jshon/