aboutsummaryrefslogtreecommitdiff
path: root/textproc/jtc
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-03-07 08:19:27 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-03-07 08:19:27 +0000
commita2bf5325921bc264307ed4aedf1467983b291e8e (patch)
treedba871d59881c891d1f449df5b5485d656f5c203 /textproc/jtc
parente6dc31c85f6916eb8575c8c52c4b9156b8ceaacc (diff)
downloadports-a2bf5325921bc264307ed4aedf1467983b291e8e.tar.gz
ports-a2bf5325921bc264307ed4aedf1467983b291e8e.zip
New port: textproc/jtc: CLI tool to extract, manipulate and transform JSON
Simple but efficient cli utility tool to manipulate JSON data. Offering a powerful way to select one or multiple elements from a source JSON and apply various actions on the selected elements at once, e.g. wrap selected elements into a new JSON, filter in/out, sort elements, update elements, insert new elements, remove, copy, move, compare, transform, swap around and many other operations. WWW: https://github.com/ldn-softdev/jtc PR: 244643 Submitted by: Lewis Cook <vulcan@wired.sh>
Notes
Notes: svn path=/head/; revision=527923
Diffstat (limited to 'textproc/jtc')
-rw-r--r--textproc/jtc/Makefile36
-rw-r--r--textproc/jtc/distinfo3
-rw-r--r--textproc/jtc/pkg-descr10
3 files changed, 49 insertions, 0 deletions
diff --git a/textproc/jtc/Makefile b/textproc/jtc/Makefile
new file mode 100644
index 000000000000..4829201fc62f
--- /dev/null
+++ b/textproc/jtc/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= jtc
+DISTVERSION= 1.75d
+CATEGORIES= textproc
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= CLI tool to extract, manipulate and transform JSON
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= compiler:c++14-lang
+USE_CXXSTD= c++14
+USE_GITHUB= yes
+GH_ACCOUNT= ldn-softdev
+
+LDFLAGS+= -lexecinfo
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md Release\ Notes.md User\ Guide.md \
+ Walk-path\ tutorial.md
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ ${CXX} ${CXXFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.cpp -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/jtc/distinfo b/textproc/jtc/distinfo
new file mode 100644
index 000000000000..1587aade17e1
--- /dev/null
+++ b/textproc/jtc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1583518848
+SHA256 (ldn-softdev-jtc-1.75d_GH0.tar.gz) = e490a754be493660ef4f2e764ea121b5c39b280adf9b4c55d73e4876e8618f04
+SIZE (ldn-softdev-jtc-1.75d_GH0.tar.gz) = 206457
diff --git a/textproc/jtc/pkg-descr b/textproc/jtc/pkg-descr
new file mode 100644
index 000000000000..6182980f52f6
--- /dev/null
+++ b/textproc/jtc/pkg-descr
@@ -0,0 +1,10 @@
+Simple but efficient cli utility tool to manipulate
+JSON data. Offering a powerful way to select one or
+multiple elements from a source JSON and apply various
+actions on the selected elements at once, e.g. wrap
+selected elements into a new JSON, filter in/out,
+sort elements, update elements, insert new elements,
+remove, copy, move, compare, transform, swap around
+and many other operations.
+
+WWW: https://github.com/ldn-softdev/jtc