aboutsummaryrefslogtreecommitdiff
path: root/textproc/kmfl-sil-yi/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-05-29 13:28:25 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-05-29 13:28:25 +0000
commit7da81d324008555292e1dde1fddcd8c9fd99f1ee (patch)
treed9c454e21c78ac8e86d6741af9a2646c2bb511b2 /textproc/kmfl-sil-yi/Makefile
parent36eae5ec7d9f2ba945a632013c3defaf227fbb4f (diff)
downloadports-7da81d324008555292e1dde1fddcd8c9fd99f1ee.tar.gz
ports-7da81d324008555292e1dde1fddcd8c9fd99f1ee.zip
- Patch SCIM KMFL engine (textproc/scim-kmfl-imengine) to use
the same neutral keyboard repository as textproc/ibus-kmfl does, ${LOCALBASE}/share/kmfl/. This approach is similar to m17n (its keyboard databases, devel/m17n-db and textproc/m17n-contrib, are shared between textproc/scim-m17n and textproc/ibus-m17n). This patch also makes both these KMFL engine ports to read ~/.kmfl/ instead of SCIM-oriented ~/.scim/kmfl/. There is UPDATING text that informs KMFL users about this. - Patch keyboard ports (7 of them) to install data to the new repository, ${LOCALBASE}/share/kmfl/; the keyboard ports were SCIM-only and used to install to ${LOCALBASE}/share/scim/kmfl/. - Adapt descriptions in other KMFL ports (textproc/kmflcomp, textproc/libkmfl); - While we are here, do some additional maintenance. - Remove the 7 old ports. - Please see the PR for full details. PR: ports/156694 Submitted by: Nikola Lecic <nikola.lecic@anthesphoria.net> (maintainer)
Notes
Notes: svn path=/head/; revision=274783
Diffstat (limited to 'textproc/kmfl-sil-yi/Makefile')
-rw-r--r--textproc/kmfl-sil-yi/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/textproc/kmfl-sil-yi/Makefile b/textproc/kmfl-sil-yi/Makefile
index 51db1967f9bc..878557276618 100644
--- a/textproc/kmfl-sil-yi/Makefile
+++ b/textproc/kmfl-sil-yi/Makefile
@@ -5,40 +5,42 @@
# $FreeBSD$
#
-PORTNAME= scim-kmfl-sil-yi
+PORTNAME= kmfl-sil-yi
PORTVERSION= 20020903
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=SILYi12OFL_Src&filename=/ \
- http://anthesphoria.net/FreeBSD/ports/distfiles/kmfl/
+ http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
DISTNAME= SILYiOFL1.2Src
DIST_SUBDIR= kmfl
MAINTAINER= nikola.lecic@anthesphoria.net
-COMMENT= SCIM KMFL IMEngine Unicode keyboard for standardized Yi script
+COMMENT= KMFL Unicode keyboard for standardized Yi script
-RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
- ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp
WRKSRC= ${WRKDIR}
USE_DOS2UNIX= SourceFiles/Yi7.kmn
NO_BUILD= yes
USE_ZIP= yes
-SCIM_KMFL_DIR= share/scim/kmfl
-SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+KMFL_DIR= share/kmfl
+KMFL_ICONS_DIR= share/kmfl/icons
-PLIST_FILES= ${SCIM_KMFL_DIR}/Yi7.kmn \
- ${SCIM_KMFL_ICONS_DIR}/YiPinYin.bmp
+PLIST_FILES= ${KMFL_DIR}/Yi7.kmn \
+ ${KMFL_ICONS_DIR}/YiPinYin.bmp
+PLIST_DIRSTRY= ${KMFL_ICONS_DIR} \
+ ${KMFL_DIR}
do-install:
- ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
- ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+ ${MKDIR} ${LOCALBASE}/${KMFL_DIR} ${LOCALBASE}/${KMFL_ICONS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.kmn ${LOCALBASE}/${KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/SourceFiles/*.bmp ${LOCALBASE}/${KMFL_ICONS_DIR}
post-install:
@${ECHO_MSG} "--------------------------------------------------------"
@${ECHO_MSG} " You should now have the new keyboard in the section"
- @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " \"Others\" in your SCIM/IBus menu. If you don't see it,"
@${ECHO_MSG} " restart X."
@${ECHO_MSG}
@${ECHO_MSG} " At the moment, this keyboard has no documentation."