aboutsummaryrefslogtreecommitdiff
path: root/textproc/kreport
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
commita842d469243bc265e68c14c19cdf2648a2aaac95 (patch)
treed722a6757db1136f92f82f7b7d4e4d968a16b536 /textproc/kreport
parent4f68d0d44822e3c276d674d30164f29889b27351 (diff)
downloadports-a842d469243bc265e68c14c19cdf2648a2aaac95.tar.gz
ports-a842d469243bc265e68c14c19cdf2648a2aaac95.zip
Notes
Diffstat (limited to 'textproc/kreport')
-rw-r--r--textproc/kreport/Makefile21
-rw-r--r--textproc/kreport/distinfo3
-rw-r--r--textproc/kreport/pkg-descr9
-rw-r--r--textproc/kreport/pkg-plist94
4 files changed, 127 insertions, 0 deletions
diff --git a/textproc/kreport/Makefile b/textproc/kreport/Makefile
new file mode 100644
index 000000000000..cc87d111ce3a
--- /dev/null
+++ b/textproc/kreport/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= kreport
+PORTVERSION= 3.0.0
+CATEGORIES= textproc kde
+MASTER_SITES= KDE/stable/${PORTNAME}/src
+DIST_SUBDIR= KDE/${PORTNAME}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Framework for creation of reports in multiple formats
+
+LIB_DEPENDS= libKPropertyCore3.so:x11-toolkits/kproperty
+
+USES= cmake:outsource gettext kde:5 python:2 tar:xz
+USE_KDE= config coreaddons ecm widgetsaddons
+USE_QT5= core gui network qml webkit widgets xml \
+ buildtools_build printsupport qmake_build
+
+CONFLICTS_INSTALL= calligra-2*
+
+.include <bsd.port.mk>
diff --git a/textproc/kreport/distinfo b/textproc/kreport/distinfo
new file mode 100644
index 000000000000..f5432efa4862
--- /dev/null
+++ b/textproc/kreport/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481142784
+SHA256 (KDE/kreport/kreport-3.0.0.tar.xz) = c3d8a310fd4b68bbce83370796ea2efdf93b9ce9f8cafb66e331b0db94ec2a00
+SIZE (KDE/kreport/kreport-3.0.0.tar.xz) = 225868
diff --git a/textproc/kreport/pkg-descr b/textproc/kreport/pkg-descr
new file mode 100644
index 000000000000..e840860b7e81
--- /dev/null
+++ b/textproc/kreport/pkg-descr
@@ -0,0 +1,9 @@
+The KReport framework implements reporting functionality for creation of
+reports in MS Access style. They are also similar to SAP Crystal Reports
+and FileMaker reports.
+
+Reports can be created interactively and programmatically. They can be
+previewed on screen, printed, and saved in a variety of formats such
+as HTML, PDF and OpenDocument.
+
+WWW: http://www.kexi-project.org/
diff --git a/textproc/kreport/pkg-plist b/textproc/kreport/pkg-plist
new file mode 100644
index 000000000000..563f5c1b4845
--- /dev/null
+++ b/textproc/kreport/pkg-plist
@@ -0,0 +1,94 @@
+include/KReport3/KReportAsyncItemBase
+include/KReport3/KReportAsyncItemBase.h
+include/KReport3/KReportData
+include/KReport3/KReportData.h
+include/KReport3/KReportDesign
+include/KReport3/KReportDesign.h
+include/KReport3/KReportDesigner
+include/KReport3/KReportDesigner.h
+include/KReport3/KReportDesignerItemBase
+include/KReport3/KReportDesignerItemBase.h
+include/KReport3/KReportDesignerItemRectBase
+include/KReport3/KReportDesignerItemRectBase.h
+include/KReport3/KReportDesignerSection
+include/KReport3/KReportDesignerSection.h
+include/KReport3/KReportDesignerSectionDetail
+include/KReport3/KReportDesignerSectionDetail.h
+include/KReport3/KReportDesignerSectionDetailGroup
+include/KReport3/KReportDesignerSectionDetailGroup.h
+include/KReport3/KReportDocument
+include/KReport3/KReportDocument.h
+include/KReport3/KReportDpi
+include/KReport3/KReportDpi.h
+include/KReport3/KReportElement
+include/KReport3/KReportElement.h
+include/KReport3/KReportGroupTracker
+include/KReport3/KReportGroupTracker.h
+include/KReport3/KReportItemBase
+include/KReport3/KReportItemBase.h
+include/KReport3/KReportItemLine
+include/KReport3/KReportItemLine.h
+include/KReport3/KReportLabelElement
+include/KReport3/KReportLabelElement.h
+include/KReport3/KReportLineStyle
+include/KReport3/KReportLineStyle.h
+include/KReport3/KReportPage
+include/KReport3/KReportPage.h
+include/KReport3/KReportPageOptions
+include/KReport3/KReportPageOptions.h
+include/KReport3/KReportPageSize
+include/KReport3/KReportPageSize.h
+include/KReport3/KReportPluginInterface
+include/KReport3/KReportPluginInterface.h
+include/KReport3/KReportPluginManager
+include/KReport3/KReportPluginManager.h
+include/KReport3/KReportPluginMetaData
+include/KReport3/KReportPluginMetaData.h
+include/KReport3/KReportPosition
+include/KReport3/KReportPosition.h
+include/KReport3/KReportPreRenderer
+include/KReport3/KReportPreRenderer.h
+include/KReport3/KReportRenderObjects
+include/KReport3/KReportRenderObjects.h
+include/KReport3/KReportRendererBase
+include/KReport3/KReportRendererBase.h
+include/KReport3/KReportScriptConstants
+include/KReport3/KReportScriptConstants.h
+include/KReport3/KReportScriptDraw
+include/KReport3/KReportScriptDraw.h
+include/KReport3/KReportScriptHandler
+include/KReport3/KReportScriptHandler.h
+include/KReport3/KReportSection
+include/KReport3/KReportSection.h
+include/KReport3/KReportSectionData
+include/KReport3/KReportSectionData.h
+include/KReport3/KReportSize
+include/KReport3/KReportSize.h
+include/KReport3/KReportUnit
+include/KReport3/KReportUnit.h
+include/KReport3/KReportUtils
+include/KReport3/KReportUtils.h
+include/KReport3/KReportView
+include/KReport3/KReportView.h
+include/KReport3/KReportZoomHandler
+include/KReport3/KReportZoomHandler.h
+include/KReport3/KReportZoomMode
+include/KReport3/KReportZoomMode.h
+include/KReport3/config-kreport.h
+include/KReport3/kreport_export.h
+include/KReport3/kreport_version.h
+lib/cmake/KReport3/KReportConfig.cmake
+lib/cmake/KReport3/KReportConfigVersion.cmake
+lib/cmake/KReport3/KReportTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KReport3/KReportTargets.cmake
+lib/libKReport3.so
+lib/libKReport3.so.3
+lib/libKReport3.so.3.0
+libdata/pkgconfig/KReport3.pc
+%%QT_MKSPECDIR%%/modules/qt_KReport3.pri
+%%QT_PLUGINDIR%%/kreport3/org.kde.kreport.barcode.so
+%%QT_PLUGINDIR%%/kreport3/org.kde.kreport.web.so
+%%DATADIR%%3/icons/kreport_breeze.rcc
+%%DATADIR%%3/icons/org.kde.kreport.barcode_breeze.rcc
+%%DATADIR%%3/icons/org.kde.kreport.web_breeze.rcc
+share/kservicetypes5/kreport_elementplugin.desktop