aboutsummaryrefslogtreecommitdiff
path: root/textproc/latex2html
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-04-20 16:56:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-04-20 16:56:50 +0000
commit46f3e7f46299d90ab8b3e2ea19f6a6243319da30 (patch)
tree9df377f76786db2d06f2c31c469fdb229936d3ce /textproc/latex2html
parent227083f52ce05265a66c3afc29a9dd5c21ce72e4 (diff)
downloadports-46f3e7f46299d90ab8b3e2ea19f6a6243319da30.tar.gz
ports-46f3e7f46299d90ab8b3e2ea19f6a6243319da30.zip
Fix with Perl 5.21.1+
"defined(@array)" and "defined(%hash)" are now fatal errors These have been deprecated since v5.6.1 and have raised deprecation warnings since v5.16. With hat: perl@ Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=384368
Diffstat (limited to 'textproc/latex2html')
-rw-r--r--textproc/latex2html/Makefile2
-rw-r--r--textproc/latex2html/files/patch-latex2html.pin29
2 files changed, 30 insertions, 1 deletions
diff --git a/textproc/latex2html/Makefile b/textproc/latex2html/Makefile
index 08860bb6c2ee..2cdeb80e06df 100644
--- a/textproc/latex2html/Makefile
+++ b/textproc/latex2html/Makefile
@@ -3,7 +3,7 @@
PORTNAME= latex2html
PORTVERSION= 2008
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/${PORTNAME}
diff --git a/textproc/latex2html/files/patch-latex2html.pin b/textproc/latex2html/files/patch-latex2html.pin
new file mode 100644
index 000000000000..eb759f80bad1
--- /dev/null
+++ b/textproc/latex2html/files/patch-latex2html.pin
@@ -0,0 +1,29 @@
+--- latex2html.pin.orig 2015-04-20 16:01:37 UTC
++++ latex2html.pin
+@@ -532,7 +532,7 @@ $CHARSET = $charset || 'iso-8859-1';
+ #
+ # If possible, use icons of the same type as generated images
+ #
+-if ($IMAGE_TYPE && defined %{"icons_$IMAGE_TYPE"}) {
++if ($IMAGE_TYPE && %{"icons_$IMAGE_TYPE"}) {
+ %icons = %{"icons_$IMAGE_TYPE"};
+ }
+
+@@ -2112,7 +2112,7 @@ sub convert_iso_latin_chars {
+ "\nCould not find translation function for $default_language.\n\n")
+ }
+ );
+- if ($USE_UTF ||(!$NO_UTF &&(defined %unicode_table)&&length(%unicode_table)>2)) {
++ if ($USE_UTF ||(!$NO_UTF &&(%unicode_table)&&length(%unicode_table)>2)) {
+ &convert_to_unicode($_)};
+ }
+ $_ = join('', @case_processed, $_); undef(@case_processed);
+@@ -9117,7 +9117,7 @@ sub real_replace_strange_accents {
+ my ($charset) = "${CHARSET}_character_map_inv";
+ $charset =~ s/-/_/g;
+ # convert upper 8-bit characters
+- if (defined %$charset &&($CHARSET =~ /8859[_\-]1$/)) {
++ if ((%$charset) &&($CHARSET =~ /8859[_\-]1$/)) {
+ s/([\200-\377])/
+ $tmp = $$charset{'&#'.ord($1).';'};
+ &mark_string($tmp) if ($tmp =~ m!\{!);