aboutsummaryrefslogtreecommitdiff
path: root/textproc/libkolabxml
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:40:57 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-03 20:40:57 +0000
commit52e8a321a05486adfd80ca5576530d7a54df7acf (patch)
tree6dc5a6c67a143e0cf817ad5312566003c502fb46 /textproc/libkolabxml
parent48d7a30d23f57e0fb132b149b7ef27ed71ab01a3 (diff)
downloadports-52e8a321a05486adfd80ca5576530d7a54df7acf.tar.gz
ports-52e8a321a05486adfd80ca5576530d7a54df7acf.zip
Add new ports required for deskutils/kdepim4.
Reminded by: rakuco Pointyhat to: me
Notes
Notes: svn path=/head/; revision=311493
Diffstat (limited to 'textproc/libkolabxml')
-rw-r--r--textproc/libkolabxml/Makefile33
-rw-r--r--textproc/libkolabxml/distinfo2
-rw-r--r--textproc/libkolabxml/pkg-descr6
-rw-r--r--textproc/libkolabxml/pkg-plist22
4 files changed, 63 insertions, 0 deletions
diff --git a/textproc/libkolabxml/Makefile b/textproc/libkolabxml/Makefile
new file mode 100644
index 000000000000..70d6ccd94775
--- /dev/null
+++ b/textproc/libkolabxml/Makefile
@@ -0,0 +1,33 @@
+# Created by: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libkolabxml
+PORTVERSION= 0.8.1
+CATEGORIES= textproc
+MASTER_SITES= http://mirror.kolabsys.com/pub/releases/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Kolab XML Format Schema Definitions Library
+
+# The XSD schemas in schemas/ are AL2-licensed, and some files are
+# in public domain. The library itself and the installed headers are
+# considered LGPL3-licensed, though.
+LICENSE= LGPL3
+
+BUILD_DEPENDS= xsdcxx:${PORTSDIR}/devel/xsd
+LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
+ curl:${PORTSDIR}/ftp/curl \
+ xerces-c.3:${PORTSDIR}/textproc/xerces-c3
+
+# TODO: Conditionally enable the bindings based on OPTIONs.
+CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
+ -DCSHARP_BINDINGS:BOOL=OFF \
+ -DDIST_ONLY:BOOL=OFF \
+ -DJAVA_BINDINGS:BOOL=OFF \
+ -DPHP_BINDINGS:BOOL=OFF \
+ -DPYTHON_BINDINGS:BOOL=OFF
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/libkolabxml/distinfo b/textproc/libkolabxml/distinfo
new file mode 100644
index 000000000000..01d3dfea3647
--- /dev/null
+++ b/textproc/libkolabxml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libkolabxml-0.8.1.tar.gz) = 03ed6cdc89ec92c36427f6e30b020285b6e5256ce56f2486c8355f51b5b75180
+SIZE (libkolabxml-0.8.1.tar.gz) = 113707
diff --git a/textproc/libkolabxml/pkg-descr b/textproc/libkolabxml/pkg-descr
new file mode 100644
index 000000000000..a80a6e24c995
--- /dev/null
+++ b/textproc/libkolabxml/pkg-descr
@@ -0,0 +1,6 @@
+Libkolabxml is the reference implementation of the Kolab XML Format.
+
+It provides serialization/deserialization from/to in-memory
+representations for all Kolab Objects, including input validation.
+
+WWW: http://www.kolab.org/about/libkolabxml
diff --git a/textproc/libkolabxml/pkg-plist b/textproc/libkolabxml/pkg-plist
new file mode 100644
index 000000000000..a1ebd90ab594
--- /dev/null
+++ b/textproc/libkolabxml/pkg-plist
@@ -0,0 +1,22 @@
+include/kolabxml/global_definitions.h
+include/kolabxml/incidence_p.h
+include/kolabxml/kolabconfiguration.h
+include/kolabxml/kolabcontact.h
+include/kolabxml/kolabcontainers.h
+include/kolabxml/kolabevent.h
+include/kolabxml/kolabevent_p.h
+include/kolabxml/kolabformat.h
+include/kolabxml/kolabfreebusy.h
+include/kolabxml/kolabjournal.h
+include/kolabxml/kolabnote.h
+include/kolabxml/kolabtodo.h
+lib/cmake/Libkolabxml/LibkolabxmlConfig.cmake
+lib/cmake/Libkolabxml/LibkolabxmlConfigVersion.cmake
+lib/cmake/Libkolabxml/LibkolabxmlTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Libkolabxml/LibkolabxmlTargets.cmake
+lib/libkolabxml.so
+lib/libkolabxml.so.0
+lib/libkolabxml.so.0.8.1
+@dirrm lib/cmake/Libkolabxml
+@dirrmtry lib/cmake
+@dirrm include/kolabxml