aboutsummaryrefslogtreecommitdiff
path: root/textproc/libnumbertext
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2019-02-05 02:02:55 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2019-02-05 02:02:55 +0000
commitdeb846c31219a150f9e51851c1e30b5e3b2d4645 (patch)
tree320b302747b84c3672c64d65f3f34eebd36c45f1 /textproc/libnumbertext
parent4d84b8600cb9acd728dfe03e7e2f3d524bbc0218 (diff)
downloadports-deb846c31219a150f9e51851c1e30b5e3b2d4645.tar.gz
ports-deb846c31219a150f9e51851c1e30b5e3b2d4645.zip
Notes
Diffstat (limited to 'textproc/libnumbertext')
-rw-r--r--textproc/libnumbertext/Makefile19
-rw-r--r--textproc/libnumbertext/distinfo3
-rw-r--r--textproc/libnumbertext/files/patch-src_Makefile.am8
-rw-r--r--textproc/libnumbertext/files/patch-src_Makefile.in11
-rw-r--r--textproc/libnumbertext/files/patch-src_spellout.cxx11
-rw-r--r--textproc/libnumbertext/pkg-descr4
-rw-r--r--textproc/libnumbertext/pkg-plist54
7 files changed, 110 insertions, 0 deletions
diff --git a/textproc/libnumbertext/Makefile b/textproc/libnumbertext/Makefile
new file mode 100644
index 000000000000..7a82807da4a3
--- /dev/null
+++ b/textproc/libnumbertext/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= libnumbertext
+PORTVERSION= 1.0.5
+CATEGORIES= textproc
+MASTER_SITES= https://github.com/Numbertext/libnumbertext/releases/download/${PORTVERSION}/
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Number to number name and money text conversion libraries
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake libtool tar:xz
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/libnumbertext/distinfo b/textproc/libnumbertext/distinfo
new file mode 100644
index 000000000000..1d02ce8b3994
--- /dev/null
+++ b/textproc/libnumbertext/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1548870050
+SHA256 (libnumbertext-1.0.5.tar.xz) = e1c9086b4cecb6b25f180316f30740dfabe6a4dbaf70dddc34276fc839e4f4f7
+SIZE (libnumbertext-1.0.5.tar.xz) = 281640
diff --git a/textproc/libnumbertext/files/patch-src_Makefile.am b/textproc/libnumbertext/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..7e7f40478a11
--- /dev/null
+++ b/textproc/libnumbertext/files/patch-src_Makefile.am
@@ -0,0 +1,8 @@
+--- src/Makefile.am.orig 2019-02-05 01:43:55 UTC
++++ src/Makefile.am
+@@ -1,4 +1,4 @@
+-AM_CXXFLAGS = -D_THREAD_SAFE -D_GNU_SOURCE -DVERBOSE
++AM_CXXFLAGS = -D_THREAD_SAFE -D_GNU_SOURCE -DVERBOSE -DDATADIR='"$(datadir)"'
+
+ LIBS += $(BOOST_REGEX_LIB)
+
diff --git a/textproc/libnumbertext/files/patch-src_Makefile.in b/textproc/libnumbertext/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..0f637879b8fe
--- /dev/null
+++ b/textproc/libnumbertext/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2019-02-05 01:45:09 UTC
++++ src/Makefile.in
+@@ -346,7 +346,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-AM_CXXFLAGS = -D_THREAD_SAFE -D_GNU_SOURCE -DVERBOSE
++AM_CXXFLAGS = -D_THREAD_SAFE -D_GNU_SOURCE -DVERBOSE -DDATADIR='"$(datadir)"'
+ libnumbertext_1_0_includedir = $(includedir)/libnumbertext
+ libnumbertext_1_0_include_HEADERS = \
+ Soros.hxx Numbertext.hxx \
diff --git a/textproc/libnumbertext/files/patch-src_spellout.cxx b/textproc/libnumbertext/files/patch-src_spellout.cxx
new file mode 100644
index 000000000000..885396108d6a
--- /dev/null
+++ b/textproc/libnumbertext/files/patch-src_spellout.cxx
@@ -0,0 +1,11 @@
+--- src/spellout.cxx.orig 2019-02-05 01:41:33 UTC
++++ src/spellout.cxx
+@@ -10,7 +10,7 @@
+
+ #define LANG "LANG"
+ #define PATH "NUMBERTEXTPATH"
+-#define DEFPATH "/usr/share/libnumbertext/"
++#define DEFPATH DATADIR "/libnumbertext/"
+ #define DEFPATH2 "data/"
+
+ enum State { base, loaded, flag_lang, flag_prefix};
diff --git a/textproc/libnumbertext/pkg-descr b/textproc/libnumbertext/pkg-descr
new file mode 100644
index 000000000000..7a583ecb40d6
--- /dev/null
+++ b/textproc/libnumbertext/pkg-descr
@@ -0,0 +1,4 @@
+Number to number name and money text conversion libraries in C++, Java,
+JavaScript and Python & LibreOffice Calc Extension
+
+WWW: https://numbertext.org
diff --git a/textproc/libnumbertext/pkg-plist b/textproc/libnumbertext/pkg-plist
new file mode 100644
index 000000000000..282f44b4d33e
--- /dev/null
+++ b/textproc/libnumbertext/pkg-plist
@@ -0,0 +1,54 @@
+bin/spellout
+include/libnumbertext/Numbertext.hxx
+include/libnumbertext/Soros.hxx
+include/libnumbertext/numbertext-version.h
+lib/libnumbertext-1.0.a
+lib/libnumbertext-1.0.so
+lib/libnumbertext-1.0.so.0
+lib/libnumbertext-1.0.so.0.0.0
+libdata/pkgconfig/libnumbertext.pc
+%%DATADIR%%/Hung.sor
+%%DATADIR%%/Roman.sor
+%%DATADIR%%/Suzhou.sor
+%%DATADIR%%/af.sor
+%%DATADIR%%/bg.sor
+%%DATADIR%%/ca.sor
+%%DATADIR%%/cs.sor
+%%DATADIR%%/da.sor
+%%DATADIR%%/de.sor
+%%DATADIR%%/el.sor
+%%DATADIR%%/en.sor
+%%DATADIR%%/eo.sor
+%%DATADIR%%/es.sor
+%%DATADIR%%/et.sor
+%%DATADIR%%/fi.sor
+%%DATADIR%%/fr.sor
+%%DATADIR%%/gl.sor
+%%DATADIR%%/he.sor
+%%DATADIR%%/hr.sor
+%%DATADIR%%/hu.sor
+%%DATADIR%%/id.sor
+%%DATADIR%%/is.sor
+%%DATADIR%%/it.sor
+%%DATADIR%%/ja.sor
+%%DATADIR%%/ko.sor
+%%DATADIR%%/lb.sor
+%%DATADIR%%/lt.sor
+%%DATADIR%%/lv.sor
+%%DATADIR%%/ms.sor
+%%DATADIR%%/nl.sor
+%%DATADIR%%/no.sor
+%%DATADIR%%/pl.sor
+%%DATADIR%%/pt.sor
+%%DATADIR%%/ro.sor
+%%DATADIR%%/ru.sor
+%%DATADIR%%/sh.sor
+%%DATADIR%%/sl.sor
+%%DATADIR%%/sq.sor
+%%DATADIR%%/sr.sor
+%%DATADIR%%/sv.sor
+%%DATADIR%%/th.sor
+%%DATADIR%%/tr.sor
+%%DATADIR%%/uk.sor
+%%DATADIR%%/vi.sor
+%%DATADIR%%/zh.sor