aboutsummaryrefslogtreecommitdiff
path: root/textproc/libnxml
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-09 18:02:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-09 18:02:57 +0000
commit52140fb40ce1bad087a2312454e6e30c4831991e (patch)
tree57bd1d70299fc1785c0f836b3748940d00ed94ae /textproc/libnxml
parentad7873b88948444ebba5cf73ee51f546aead778d (diff)
downloadports-52140fb40ce1bad087a2312454e6e30c4831991e.tar.gz
ports-52140fb40ce1bad087a2312454e6e30c4831991e.zip
nXML is a C library for parsing, writing and creating XML 1.0 and 1.1 files
or streams. It supports utf-8, utf-16be and utf-16le, ucs-4 (1234, 4321, 2143, 2312). Author: Andrea Marchesini <bakunin@autistici.org> WWW: http://www2.autistici.org/bakunin/libnxml/doc/ PR: ports/95539 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=159227
Diffstat (limited to 'textproc/libnxml')
-rw-r--r--textproc/libnxml/Makefile29
-rw-r--r--textproc/libnxml/distinfo3
-rw-r--r--textproc/libnxml/pkg-descr6
-rw-r--r--textproc/libnxml/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
new file mode 100644
index 000000000000..57c52e62f62e
--- /dev/null
+++ b/textproc/libnxml/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libnxml
+# Date created: 2006-04-09
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnxml
+PORTVERSION= 0.9
+CATEGORIES= textproc devel
+MASTER_SITES= http://www2.autistici.org/bakunin/libnxml/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A C library for writing XML 1.0/1.1 files or streams
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I/${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+INSTALLS_SHLIB= yes
+
+WANT_GNOME= yes
+
+pre-patch:
+ ${gnomehack_PRE_PATCH}
+
+.include <bsd.port.mk>
diff --git a/textproc/libnxml/distinfo b/textproc/libnxml/distinfo
new file mode 100644
index 000000000000..8e36da288223
--- /dev/null
+++ b/textproc/libnxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (libnxml-0.9.tar.gz) = e5b3443280c9fd803ba280cbc7a8a45b
+SHA256 (libnxml-0.9.tar.gz) = 39590fd2c567bff3e5d48d294d65d52e38a4665f6a234bb1496147f99f9afe21
+SIZE (libnxml-0.9.tar.gz) = 338191
diff --git a/textproc/libnxml/pkg-descr b/textproc/libnxml/pkg-descr
new file mode 100644
index 000000000000..20572bc4dd1f
--- /dev/null
+++ b/textproc/libnxml/pkg-descr
@@ -0,0 +1,6 @@
+nXML is a C library for parsing, writing and creating XML 1.0 and 1.1 files
+or streams. It supports utf-8, utf-16be and utf-16le, ucs-4 (1234, 4321,
+2143, 2312).
+
+Author: Andrea Marchesini <bakunin@autistici.org>
+WWW: http://www2.autistici.org/bakunin/libnxml/doc/
diff --git a/textproc/libnxml/pkg-plist b/textproc/libnxml/pkg-plist
new file mode 100644
index 000000000000..17ae70a3c172
--- /dev/null
+++ b/textproc/libnxml/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+include/nxml.h
+lib/libnxml.a
+lib/libnxml.la
+lib/libnxml.so
+lib/libnxml.so.0
+libdata/pkgconfig/nxml.pc