aboutsummaryrefslogtreecommitdiff
path: root/textproc/libqxp
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-21 03:14:49 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-02-21 03:14:49 +0000
commit3401c49da274a028c6c74dcf62e4b0e581f8caac (patch)
tree314b7b0727684b2588082ed24c13af69edee2853 /textproc/libqxp
parent5938a3070d90de06f45ae2fbfd05617a75ec3557 (diff)
downloadports-3401c49da274a028c6c74dcf62e4b0e581f8caac.tar.gz
ports-3401c49da274a028c6c74dcf62e4b0e581f8caac.zip
Add textproc/libqxp, library for parsing QuarkXPress documents
PR: 224284 Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=462472
Diffstat (limited to 'textproc/libqxp')
-rw-r--r--textproc/libqxp/Makefile44
-rw-r--r--textproc/libqxp/distinfo3
-rw-r--r--textproc/libqxp/files/patch-src_lib_QXPBlockParser.cpp13
-rw-r--r--textproc/libqxp/pkg-descr4
-rw-r--r--textproc/libqxp/pkg-plist11
5 files changed, 75 insertions, 0 deletions
diff --git a/textproc/libqxp/Makefile b/textproc/libqxp/Makefile
new file mode 100644
index 000000000000..976c33cea67a
--- /dev/null
+++ b/textproc/libqxp/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= libqxp
+PORTVERSION= 0.0.0
+CATEGORIES= textproc
+MASTER_SITES= https://dev-www.libreoffice.org/src/${PORTNAME}/
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Library for parsing QuarkXPress documents
+
+LICENSE= MPL20
+
+LIB_DEPENDS= librevenge-0.0.so:textproc/librevenge \
+ libicui18n.so:devel/icu
+ #libicui18n.so:devel/icu \
+ #libicuuc.so:devel/icu \
+ #libicudata.so:devel/icu
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/math/constants/constants.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/optional.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/variant.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/range/adaptor/reversed.hpp:devel/boost-libs \
+ ${LOCALBASE}/include/boost/cstdint.hpp:devel/boost-libs
+
+CONFIGURE_ARGS= --disable-werror
+CPPFLAGS+= -I${LOCALBASE}/include
+
+GNU_CONFIGURE= yes
+USES= compiler:features libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DOXYGEN TEST
+OPTIONS_DEFAULT=
+OPTIONS_SUB= yes
+
+TEST_TARGET= check
+TEST_LIB_DEPENDS= libcppunit.so:devel/cppunit
+TEST_CONFIGURE_ENABLE= tests
+
+PORTDOCS= *
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+DOXYGEN_CONFIGURE_OFF= --without-docs
+
+.include <bsd.port.mk>
diff --git a/textproc/libqxp/distinfo b/textproc/libqxp/distinfo
new file mode 100644
index 000000000000..2bf0706afe77
--- /dev/null
+++ b/textproc/libqxp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513087591
+SHA256 (libqxp-0.0.0.tar.xz) = 0dd32afbf1c889debc28848b260c1bdc0eba5f57504476b787e164f7c59776d5
+SIZE (libqxp-0.0.0.tar.xz) = 337292
diff --git a/textproc/libqxp/files/patch-src_lib_QXPBlockParser.cpp b/textproc/libqxp/files/patch-src_lib_QXPBlockParser.cpp
new file mode 100644
index 000000000000..a46777ba9cf3
--- /dev/null
+++ b/textproc/libqxp/files/patch-src_lib_QXPBlockParser.cpp
@@ -0,0 +1,13 @@
+Fixes FreeBSD 10 build error:
+
+QXPBlockParser.cpp:60:12: error: use of undeclared identifier 'abs'; did you mean 'fabs'?
+--- src/lib/QXPBlockParser.cpp.orig 2018-02-07 14:08:00 UTC
++++ src/lib/QXPBlockParser.cpp
+@@ -13,6 +13,7 @@
+ #include <algorithm>
+ #include <memory>
+ #include <vector>
++#include <cstdlib>
+
+ #include "QXPHeader.h"
+
diff --git a/textproc/libqxp/pkg-descr b/textproc/libqxp/pkg-descr
new file mode 100644
index 000000000000..35d07905dc6c
--- /dev/null
+++ b/textproc/libqxp/pkg-descr
@@ -0,0 +1,4 @@
+libqxp is a library that parses the file format of QuarkXPress documents.
+Currently it only understands documents created by QuarkXPress 3.1 to 4.1.
+
+WWW: https://wiki.documentfoundation.org/DLP/Libraries/libqxp
diff --git a/textproc/libqxp/pkg-plist b/textproc/libqxp/pkg-plist
new file mode 100644
index 000000000000..05caea72a7bc
--- /dev/null
+++ b/textproc/libqxp/pkg-plist
@@ -0,0 +1,11 @@
+bin/qxp2raw
+bin/qxp2svg
+bin/qxp2text
+include/libqxp-0.0/libqxp/QXPDocument.h
+include/libqxp-0.0/libqxp/QXPPathResolver.h
+include/libqxp-0.0/libqxp/libqxp.h
+include/libqxp-0.0/libqxp/libqxp_api.h
+lib/libqxp-0.0.so
+lib/libqxp-0.0.so.0
+lib/libqxp-0.0.so.0.0.0
+libdata/pkgconfig/libqxp-0.0.pc