aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtranslate
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-07 12:46:47 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-07 12:46:47 +0000
commita134a319003811f79a5addf2ada3971db8e99ac8 (patch)
tree760c2d21ee8581cffd781d6cca486eef7192da39 /textproc/libtranslate
parent8529a5a7e0b5bff5a16fb19efc6e9f1e9ca79ee5 (diff)
downloadports-a134a319003811f79a5addf2ada3971db8e99ac8.tar.gz
ports-a134a319003811f79a5addf2ada3971db8e99ac8.zip
textproc/libtranslate: Bring in DragonFly support patch from dports
Notes
Notes: svn path=/head/; revision=361073
Diffstat (limited to 'textproc/libtranslate')
-rw-r--r--textproc/libtranslate/Makefile2
-rw-r--r--textproc/libtranslate/files/patch-configure101
2 files changed, 102 insertions, 1 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index 763be2adf48e..5a127b20faff 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -15,7 +15,7 @@ PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
-COMMENT= A natural language translation library
+COMMENT= Natural language translation library
USES= gmake pathfix pkgconfig
USE_GNOME= glib20 intlhack
diff --git a/textproc/libtranslate/files/patch-configure b/textproc/libtranslate/files/patch-configure
new file mode 100644
index 000000000000..cd4f4adb9623
--- /dev/null
+++ b/textproc/libtranslate/files/patch-configure
@@ -0,0 +1,101 @@
+--- configure.orig 2014-06-20 22:12:16.401089000 +0000
++++ configure
+@@ -3608,7 +3608,7 @@ darwin* | rhapsody*)
+ lt_cv_deplibs_check_method=pass_all
+ ;;
+
+-freebsd* | kfreebsd*-gnu)
++dragonfly* | freebsd* | kfreebsd*-gnu)
+ if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+ case $host_cpu in
+ i*86 )
+@@ -5545,7 +5545,7 @@ else
+ lt_cv_sys_max_cmd_len=8192;
+ ;;
+
+- netbsd* | freebsd* | openbsd* | darwin* )
++ netbsd* | dragonfly* | freebsd* | openbsd* | darwin* )
+ # This has been around since 386BSD, at least. Likely further.
+ if test -x /sbin/sysctl; then
+ lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
+@@ -7324,7 +7324,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec='-R$libdir'
+ hardcode_direct=yes
+@@ -7903,7 +7903,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly* | freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -10260,7 +10260,7 @@ if test -z "$aix_libpath"; then aix_libp
+ freebsd-elf*)
+ archive_cmds_need_lc_CXX=no
+ ;;
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ # FreeBSD 3 and later use GNU C++ and GNU ld with standard ELF
+ # conventions
+ ld_shlibs_CXX=yes
+@@ -11004,7 +11004,7 @@ echo $ECHO_N "checking for $compiler opt
+ ;;
+ esac
+ ;;
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ # FreeBSD uses GNU C++
+ ;;
+ hpux9* | hpux10* | hpux11*)
+@@ -11615,7 +11615,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly* | freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -14196,7 +14196,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds_F77='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec_F77='-R$libdir'
+ hardcode_direct_F77=yes
+@@ -14775,7 +14775,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly* | freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in
+@@ -16554,7 +16554,7 @@ if test -z "$aix_libpath"; then aix_libp
+ ;;
+
+ # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
+- freebsd* | kfreebsd*-gnu)
++ dragonfly* | freebsd* | kfreebsd*-gnu)
+ archive_cmds_GCJ='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
+ hardcode_libdir_flag_spec_GCJ='-R$libdir'
+ hardcode_direct_GCJ=yes
+@@ -17133,7 +17133,7 @@ kfreebsd*-gnu)
+ dynamic_linker='GNU ld.so'
+ ;;
+
+-freebsd*)
++dragonfly* | freebsd*)
+ objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+ version_type=freebsd-$objformat
+ case $version_type in