aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtranslate
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-11-29 18:22:32 +0000
commitedb7229dd444037f6015d4a7d1c93eade4ed41f0 (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /textproc/libtranslate
parentb134ca1eb84846189b4cdfa7ab624072ad1aebb6 (diff)
downloadports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.tar.gz
ports-edb7229dd444037f6015d4a7d1c93eade4ed41f0.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=373636
Diffstat (limited to 'textproc/libtranslate')
-rw-r--r--textproc/libtranslate/Makefile9
-rw-r--r--textproc/libtranslate/files/patch-configure101
-rw-r--r--textproc/libtranslate/pkg-plist1
3 files changed, 5 insertions, 106 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index 5a127b20faff..45ed2a74825f 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libtranslate
PORTVERSION= 0.99
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,12 +17,12 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= Natural language translation library
-USES= gmake pathfix pkgconfig
+USES= gettext gmake libtool pathfix pkgconfig
USE_GNOME= glib20 intlhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
OPTIONS_DEFINE= GENERIC TALKFILTERS
@@ -31,8 +31,7 @@ GENERIC_DESC= generic module
TALKFILTERS_DESC= talkfilters module
post-patch::
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|' \
- -e 's|libsoup-2.2|libsoup-2.4|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|libsoup-2.2|libsoup-2.4|g' ${WRKSRC}/configure
.include <bsd.port.options.mk>
diff --git a/textproc/libtranslate/files/patch-configure b/textproc/libtranslate/files/patch-configure
deleted file mode 100644
index cd4f4adb9623..000000000000
--- a/textproc/libtranslate/files/patch-configure
+++ /dev/null
@@ -1,101 +0,0 @@
---- configure.orig 2014-06-20 22:12:16.401089000 +0000
-+++ configure
-@@ -3608,7 +3608,7 @@ darwin* | rhapsody*)
- lt_cv_deplibs_check_method=pass_all
- ;;
-
--freebsd* | kfreebsd*-gnu)
-+dragonfly* | freebsd* | kfreebsd*-gnu)
- if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
- case $host_cpu in
- i*86 )
-@@ -5545,7 +5545,7 @@ else
- lt_cv_sys_max_cmd_len=8192;
- ;;
-
-- netbsd* | freebsd* | openbsd* | darwin* )
-+ netbsd* | dragonfly* | freebsd* | openbsd* | darwin* )
- # This has been around since 386BSD, at least. Likely further.
- if test -x /sbin/sysctl; then
- lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
-@@ -7324,7 +7324,7 @@ if test -z "$aix_libpath"; then aix_libp
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ dragonfly* | freebsd* | kfreebsd*-gnu)
- archive_cmds='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec='-R$libdir'
- hardcode_direct=yes
-@@ -7903,7 +7903,7 @@ kfreebsd*-gnu)
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+dragonfly* | freebsd*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -10260,7 +10260,7 @@ if test -z "$aix_libpath"; then aix_libp
- freebsd-elf*)
- archive_cmds_need_lc_CXX=no
- ;;
-- freebsd* | kfreebsd*-gnu)
-+ dragonfly* | freebsd* | kfreebsd*-gnu)
- # FreeBSD 3 and later use GNU C++ and GNU ld with standard ELF
- # conventions
- ld_shlibs_CXX=yes
-@@ -11004,7 +11004,7 @@ echo $ECHO_N "checking for $compiler opt
- ;;
- esac
- ;;
-- freebsd* | kfreebsd*-gnu)
-+ dragonfly* | freebsd* | kfreebsd*-gnu)
- # FreeBSD uses GNU C++
- ;;
- hpux9* | hpux10* | hpux11*)
-@@ -11615,7 +11615,7 @@ kfreebsd*-gnu)
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+dragonfly* | freebsd*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -14196,7 +14196,7 @@ if test -z "$aix_libpath"; then aix_libp
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ dragonfly* | freebsd* | kfreebsd*-gnu)
- archive_cmds_F77='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec_F77='-R$libdir'
- hardcode_direct_F77=yes
-@@ -14775,7 +14775,7 @@ kfreebsd*-gnu)
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+dragonfly* | freebsd*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
-@@ -16554,7 +16554,7 @@ if test -z "$aix_libpath"; then aix_libp
- ;;
-
- # FreeBSD 3 and greater uses gcc -shared to do shared libraries.
-- freebsd* | kfreebsd*-gnu)
-+ dragonfly* | freebsd* | kfreebsd*-gnu)
- archive_cmds_GCJ='$CC -shared -o $lib $libobjs $deplibs $compiler_flags'
- hardcode_libdir_flag_spec_GCJ='-R$libdir'
- hardcode_direct_GCJ=yes
-@@ -17133,7 +17133,7 @@ kfreebsd*-gnu)
- dynamic_linker='GNU ld.so'
- ;;
-
--freebsd*)
-+dragonfly* | freebsd*)
- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
- version_type=freebsd-$objformat
- case $version_type in
diff --git a/textproc/libtranslate/pkg-plist b/textproc/libtranslate/pkg-plist
index 5cc2f24e434a..fa2700e51039 100644
--- a/textproc/libtranslate/pkg-plist
+++ b/textproc/libtranslate/pkg-plist
@@ -8,6 +8,7 @@ include/libtranslate/translate.h
lib/libtranslate.a
lib/libtranslate.so
lib/libtranslate.so.0
+lib/libtranslate.so.0.0.0
%%GENERIC%%lib/libtranslate/modules/generic.so
%%TALKFILTERS%%lib/libtranslate/modules/talkfilters.so
libdata/pkgconfig/libtranslate.pc