aboutsummaryrefslogtreecommitdiff
path: root/textproc/libwps03
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:09:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-06 19:09:37 +0000
commite64d7b3d4691c055eea773e449935a1239ff313e (patch)
tree0313677438d0768a90153667cf164a3648f70c94 /textproc/libwps03
parent4f19d92e374355997d55ca59f9e409913e2356fe (diff)
downloadports-e64d7b3d4691c055eea773e449935a1239ff313e.tar.gz
ports-e64d7b3d4691c055eea773e449935a1239ff313e.zip
Import libwps03
Ensure libwps does not conflict with libwps03
Notes
Notes: svn path=/head/; revision=370210
Diffstat (limited to 'textproc/libwps03')
-rw-r--r--textproc/libwps03/Makefile35
-rw-r--r--textproc/libwps03/distinfo2
-rw-r--r--textproc/libwps03/pkg-descr7
-rw-r--r--textproc/libwps03/pkg-plist12
4 files changed, 56 insertions, 0 deletions
diff --git a/textproc/libwps03/Makefile b/textproc/libwps03/Makefile
new file mode 100644
index 000000000000..efba8aac4e05
--- /dev/null
+++ b/textproc/libwps03/Makefile
@@ -0,0 +1,35 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libwps
+PORTVERSION= 0.3.0
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMESUFFIX= 03
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Microsoft file word processor format import filter library
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+LIB_DEPENDS= librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+CONFIGURE_ARGS= --disable-werror
+CPPFLAGS+= -I${LOCALBASE}/include
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-docs
+USES= compiler:features libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS+= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+= --with-sharedptr=boost
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libwps03/distinfo b/textproc/libwps03/distinfo
new file mode 100644
index 000000000000..820790800fe5
--- /dev/null
+++ b/textproc/libwps03/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libwps-0.3.0.tar.gz) = ec6f17caa6cd576a2851d92b4d48508d79bece4fc83b66b012e4c8026113d44a
+SIZE (libwps-0.3.0.tar.gz) = 639591
diff --git a/textproc/libwps03/pkg-descr b/textproc/libwps03/pkg-descr
new file mode 100644
index 000000000000..b9fabb298083
--- /dev/null
+++ b/textproc/libwps03/pkg-descr
@@ -0,0 +1,7 @@
+Libwps is a library (for use by word procesors, for example) for importing the
+Microsoft Works word processor file format. It imports Works format versions 2,
+3, 4, 5 (aka 2000), and 8 with some formatting. The scope of this project is
+just a Works word processor import filter, so there are no plans for supporting
+an export filter, spreadsheets, or databases.
+
+WWW: http://libwps.sourceforge.net/
diff --git a/textproc/libwps03/pkg-plist b/textproc/libwps03/pkg-plist
new file mode 100644
index 000000000000..aa06701ffa46
--- /dev/null
+++ b/textproc/libwps03/pkg-plist
@@ -0,0 +1,12 @@
+bin/wks2csv
+bin/wks2raw
+bin/wks2text
+bin/wps2html
+bin/wps2raw
+bin/wps2text
+include/libwps-0.3/libwps/WPSDocument.h
+include/libwps-0.3/libwps/libwps.h
+lib/libwps-0.3.so
+lib/libwps-0.3.so.3
+lib/libwps-0.3.so.3.0.0
+libdata/pkgconfig/libwps-0.3.pc