aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-05 06:36:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-05 06:36:12 +0000
commit20f1fb4ea44c558a829f8e5d027cc2d8f869e835 (patch)
treee1fd0c9a84c120c5e4bb4159962a5ed033a88c35 /textproc/libxdiff
parent676c175ca9a579af6912b24e01aebe112843a878 (diff)
downloadports-20f1fb4ea44c558a829f8e5d027cc2d8f869e835.tar.gz
ports-20f1fb4ea44c558a829f8e5d027cc2d8f869e835.zip
add libxdiff 0.5
Create file differences/patches to both binary and text files
Notes
Notes: svn path=/head/; revision=97328
Diffstat (limited to 'textproc/libxdiff')
-rw-r--r--textproc/libxdiff/Makefile23
-rw-r--r--textproc/libxdiff/distinfo1
-rw-r--r--textproc/libxdiff/pkg-descr15
-rw-r--r--textproc/libxdiff/pkg-plist2
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/libxdiff/Makefile b/textproc/libxdiff/Makefile
new file mode 100644
index 000000000000..cd60c5a7d5e1
--- /dev/null
+++ b/textproc/libxdiff/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: libxdiff
+# Date created: Jan 5, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxdiff
+PORTVERSION= 0.5
+CATEGORIES= textproc
+MASTER_SITES= http://www.xmailserver.org/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Create file differences/patches to both binary and text files
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+GNU_CONFIGURE= yes
+
+MAN3= xdiff.3
+
+.include <bsd.port.mk>
diff --git a/textproc/libxdiff/distinfo b/textproc/libxdiff/distinfo
new file mode 100644
index 000000000000..f2470135ff9e
--- /dev/null
+++ b/textproc/libxdiff/distinfo
@@ -0,0 +1 @@
+MD5 (libxdiff-0.5.tar.gz) = d848a5569d499b1228d3d3c98489ae58
diff --git a/textproc/libxdiff/pkg-descr b/textproc/libxdiff/pkg-descr
new file mode 100644
index 000000000000..f33dfe17544e
--- /dev/null
+++ b/textproc/libxdiff/pkg-descr
@@ -0,0 +1,15 @@
+The LibXDiff library implements basic and yet complete functionalities to
+create file differences/patches to both binary and text files. The library
+uses memory files as file abstraction to achieve both performance and
+portability. For binary files, LibXDiff implements (with some modification)
+the algorithm described in File System Support for Delta Compression by
+Joshua P. MacDonald, while for text files it follows directives described in
+An O(ND) Difference Algorithm and Its Variations by Eugene W. Myers. Memory
+files used by the library are basically a collection of buffers that store the
+file content. There are two different requirements for memory files when passed
+to diff/patch functions. Text files for diff/patch functions require that a
+single line do not have to spawn across two different memory file blocks.
+Binary diff/patch functions require memory files to be compact. A compact
+memory files is a file whose content is stored inside a single block.
+
+WWW: http://www.xmailserver.org/xdiff-lib.html
diff --git a/textproc/libxdiff/pkg-plist b/textproc/libxdiff/pkg-plist
new file mode 100644
index 000000000000..2f0c9e8ec085
--- /dev/null
+++ b/textproc/libxdiff/pkg-plist
@@ -0,0 +1,2 @@
+include/xdiff.h
+lib/libxdiff.a