aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-04-18 22:40:33 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-04-18 22:40:33 +0000
commit879bb9b6c2afc1a1fdcaae10e5517ed41a01bbde (patch)
tree60fb3b997541e5036bd80197c72b9279f9805a16 /textproc/libxml2
parente4aa77680dfea7fd90ee5180d148edc95e38f0f5 (diff)
downloadports-879bb9b6c2afc1a1fdcaae10e5517ed41a01bbde.tar.gz
ports-879bb9b6c2afc1a1fdcaae10e5517ed41a01bbde.zip
Fix build with LZMA. All supported versions have liblzma in the base.
Approved by: gnome (mezz) Feature safe: yes
Notes
Notes: svn path=/head/; revision=316079
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile5
-rw-r--r--textproc/libxml2/files/patch-libxml-2.0-uninstalled.pc.in9
-rw-r--r--textproc/libxml2/files/patch-libxml-2.0.pc.in9
3 files changed, 20 insertions, 3 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 89d73dce919a..7c42905d89f7 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= libxml2
PORTVERSION= 2.8.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= textproc gnome
MASTER_SITES= ftp://xmlsoft.org/libxml2/ \
http://xmlsoft.org/sources/ \
@@ -27,9 +27,8 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS?=--with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
--with-html-subdir=${PORTNAME} \
+ --with-lzma=/usr \
--without-python
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(MASTERDIR)
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
diff --git a/textproc/libxml2/files/patch-libxml-2.0-uninstalled.pc.in b/textproc/libxml2/files/patch-libxml-2.0-uninstalled.pc.in
new file mode 100644
index 000000000000..d8e7102df19a
--- /dev/null
+++ b/textproc/libxml2/files/patch-libxml-2.0-uninstalled.pc.in
@@ -0,0 +1,9 @@
+--- libxml-2.0-uninstalled.pc.in.orig 2009-07-30 11:24:34.000000000 -0400
++++ libxml-2.0-uninstalled.pc.in 2013-04-09 15:37:18.000000000 -0400
+@@ -8,5 +8,5 @@
+ Version: @VERSION@
+ Description: libXML library version2.
+ Requires:
+-Libs: -L${libdir} -lxml2 @THREAD_LIBS@ @Z_LIBS@ @ICONV_LIBS@ @M_LIBS@ @LIBS@
++Libs: -L${libdir} -lxml2 @THREAD_LIBS@ @Z_LIBS@ @LZMA_LIBS@ @ICONV_LIBS@ @M_LIBS@ @LIBS@
+ Cflags: -I${includedir} @XML_INCLUDEDIR@ @XML_CFLAGS@
diff --git a/textproc/libxml2/files/patch-libxml-2.0.pc.in b/textproc/libxml2/files/patch-libxml-2.0.pc.in
new file mode 100644
index 000000000000..37f94ce3d499
--- /dev/null
+++ b/textproc/libxml2/files/patch-libxml-2.0.pc.in
@@ -0,0 +1,9 @@
+--- libxml-2.0.pc.in.orig 2010-05-14 11:26:41.000000000 -0400
++++ libxml-2.0.pc.in 2013-04-09 15:35:53.000000000 -0400
+@@ -9,5 +9,5 @@
+ Description: libXML library version2.
+ Requires:
+ Libs: -L${libdir} -lxml2
+-Libs.private: @THREAD_LIBS@ @Z_LIBS@ @ICONV_LIBS@ @M_LIBS@ @WIN32_EXTRA_LIBADD@ @LIBS@
++Libs.private: @THREAD_LIBS@ @Z_LIBS@ @LZMA_LIBS@ @ICONV_LIBS@ @M_LIBS@ @WIN32_EXTRA_LIBADD@ @LIBS@
+ Cflags: @XML_INCLUDEDIR@ @XML_CFLAGS@