aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-05-24 05:27:36 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-05-24 05:27:36 +0000
commit4ceb28e0acb9641c2b2297fec0e8ca1131251bd2 (patch)
tree8428ad523ff9a6169568b0f29064b65fad77032e /textproc/libxslt
parente39c0ec06b5725d28782835773aa7d1d0436b93d (diff)
downloadports-4ceb28e0acb9641c2b2297fec0e8ca1131251bd2.tar.gz
ports-4ceb28e0acb9641c2b2297fec0e8ca1131251bd2.zip
Update to 1.1.24. As for the py-libxslt, get it able to find Python correct
when PREFIX is set other than LOCALBASE and will allowing the modules to build.
Notes
Notes: svn path=/head/; revision=213580
Diffstat (limited to 'textproc/libxslt')
-rw-r--r--textproc/libxslt/Makefile9
-rw-r--r--textproc/libxslt/distinfo6
-rw-r--r--textproc/libxslt/files/patch-configure11
-rw-r--r--textproc/libxslt/files/patch-python::Makefile.in19
-rw-r--r--textproc/libxslt/files/patch-python::tests::Makefile.in10
5 files changed, 25 insertions, 30 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 0b2cd7d72ca4..147410fab771 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= libxslt
-PORTVERSION= 1.1.22
-PORTREVISION?= 1
+PORTVERSION= 1.1.24
+PORTREVISION?= 0
CATEGORIES?= textproc gnome
-MASTER_SITES= GNOME \
- ftp://fr.rpmfind.net/pub/libxml/
+MASTER_SITES= ftp://fr.rpmfind.net/pub/libxml/ \
+ ftp://gd.tuwien.ac.at/pub/libxml/ \
+ ftp://xmlsoft.org/libxml2/
DIST_SUBDIR= gnome2
MAINTAINER?= gnome@FreeBSD.org
diff --git a/textproc/libxslt/distinfo b/textproc/libxslt/distinfo
index 685ecf90fc5e..c80840a40527 100644
--- a/textproc/libxslt/distinfo
+++ b/textproc/libxslt/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libxslt-1.1.22.tar.gz) = d6a9a020a76a3db17848d769d6c9c8a9
-SHA256 (gnome2/libxslt-1.1.22.tar.gz) = 4e1f39ee16596fd2a83d28d6c3b065f742254f3336f93ce8ed1cae48ecbe49da
-SIZE (gnome2/libxslt-1.1.22.tar.gz) = 2783003
+MD5 (gnome2/libxslt-1.1.24.tar.gz) = e83ec5d27fc4c10c6f612879bea9a153
+SHA256 (gnome2/libxslt-1.1.24.tar.gz) = c0c10944841e9a79f29d409c6f8da0d1b1af0403eb3819c82c788dfa6a180b3e
+SIZE (gnome2/libxslt-1.1.24.tar.gz) = 3363961
diff --git a/textproc/libxslt/files/patch-configure b/textproc/libxslt/files/patch-configure
index 58a1e205ab9a..8423bb993eca 100644
--- a/textproc/libxslt/files/patch-configure
+++ b/textproc/libxslt/files/patch-configure
@@ -1,6 +1,11 @@
---- configure.orig Mon Jan 15 19:34:30 2007
-+++ configure Mon Jan 15 19:37:48 2007
-@@ -21663,7 +21663,7 @@
+--- configure.orig 2008-05-24 00:09:57.000000000 -0500
++++ configure 2008-05-24 00:10:20.000000000 -0500
+@@ -22284,11 +22284,12 @@
+ fi
+ if test "$PYTHON_VERSION" != ""
+ then
++ with_python=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ if test -r $with_python/include/python$PYTHON_VERSION/Python.h -a \
-d $with_python/lib/python$PYTHON_VERSION/site-packages
then
PYTHON_INCLUDES=$with_python/include/python$PYTHON_VERSION
diff --git a/textproc/libxslt/files/patch-python::Makefile.in b/textproc/libxslt/files/patch-python::Makefile.in
index 81a1d5c7a648..f30b906feb64 100644
--- a/textproc/libxslt/files/patch-python::Makefile.in
+++ b/textproc/libxslt/files/patch-python::Makefile.in
@@ -1,17 +1,6 @@
---- python/Makefile.in.orig Mon Jan 15 19:38:01 2007
-+++ python/Makefile.in Mon Jan 15 19:38:51 2007
-@@ -54,9 +54,7 @@
- am__installdirs = "$(DESTDIR)$(pythondir)"
- pythonLTLIBRARIES_INSTALL = $(INSTALL)
- LTLIBRARIES = $(python_LTLIBRARIES)
--@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = \
--@WITH_PYTHON_TRUE@ $(top_builddir)/libxslt/libxslt.la \
--@WITH_PYTHON_TRUE@ $(top_builddir)/libexslt/libexslt.la
-+@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 =
- @WITH_PYTHON_TRUE@libxsltmod_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
- am__libxsltmod_la_SOURCES_DIST = libxslt.c types.c libxslt-py.c
- @WITH_PYTHON_TRUE@am_libxsltmod_la_OBJECTS = libxslt.lo types.lo \
-@@ -255,7 +253,7 @@
+--- python/Makefile.in.orig 2008-05-23 23:03:51.000000000 -0500
++++ python/Makefile.in 2008-05-23 23:09:55.000000000 -0500
+@@ -258,7 +258,7 @@
-I$(top_srcdir) \
-I../libexslt
@@ -20,7 +9,7 @@
# libxsltclass.txt is generated
DOCS = TODO
EXTRA_DIST = \
-@@ -270,8 +268,8 @@
+@@ -273,8 +273,8 @@
libxsltmod_la_LDFLAGS = -module -avoid-version
@WITH_PYTHON_TRUE@mylibs = \
diff --git a/textproc/libxslt/files/patch-python::tests::Makefile.in b/textproc/libxslt/files/patch-python::tests::Makefile.in
index 7abaa6ee5739..385552556c34 100644
--- a/textproc/libxslt/files/patch-python::tests::Makefile.in
+++ b/textproc/libxslt/files/patch-python::tests::Makefile.in
@@ -1,9 +1,9 @@
---- python/tests/Makefile.in.orig Tue Mar 30 12:24:43 2004
-+++ python/tests/Makefile.in Tue Mar 30 12:25:47 2004
-@@ -190,7 +190,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
+--- python/tests/Makefile.in.orig 2008-05-23 23:11:10.000000000 -0500
++++ python/tests/Makefile.in 2008-05-23 23:11:33.000000000 -0500
+@@ -204,7 +204,7 @@
target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
-EXAMPLE_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)/examples
+EXAMPLE_DIR = $(datadir)/examples/py-libxslt
TESTSPY = \