aboutsummaryrefslogtreecommitdiff
path: root/textproc/link-grammar
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-05-22 08:24:33 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-05-22 08:24:33 +0000
commitfe3cd0525f2e14057c6a277b2bcb683d0e256d2f (patch)
tree800ac78bd2b7c834e3230098452c16ba36fa4549 /textproc/link-grammar
parent2d636e9a5f85260ebd11c411fbe79d9654138b07 (diff)
downloadports-fe3cd0525f2e14057c6a277b2bcb683d0e256d2f.tar.gz
ports-fe3cd0525f2e14057c6a277b2bcb683d0e256d2f.zip
Notes
Diffstat (limited to 'textproc/link-grammar')
-rw-r--r--textproc/link-grammar/Makefile38
-rw-r--r--textproc/link-grammar/distinfo2
-rw-r--r--textproc/link-grammar/pkg-descr7
-rw-r--r--textproc/link-grammar/pkg-plist98
4 files changed, 145 insertions, 0 deletions
diff --git a/textproc/link-grammar/Makefile b/textproc/link-grammar/Makefile
new file mode 100644
index 000000000000..771d8d7804f4
--- /dev/null
+++ b/textproc/link-grammar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: link-grammar
+# Date created: 22 May 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= link-grammar
+PORTVERSION= 4.1.1
+CATEGORIES= textproc
+MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A grammar checking library
+
+USE_GNOME= gnometarget
+USE_GMAKE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+
+DOCS= LICENSE README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/words/|/en/words/|g' \
+ ${WRKSRC}/data/en/4.0.dict
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/link-grammar/distinfo b/textproc/link-grammar/distinfo
new file mode 100644
index 000000000000..7137890d53d1
--- /dev/null
+++ b/textproc/link-grammar/distinfo
@@ -0,0 +1,2 @@
+MD5 (link-grammar-4.1.1.tar.gz) = c39f6ce4887e0737b70d4740680bce79
+SIZE (link-grammar-4.1.1.tar.gz) = 703878
diff --git a/textproc/link-grammar/pkg-descr b/textproc/link-grammar/pkg-descr
new file mode 100644
index 000000000000..a2bd91d66f5c
--- /dev/null
+++ b/textproc/link-grammar/pkg-descr
@@ -0,0 +1,7 @@
+The Link Grammar Parser is a syntactic parser of English, based on link
+grammar, an original theory of English syntax. Given a sentence, the system
+assigns to it a syntactic structure, which consists of a set of labeled links
+connecting pairs of words. The parser also produces a "constituent"
+representation of a sentence (showing noun phrases, verb phrases, etc.).
+
+WWW: http://www.link.cs.cmu.edu/link/
diff --git a/textproc/link-grammar/pkg-plist b/textproc/link-grammar/pkg-plist
new file mode 100644
index 000000000000..258d1204119e
--- /dev/null
+++ b/textproc/link-grammar/pkg-plist
@@ -0,0 +1,98 @@
+bin/grammar-parse
+include/link-grammar/analyze-linkage.h
+include/link-grammar/and.h
+include/link-grammar/api-structures.h
+include/link-grammar/api.h
+include/link-grammar/build-disjuncts.h
+include/link-grammar/constituents.h
+include/link-grammar/count.h
+include/link-grammar/error.h
+include/link-grammar/externs.h
+include/link-grammar/extract-links.h
+include/link-grammar/fast-match.h
+include/link-grammar/idiom.h
+include/link-grammar/link-includes.h
+include/link-grammar/linkset.h
+include/link-grammar/massage.h
+include/link-grammar/post-process.h
+include/link-grammar/pp_knowledge.h
+include/link-grammar/pp_lexer.h
+include/link-grammar/pp_linkset.h
+include/link-grammar/preparation.h
+include/link-grammar/print-util.h
+include/link-grammar/print.h
+include/link-grammar/prune.h
+include/link-grammar/read-dict.h
+include/link-grammar/resources.h
+include/link-grammar/string-set.h
+include/link-grammar/structures.h
+include/link-grammar/tokenize.h
+include/link-grammar/utilities.h
+include/link-grammar/word-file.h
+lib/liblink-grammar.a
+lib/liblink-grammar.so
+lib/liblink-grammar.so.5
+libdata/pkgconfig/link-grammar.pc
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/en/4.0.affix
+%%DATADIR%%/en/4.0.batch
+%%DATADIR%%/en/4.0.constituent-knowledge
+%%DATADIR%%/en/4.0.dict
+%%DATADIR%%/en/4.0.knowledge
+%%DATADIR%%/en/tiny.dict
+%%DATADIR%%/en/words/words.adj.1
+%%DATADIR%%/en/words/words.adj.2
+%%DATADIR%%/en/words/words.adj.3
+%%DATADIR%%/en/words/words.adv.1
+%%DATADIR%%/en/words/words.adv.2
+%%DATADIR%%/en/words/words.adv.3
+%%DATADIR%%/en/words/words.n.1
+%%DATADIR%%/en/words/words.n.2.s
+%%DATADIR%%/en/words/words.n.2.x
+%%DATADIR%%/en/words/words.n.3
+%%DATADIR%%/en/words/words.n.4
+%%DATADIR%%/en/words/words.n.c.1
+%%DATADIR%%/en/words/words.n.c.2
+%%DATADIR%%/en/words/words.n.p
+%%DATADIR%%/en/words/words.n.t
+%%DATADIR%%/en/words/words.s
+%%DATADIR%%/en/words/words.v.1.1
+%%DATADIR%%/en/words/words.v.1.2
+%%DATADIR%%/en/words/words.v.1.3
+%%DATADIR%%/en/words/words.v.1.4
+%%DATADIR%%/en/words/words.v.1.p
+%%DATADIR%%/en/words/words.v.10.1
+%%DATADIR%%/en/words/words.v.10.2
+%%DATADIR%%/en/words/words.v.10.3
+%%DATADIR%%/en/words/words.v.10.4
+%%DATADIR%%/en/words/words.v.2.1
+%%DATADIR%%/en/words/words.v.2.2
+%%DATADIR%%/en/words/words.v.2.3
+%%DATADIR%%/en/words/words.v.2.4
+%%DATADIR%%/en/words/words.v.2.5
+%%DATADIR%%/en/words/words.v.4.1
+%%DATADIR%%/en/words/words.v.4.2
+%%DATADIR%%/en/words/words.v.4.3
+%%DATADIR%%/en/words/words.v.4.4
+%%DATADIR%%/en/words/words.v.4.5
+%%DATADIR%%/en/words/words.v.5.1
+%%DATADIR%%/en/words/words.v.5.2
+%%DATADIR%%/en/words/words.v.5.3
+%%DATADIR%%/en/words/words.v.5.4
+%%DATADIR%%/en/words/words.v.6.1
+%%DATADIR%%/en/words/words.v.6.2
+%%DATADIR%%/en/words/words.v.6.3
+%%DATADIR%%/en/words/words.v.6.4
+%%DATADIR%%/en/words/words.v.6.5
+%%DATADIR%%/en/words/words.v.8.1
+%%DATADIR%%/en/words/words.v.8.2
+%%DATADIR%%/en/words/words.v.8.3
+%%DATADIR%%/en/words/words.v.8.4
+%%DATADIR%%/en/words/words.v.8.5
+%%DATADIR%%/en/words/words.y
+@dirrm %%DATADIR%%/en/words
+@dirrm %%DATADIR%%/en
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/link-grammar