aboutsummaryrefslogtreecommitdiff
path: root/textproc/linux-f10-expat/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
commit824eda00fccb57b36978b562ecfc6572fa5de766 (patch)
treedddb20be9539275c41e943b4763c0b29ba61151d /textproc/linux-f10-expat/Makefile
parent8217c4dd1dea5cbe146907f97afb3e458208ec77 (diff)
downloadports-824eda00fccb57b36978b562ecfc6572fa5de766.tar.gz
ports-824eda00fccb57b36978b562ecfc6572fa5de766.zip
Notes
Diffstat (limited to 'textproc/linux-f10-expat/Makefile')
-rw-r--r--textproc/linux-f10-expat/Makefile28
1 files changed, 17 insertions, 11 deletions
diff --git a/textproc/linux-f10-expat/Makefile b/textproc/linux-f10-expat/Makefile
index e5c55dc2ac43..d14588dad4eb 100644
--- a/textproc/linux-f10-expat/Makefile
+++ b/textproc/linux-f10-expat/Makefile
@@ -1,24 +1,30 @@
-# New ports collection makefile for: linux-expat
-# Date created: 2003-07-05
-# Whom: trevor
+# New ports collection makefile for: textproc/linux-f8-expat
+# Date created: 2008-03-28
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= expat
-PORTVERSION= 1.95.8
+PORTVERSION= 2.0.1
CATEGORIES= textproc linux
-DISTNAME= ${PORTNAME}-${PORTVERSION}-6
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= freebsd-emulation@FreeBSD.org
-COMMENT= Linux/i386 binary port of Expat XML-parsing library
+COMMENT= Linux/i386 binary port of Expat XML-parsing library (Linux Fedora 8)
-BRANDELF_DIRS= usr/bin
-
-USE_LINUX_RPM= yes
-LINUX_DIST_VER= 4
ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 8
+RPMVERSION= 2
+BRANDELF_FILES= usr/bin/xmlwf
USE_LDCONFIG= yes
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+PLIST_FILES= lib/libexpat.so.1 lib/libexpat.so.1.5.2 \
+ usr/bin/xmlwf usr/share/man/man1/xmlwf.1.gz
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= COPYING README
+DESCR= ${.CURDIR}/../${PORTNAME}2/pkg-descr
.include <bsd.port.mk>