aboutsummaryrefslogtreecommitdiff
path: root/textproc/luceneplusplus
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2014-12-03 13:59:41 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2014-12-03 13:59:41 +0000
commitc52b37244e22971c268ee2fc30c791763ed29a84 (patch)
tree940ca6b2b9c5a90e3d0d38bc0525d4895c3361cc /textproc/luceneplusplus
parent560d730a5e9ff97c43d26b5715869473c42f660b (diff)
downloadports-c52b37244e22971c268ee2fc30c791763ed29a84.tar.gz
ports-c52b37244e22971c268ee2fc30c791763ed29a84.zip
Notes
Diffstat (limited to 'textproc/luceneplusplus')
-rw-r--r--textproc/luceneplusplus/Makefile2
-rw-r--r--textproc/luceneplusplus/files/patch-CMakeLists.txt24
2 files changed, 20 insertions, 6 deletions
diff --git a/textproc/luceneplusplus/Makefile b/textproc/luceneplusplus/Makefile
index 149191ad8867..1d6b3f91e79d 100644
--- a/textproc/luceneplusplus/Makefile
+++ b/textproc/luceneplusplus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= lucene++
PORTVERSION= 3.0.6
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= arved@FreeBSD.org
@@ -10,7 +11,6 @@ COMMENT= C++ port of the Lucene library
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LGPL.license
-BUILD_DEPENDS= svn:${PORTSDIR}/devel/subversion
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
diff --git a/textproc/luceneplusplus/files/patch-CMakeLists.txt b/textproc/luceneplusplus/files/patch-CMakeLists.txt
index b5a025244bc2..d91bbd96aa3e 100644
--- a/textproc/luceneplusplus/files/patch-CMakeLists.txt
+++ b/textproc/luceneplusplus/files/patch-CMakeLists.txt
@@ -1,14 +1,28 @@
---- CMakeLists.txt.orig 2014-11-29 23:14:14.000000000 +0100
-+++ CMakeLists.txt 2014-11-29 23:23:52.000000000 +0100
-@@ -118,7 +118,6 @@
+--- CMakeLists.txt.orig 2014-04-19 20:26:40.000000000 +0200
++++ CMakeLists.txt 2014-12-03 14:38:24.000000000 +0100
+@@ -49,7 +49,6 @@
+ # bootstrap
+ ####################################
+
+-find_package(Subversion REQUIRED)
+ find_package(Threads REQUIRED)
+ find_package(Boost COMPONENTS
+ date_time
+@@ -113,13 +112,10 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/include
+ )
+
+-include(CMakeExternal.txt)
+ enable_testing()
add_subdirectory(src/core)
add_subdirectory(src/contrib)
-add_subdirectory(src/demo)
- add_subdirectory(src/test)
+-add_subdirectory(src/test)
#################################
-@@ -135,7 +134,7 @@
+ # install pkg-config file
+@@ -135,7 +131,7 @@
FILES
${CMAKE_CURRENT_BINARY_DIR}/liblucene++.pc
${CMAKE_CURRENT_BINARY_DIR}/liblucene++-contrib.pc