aboutsummaryrefslogtreecommitdiff
path: root/textproc/makefaq
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-08 13:14:48 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-08 13:14:48 +0000
commitacdef9246a4e0f3ad82e4964ffef12f58c2b2bd1 (patch)
tree896ba5ba83cd86b9afdcb5bc94944cf97691a5d1 /textproc/makefaq
parentef4f5b9ff34d1f715462d14102c925a6fac3f3ef (diff)
downloadports-acdef9246a4e0f3ad82e4964ffef12f58c2b2bd1.tar.gz
ports-acdef9246a4e0f3ad82e4964ffef12f58c2b2bd1.zip
Add makefaq 2.4, makefaq is a Python program that creates a
(FAQ) list from a specially formatted text data file. For output, it can can generate either an HTML page, a text file, or a DocBook XML file. PR: 57694 Submitted by: king@v2project.com
Notes
Notes: svn path=/head/; revision=90636
Diffstat (limited to 'textproc/makefaq')
-rw-r--r--textproc/makefaq/Makefile36
-rw-r--r--textproc/makefaq/distinfo1
-rw-r--r--textproc/makefaq/pkg-descr5
-rw-r--r--textproc/makefaq/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/makefaq/Makefile b/textproc/makefaq/Makefile
new file mode 100644
index 000000000000..a9caa30bcf50
--- /dev/null
+++ b/textproc/makefaq/Makefile
@@ -0,0 +1,36 @@
+# Ports collection makefile for: makefaq
+# Date created: Sat Aug 23 07:15:39 CEST 2003
+# Whom: king@v2project.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= makefaq
+PORTVERSION= 2.4
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= king@v2project.com
+COMMENT= Makefaq is a Python program that creates a (FAQ)
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+NO_BUILD= yes
+
+MAN1= makefaq.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/makefaq.py ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/makefaq.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README UPGRADING faq.html
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/makefaq/distinfo b/textproc/makefaq/distinfo
new file mode 100644
index 000000000000..61bebd07e71f
--- /dev/null
+++ b/textproc/makefaq/distinfo
@@ -0,0 +1 @@
+MD5 (makefaq-2.4.tgz) = 6f145f79f869e744b9313b2b8a5c2a74
diff --git a/textproc/makefaq/pkg-descr b/textproc/makefaq/pkg-descr
new file mode 100644
index 000000000000..64da91920035
--- /dev/null
+++ b/textproc/makefaq/pkg-descr
@@ -0,0 +1,5 @@
+makefaq is a Python program that creates a Frequently Asked Questions (FAQ)
+list from a specially formatted text data file. For output, it can can
+generate either an HTML page, a text file, or a DocBook XML file.
+
+WWW: http://www.makefaq.org
diff --git a/textproc/makefaq/pkg-plist b/textproc/makefaq/pkg-plist
new file mode 100644
index 000000000000..7ed9c1793caf
--- /dev/null
+++ b/textproc/makefaq/pkg-plist
@@ -0,0 +1,5 @@
+bin/makefaq.py
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%