aboutsummaryrefslogtreecommitdiff
path: root/textproc/minify
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-22 23:59:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-22 23:59:22 +0000
commit3bd214e5a2f389637157b7a632994944fa4c9c9d (patch)
treede0885eacc981b2ce9e9655c8d0df3e4a8521b74 /textproc/minify
parent0b5b59b97e37d58829e0ddc482f8894d7100b7dd (diff)
downloadports-3bd214e5a2f389637157b7a632994944fa4c9c9d.tar.gz
ports-3bd214e5a2f389637157b7a632994944fa4c9c9d.zip
Add minify 2.3.8
Minify is a minifier package written in Go. It provides HTML5, CSS3, JS, JSON, SVG and XML minifiers and an interface to implement any other minifier. Minification is the process of removing bytes from a file (such as whitespace) without changing its output and therefore shrinking its size and speeding up transmission over the internet and possibly parsing. The implemented minifiers are designed for high performance. The core functionality associates mimetypes with minification functions, allowing embedded resources (like CSS or JS within HTML files) to be minified as well. Users can add new implementations that are triggered based on a mimetype (or pattern), or redirect to an external command (like ClosureCompiler, UglifyCSS, ...). WWW: https://github.com/tdewolff/minify
Notes
Notes: svn path=/head/; revision=490993
Diffstat (limited to 'textproc/minify')
-rw-r--r--textproc/minify/Makefile34
-rw-r--r--textproc/minify/distinfo15
-rw-r--r--textproc/minify/pkg-descr14
3 files changed, 63 insertions, 0 deletions
diff --git a/textproc/minify/Makefile b/textproc/minify/Makefile
new file mode 100644
index 000000000000..c9f2bc5fb19a
--- /dev/null
+++ b/textproc/minify/Makefile
@@ -0,0 +1,34 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= minify
+PORTVERSION= 2.3.8
+DISTVERSIONPREFIX= v
+CATEGORIES= textproc www
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Go minifiers for web formats
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= go
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+GO_TARGET= ${GO_PKGNAME}/cmd/${GH_PROJECT}
+
+PLIST_FILES= bin/minify
+
+GH_ACCOUNT= tdewolff
+GH_TUPLE= dustin:go-humanize:v1.0.0:dustin_go_humanize/../src/github.com/dustin/go-humanize \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/../src/github.com/fsnotify/fsnotify \
+ golang:sys:770c602:golang_sys/../src/golang.org/x/sys \
+ matryer:try:v1:matryer_try/../src/github.com/matryer/try \
+ spf13:pflag:v1.0.3:spf13_pflag/../src/github.com/spf13/pflag \
+ tdewolff:parse:v2.3.5:tdewolff_parse/../src/github.com/tdewolff/parse
+USE_GITHUB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${GO_WRKDIR_BIN}/minify ${STAGEDIR}${PREFIX}/bin/minify
+
+.include <bsd.port.mk>
diff --git a/textproc/minify/distinfo b/textproc/minify/distinfo
new file mode 100644
index 000000000000..a4f3bd08a8b9
--- /dev/null
+++ b/textproc/minify/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1548102446
+SHA256 (tdewolff-minify-v2.3.8_GH0.tar.gz) = b767118737eda7c2aade905d2fdeaf78d707a8cd202a0624b24dd477091ba669
+SIZE (tdewolff-minify-v2.3.8_GH0.tar.gz) = 2125614
+SHA256 (dustin-go-humanize-v1.0.0_GH0.tar.gz) = e4540bd50ac855143b4f2e509313079c50cf5d8774f09cc10dbca5ae9803d8ba
+SIZE (dustin-go-humanize-v1.0.0_GH0.tar.gz) = 17260
+SHA256 (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = b7530d973d0ab0e58ad8ce1b9a4b963d6f57b3d72f2f9e13d49846976361b1cd
+SIZE (fsnotify-fsnotify-v1.4.7_GH0.tar.gz) = 31139
+SHA256 (golang-sys-770c602_GH0.tar.gz) = 7886385551f7097416028f612a9f2994d6aa9c9c913ef7ca949a030cce6909e2
+SIZE (golang-sys-770c602_GH0.tar.gz) = 1238669
+SHA256 (matryer-try-v1_GH0.tar.gz) = a01c6644fc2e1403a4489306a4fbca52dd3b2e1b6374e6a2f86f57fd430104be
+SIZE (matryer-try-v1_GH0.tar.gz) = 2924
+SHA256 (spf13-pflag-v1.0.3_GH0.tar.gz) = 9e57f86f493f04d9077fccd04e7139ebf243dd544e917ab83d35729b3e54a124
+SIZE (spf13-pflag-v1.0.3_GH0.tar.gz) = 46002
+SHA256 (tdewolff-parse-v2.3.5_GH0.tar.gz) = e7d691607f6f53336af7c03a92ba24b78c709513b31a31e719620d4d2d07d813
+SIZE (tdewolff-parse-v2.3.5_GH0.tar.gz) = 75027
diff --git a/textproc/minify/pkg-descr b/textproc/minify/pkg-descr
new file mode 100644
index 000000000000..9d200c1f7322
--- /dev/null
+++ b/textproc/minify/pkg-descr
@@ -0,0 +1,14 @@
+Minify is a minifier package written in Go. It provides HTML5, CSS3, JS, JSON,
+SVG and XML minifiers and an interface to implement any other minifier.
+Minification is the process of removing bytes from a file (such as whitespace)
+without changing its output and therefore shrinking its size and speeding up
+transmission over the internet and possibly parsing. The implemented minifiers
+are designed for high performance.
+
+The core functionality associates mimetypes with minification functions,
+allowing embedded resources (like CSS or JS within HTML files) to be minified as
+well. Users can add new implementations that are triggered based on a mimetype
+(or pattern), or redirect to an external command (like ClosureCompiler,
+UglifyCSS, ...).
+
+WWW: https://github.com/tdewolff/minify