aboutsummaryrefslogtreecommitdiff
path: root/textproc/msort
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-11 08:18:00 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-11 08:18:00 +0000
commit647f97515d6b993c7d55af4626bdd0e8061b5cf9 (patch)
treeadb204686e33f40590fe2971e6fa3fe2c39b19c5 /textproc/msort
parentb6ae9fd0126ff75286190d3f3a09e5b714d680f7 (diff)
downloadports-647f97515d6b993c7d55af4626bdd0e8061b5cf9.tar.gz
ports-647f97515d6b993c7d55af4626bdd0e8061b5cf9.zip
Add msort 8.27, sorting files in sophisticated ways.
PR: ports/101777 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=170333
Diffstat (limited to 'textproc/msort')
-rw-r--r--textproc/msort/Makefile32
-rw-r--r--textproc/msort/distinfo3
-rw-r--r--textproc/msort/pkg-descr13
3 files changed, 48 insertions, 0 deletions
diff --git a/textproc/msort/Makefile b/textproc/msort/Makefile
new file mode 100644
index 000000000000..ee489d1ebb57
--- /dev/null
+++ b/textproc/msort/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: msort
+# Date created: 2006-08-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msort
+PORTVERSION= 8.27
+CATEGORIES= textproc
+MASTER_SITES= http://billposer.org/Software/Downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Sorting files in sophisticated ways
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre
+RUN_DEPENDS= iwidgets>=0:${PORTSDIR}/x11-toolkits/iwidgets
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+USE_TK= yes
+
+PLIST_FILES= bin/msg bin/msort
+
+MAN1= msort.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,^#include <alloca.h>,,g' ${WRKSRC}/msort.c
+
+.include <bsd.port.mk>
diff --git a/textproc/msort/distinfo b/textproc/msort/distinfo
new file mode 100644
index 000000000000..d4d618ee5190
--- /dev/null
+++ b/textproc/msort/distinfo
@@ -0,0 +1,3 @@
+MD5 (msort-8.27.tgz) = d87aecfd6ac90cbfd9c1e6911152e7bd
+SHA256 (msort-8.27.tgz) = 4d7dcb4822ab058ae301c0e78535b55a299efe6d8d699666072678a04fd03759
+SIZE (msort-8.27.tgz) = 360253
diff --git a/textproc/msort/pkg-descr b/textproc/msort/pkg-descr
new file mode 100644
index 000000000000..bff865c33a4c
--- /dev/null
+++ b/textproc/msort/pkg-descr
@@ -0,0 +1,13 @@
+Msort sorts files in sophisticated ways. Records may be fixed size,
+newline-separated blocks, or terminated by any specified character.
+Key fields may be selected by position, tag, or character range. For
+each key, distinct exclusions, multigraphs, substitutions, and a sort
+order may be defined or locale collation rules used. Comparisons may
+be lexicographic, numeric, numeric string, hybrid, random, by string
+length, angle, date, time, month name, or ISO8601 timestamp. Keys may
+be reversed so as to generate reverse dictionaries. Optional keys are
+supported. Unicode is supported, including full case-folding. Msort
+itself has a somewhat complex command line interface, but may be
+driven by an optional GUI.
+
+WWW: http://billposer.org/Software/msort.html