aboutsummaryrefslogtreecommitdiff
path: root/textproc/msort
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-22 11:36:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-22 11:36:22 +0000
commite624cceb93fb45b45e9ce439ea6d7ab03af3f0b7 (patch)
tree7b8082a4046cbd29dc8bb3835f5d36e52a858d4b /textproc/msort
parent28bc2f278b3c811756ab585e75590cbca26d7b8a (diff)
downloadports-e624cceb93fb45b45e9ce439ea6d7ab03af3f0b7.tar.gz
ports-e624cceb93fb45b45e9ce439ea6d7ab03af3f0b7.zip
- Chase libtre shlib bump
Notes
Notes: svn path=/head/; revision=246443
Diffstat (limited to 'textproc/msort')
-rw-r--r--textproc/msort/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/textproc/msort/Makefile b/textproc/msort/Makefile
index 53fbf9f246dd..2318632574b9 100644
--- a/textproc/msort/Makefile
+++ b/textproc/msort/Makefile
@@ -7,7 +7,7 @@
PORTNAME= msort
PORTVERSION= 8.52
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://billposer.org/Software/Downloads/
@@ -19,7 +19,8 @@ LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre \
utf8proc:${PORTSDIR}/textproc/utf8proc
RUN_DEPENDS= iwidgets>=0:${PORTSDIR}/x11-toolkits/iwidgets
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include" \
+ ac_cv_lib_tre_regwcomp=yes
MAKE_ENV+= INCLUDES="-I${LOCALBASE}/include"
GNU_CONFIGURE= yes
USE_TK_RUN= yes
@@ -30,4 +31,17 @@ PLIST_FILES= bin/msg bin/msort
MAN1= msort.1
+.ifdef(MAINTAINER_MODE)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|bash|${LOCALBASE}/bin/bash|g" ${WRKSRC}/RegressionTests/Makefile
+ ${REINPLACE_CMD} -e "s|msort|../&|g" ${WRKSRC}/RegressionTests/RunTests.sh \
+ ${WRKSRC}/RegressionTests/RunLocaleTests.sh
+
+test: build
+ @(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test)
+
+.endif
+
.include <bsd.port.mk>